1. xzb6np's Avatar
    I have been having a problem with the last couple insider builds as well as the production builds. My 95 be working fine and then decided to stop charging. Example I am at 53% right now. I plug it in to charge and it charges about 1% and then the indicator jumps to 100% and it stops charging. I had done soft boots, hard resets, etc. Went back to .318, etc. It started doing it again yesterday running the 342. Then we got that patch last night and it was fine all day today until tonight and it's doing it again.

    Could I have a bad battery?
    05-19-2016 08:16 PM
  2. Chintan Gohel's Avatar
    I have been having a problem with the last couple insider builds as well as the production builds. My 95 be working fine and then decided to stop charging. Example I am at 53% right now. I plug it in to charge and it charges about 1% and then the indicator jumps to 100% and it stops charging. I had done soft boots, hard resets, etc. Went back to .318, etc. It started doing it again yesterday running the 342. Then we got that patch last night and it was fine all day today until tonight and it's doing it again.

    Could I have a bad battery?
    wouldn't hurt to take it to a service centre. Maybe bad battery or charging port. But perhaps you can stick with official build after the service
    05-20-2016 12:07 AM
  3. BikeMrown's Avatar
    I had this happen to my 950 back in April. I have 3 950's so did various battery swaps, cable swaps, and even did OS release changes. It was something internal to the phone hardware, not the battery. AT&T replaced it no problem.
    05-20-2016 10:33 AM
  4. Robert Novak1's Avatar
    will it charge on a matt?
    05-20-2016 04:53 PM
  5. xzb6np's Avatar
    It just happened again today. I was videoing my daughter running in a track meet and after 6 minutes I got a message on the phone that the phone was too hot and it had to stop recording which it did. So I put it down for a while. I later picked it up to send a text and as I was typing the text it went dead. I pressed the button and it just rebooted over and over never getting past the Windows logo. So I put it in the car and plugged it in for a couple hours. When I got back in it was up and running again. It seems like it dies if the batter gets down around 50%. I am going to call ATT.
    Chintan Gohel likes this.
    05-20-2016 07:53 PM
  6. xzb6np's Avatar
    ATT is sending me another 950!

    Originally posted by xzb6np
    It just happened again today. I was videoing my daughter running in a track meet and after 6 minutes I got a message on the phone that the phone was too hot and it had to stop recording which it did. So I put it down for a while. I later picked it up to send a text and as I was typing the text it went dead. I pressed the button and it just rebooted over and over never getting past the Windows logo. So I put it in the car and plugged it in for a couple hours. When I got back in it was up and running again. It seems like it dies if the batter gets down around 50%. I am going to call ATT.
    Chintan Gohel and TgeekB like this.
    05-20-2016 11:09 PM

Similar Threads

  1. Quick Charger replacement for L 950
    By cheesemoo in forum Microsoft Lumia 950
    Replies: 11
    Last Post: 07-14-2016, 07:16 AM
  2. Spare Battery For Lumia 950 XL
    By Vociferous in forum Microsoft Lumia 950 XL
    Replies: 3
    Last Post: 06-03-2016, 09:40 AM
  3. Replies: 7
    Last Post: 05-22-2016, 01:00 PM
  4. Replies: 2
    Last Post: 05-19-2016, 04:22 PM
  5. Replies: 2
    Last Post: 05-19-2016, 08:56 AM
LINK TO POST COPIED TO CLIPBOARD