1. Keith Rowe's Avatar
    Hi there. Anyone else getting bad cellphone reception with your Nokia 950? I am on the AT&T network and used to be the go to guy when we would take remote bicycle rides and nobody else could get a signal. I always had two bars on my Nokia 1520 deep into the woods. And my battery life was phenomenal. Three days at first but then down to two days on one charge and moderate use.

    I really like my 950 but the battery cannot make it through the day and those two bars quickly become zero as I go out the same bike path. Further, in my home I used to get 4 or 5 bars on my 1520 and now its 2 or 3.

    I have tried with and without my GhostTek case. It does have some metal but it does not seem to be a factor. Please advise on both dilemmas.

    I have one more week to decide if I will take this phone back or not. It is not of any use to me half of the time.
    07-29-2016 04:48 PM
  2. Keith Rowe's Avatar
    Update: I just got off of the phone with AT&T support. Excellent understanding of my problems. The 950 has 3000 mAh while my old 1520 has 3400 mAh. That explains some of the battery life issues.

    I am really happy about the solution for the lousy reception in rural hours. By default, Windows 10 sets the SIM settings of "Enhanced 4G lTE Services" to On. He had me turn it off. I could barely tell a difference between the audio quality of my calls and I jumped back to five bars. My older 1520 did not have that feature so it would connect with stronger signals on more towers. I cannot wait to check out my reception out in the country at the same spots and to post back. You city folks won't really have a problem here and I probably won't when I am downtown, but when I am out in the sticks it matters. I want a cell signal for 911 purposes, etc.
    xandros9, Mach_E and JohnStrk like this.
    07-29-2016 05:51 PM
  3. gordonfink's Avatar
    Have you had any software updates of late? Mine was doing that, and the mic was fuzzy (callers complained to me about the mic quality, though I heard them fine). For now at least, hard reset seems to have done the trick. I have about a week on an open warranty ticket, so we'll see.
    07-29-2016 08:27 PM
  4. Matt Sharp's Avatar
    Update: I just got off of the phone with AT&T support. Excellent understanding of my problems. The 950 has 3000 mAh while my old 1520 has 3400 mAh. That explains some of the battery life issues.

    I am really happy about the solution for the lousy reception in rural hours. By default, Windows 10 sets the SIM settings of "Enhanced 4G lTE Services" to On. He had me turn it off. I could barely tell a difference between the audio quality of my calls and I jumped back to five bars. My older 1520 did not have that feature so it would connect with stronger signals on more towers. I cannot wait to check out my reception out in the country at the same spots and to post back. You city folks won't really have a problem here and I probably won't when I am downtown, but when I am out in the sticks it matters. I want a cell signal for 911 purposes, etc.
    I cannot find this setting, any guidance? My wireless reception on 950 is poor compared to my 830.
    08-10-2016 05:16 PM
  5. smchambers56's Avatar
    I cannot find this setting, any guidance? My wireless reception on 950 is poor compared to my 830.
    Settings>Networks & Wireless>Cellular & Sim>Sim Settings
    08-10-2016 06:51 PM
  6. jtzako's Avatar
    I usually find that my phone has a better signal that my friends' phones do. Though call quality is often not good even with full bars.
    08-16-2016 02:14 PM
  7. Rene Braun's Avatar
    I am on US T-Mobile. I am getting worse reception with 950XL than I used to get with 925. What is worse is that the phone seems to take a long time to readjust once I get into a good reception location ... sometimes not at all. Consequently I miss text messages and phone calls. The current status quo is that I drop off the contact completely while I sit at work ... the only help is wi-fi at work and email.

    @smchambers56 - (Settings>Networks & Wireless>Cellular & Sim>Sim Settings )? I have Settings>Networks & Wireless>Cellular&SIM>Sim1 Settings

    On that screen I have a choice of Cellular network Highest connection speed (set to LTE) - I don't see anywhere a choice to select or deselect "Enhanced 4G lTE Services"

    Thoughts?
    08-17-2016 07:51 AM

Similar Threads

  1. Nokia 635 No Longer Getting 10586 Updates
    By gamo62 in forum Nokia Lumia 635
    Replies: 12
    Last Post: 08-24-2016, 07:39 PM
  2. Headphones for Lumia?
    By BataBole in forum Ask a Question
    Replies: 9
    Last Post: 08-15-2016, 07:48 AM
  3. Problems with Windows 10
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 08-14-2016, 05:03 PM
  4. Replies: 1
    Last Post: 08-11-2016, 04:59 PM
  5. Change with build 14393.67
    By Jsypher in forum Ask a Question
    Replies: 0
    Last Post: 08-10-2016, 02:09 PM
LINK TO POST COPIED TO CLIPBOARD