1. Jopl's Avatar
    Has anybody else had luck successfully using their lumia 950 to navigate while connected to a bluetooth device? Everytime I try to do this my application freezes. I believe it has something to do with Cortana not handling the exchange properly. Anyhow, the screen stays at "Here we go".. it never updates or changes. Also, it stops tracking my location. I usually have to hard reset the phone, or at least shut off bluetooth (if it doesn't freeze the phone while trying this) and also try to close the maps program.
    I want to know if maybe my device sucks or not.
    I have about had it with this device. I have been on Windows mobile for about 3 years now (2 years with lumia 928, and now a year with 950). The map issue has been happening since maybe january/february. I don't even remember it ever really working to be honest. I could deal with the app gap, which is a real thing (despite what "they" keep saying). Every update and/or firmware update I am hopeful that the maps will be fixed, but I am always disappointed. I have submitted feedback, so I know I am not alone. Anyhow... I am pretty frustrated here and maybe somebody has a few tricks I can try?
    Thanks!
    wolfpak54 likes this.
    09-27-2016 08:57 PM
  2. ashram's Avatar
    I haven't had the issue, but I also rarely use turn by turn directions.when I have used it, it worked though.
    09-28-2016 02:28 AM
  3. Jopl's Avatar
    I would be greatly appreciative of anybody who tries this today/tomorrow and posts their results.
    1. make sure you are connected via bluetooth to something (car, or handsfree device)
    2. Launch maps and get directions.
    3. Observe what happens. Does it stay on "Here we go"? Does it work perfectly?

    Thanks!
    09-28-2016 08:52 AM
  4. Long Syntax's Avatar
    Seems to work fine for me. AT&T, up to date, connected to BT on a 2012 Honda CRV. No freezing of maps app and I get voice directions. Sorry to hear it's not working well for you. Usual advice would be a hard reset or wdrt.
    09-28-2016 10:22 AM
  5. gordonfink's Avatar
    Mine is not an ATT variant, but I was doing it all weekend. Phone was connected to car via BT, and I was getting directions and navigating by phone, because I haven't yet learned how to use the ginormous Nav screen in the car.
    libra89 likes this.
    09-28-2016 11:22 AM
  6. Jopl's Avatar
    I have had this phone for a while. I have reinstalled everything from scratch (several times). I am going to call ATT and see about getting a replacement.
    09-28-2016 02:34 PM
  7. Albatross2's Avatar
    I have the non-ATT 950 DS, but running on the ATT network. No issues for me with nav and bluetooth. I think a replacement is in order for you.
    09-29-2016 10:30 AM
  8. Jopl's Avatar
    Replacement has been ordered. I will post a follow up once I receive it and test it out.
    gordonfink likes this.
    09-29-2016 10:29 PM
  9. Jopl's Avatar
    I tried the replacement phone. Still failing to work properly. They gave me the option of using a Go phone for a few weeks while I send the phone in to be repaired. I am going to take it to the Microsoft store instead.
    10-06-2016 09:56 PM
  10. rusty502's Avatar
    AT&T 950 here.....use maps and navigation daily through Bluetooth in truck.....never had any issues....

    Sent from mTalk
    10-06-2016 11:49 PM
  11. wolfpak54's Avatar
    Has anybody else had luck successfully using their lumia 950 to navigate while connected to a bluetooth device? Everytime I try to do this my application freezes. I believe it has something to do with Cortana not handling the exchange properly. Anyhow, the screen stays at "Here we go".. it never updates or changes. Also, it stops tracking my location. I usually have to hard reset the phone, or at least shut off bluetooth (if it doesn't freeze the phone while trying this) and also try to close the maps program.
    I want to know if maybe my device sucks or not.
    I have about had it with this device. I have been on Windows mobile for about 3 years now (2 years with lumia 928, and now a year with 950). The map issue has been happening since maybe january/february. I don't even remember it ever really working to be honest. I could deal with the app gap, which is a real thing (despite what "they" keep saying). Every update and/or firmware update I am hopeful that the maps will be fixed, but I am always disappointed. I have submitted feedback, so I know I am not alone. Anyhow... I am pretty frustrated here and maybe somebody has a few tricks I can try?
    Thanks!
    Not alone, my ATT 950 does the same thing, I know this is an old thread, but if you ever found a fix i'd like to know.
    02-27-2017 06:43 PM

Similar Threads

  1. Driver error on Windows 10 PC when connect my Lumia 640
    By Leonidas Figueroa in forum Microsoft Lumia 640
    Replies: 13
    Last Post: 06-14-2017, 05:27 AM
  2. Microsoft Lumia 535 Exclamation mark on boot up attempt
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 10-02-2016, 04:41 AM
  3. Downgrade unlocked AT&T 640 from 10 to 8.1
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 10-02-2016, 04:38 AM
  4. Predictive text has vanished from my Lumia 735
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 09-28-2016, 03:01 AM
  5. Call of Duty: World at War among the latest Xbox One backwards compatible games
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-27-2016, 12:42 PM
LINK TO POST COPIED TO CLIPBOARD