1. Theo Kapaa's Avatar
    Hi I recently bought a Lumia 950 and it's awesome but I did an update that took to long to finish and when my phone started up I notice a purple tint on the display. Especially on the settings app .All the other colors look fine and if i put the brightness to max than it dissapears.What can I do to fix it I think something went wrong with the firmware how can I fix it.
    Pls help.
    05-16-2017 05:19 AM
  2. Indistinguishable's Avatar
    Hi I recently bought a Lumia 950 and it's awesome but I did an update that took to long to finish and when my phone started up I notice a purple tint on the display. Especially on the settings app .All the other colors look fine and if i put the brightness to max than it dissapears.What can I do to fix it I think something went wrong with the firmware how can I fix it.
    Pls help.
    Hi there -

    Sometimes a simple soft reset can fix things like this. To do a soft reset, simply hold down the power button until the device vibrates and restarts itself.

    Let me know if that doesn't fix the issue!
    libra89 and Theo Kapaa like this.
    05-16-2017 08:39 AM
  3. Theo Kapaa's Avatar
    Thank you for your advice but that didn't fix it.
    What else can I do?
    05-18-2017 07:04 AM
  4. Theo Kapaa's Avatar
    Is it a firmware problem?
    05-21-2017 11:52 AM
  5. xandros9's Avatar
    Is it a firmware problem?
    Quite possibly, could also be hardware but I'm thinking maybe using Color Profile in Settings > Extras > Display may help?

    If that doesn't help, which I suspect it may not if max brightness solves it, I would erase the phone with the Windows Device Recovery Tool and go from there to rule out firmware/software.
    Theo Kapaa likes this.
    05-21-2017 02:41 PM
  6. Theo Kapaa's Avatar
    I did it with windows device recovery tool but it only reinstal the software and not the firmware how can I reinstal the firmware
    Thank you by the way.
    05-22-2017 02:22 AM

Similar Threads

  1. How and When to switch from my Lumia 830?
    By Rainar Angelo in forum Windows 10 Mobile
    Replies: 16
    Last Post: 05-18-2017, 08:49 PM
  2. Lumia 520 not detecting network
    By Ronald Pfidze in forum Nokia Lumia 520
    Replies: 0
    Last Post: 05-15-2017, 02:58 PM
  3. Cannot download pictures from Lumia 650
    By eightyplus in forum Microsoft Lumia 650
    Replies: 0
    Last Post: 05-15-2017, 10:26 AM
  4. HELP - Need Lumia 730 Back panel replacement with NFC - INDIA
    By Sugadevan Rajarathinam in forum Nokia Lumia 730 & 735
    Replies: 0
    Last Post: 05-15-2017, 07:47 AM
LINK TO POST COPIED TO CLIPBOARD