1. rabit1's Avatar
    Hi,

    Is it just me or does anyone here experience the same error with windowsphone.com?

    I always get this error message when clicking on certain links such as: "Find My Phone", "Account" links. I have been trying this ever since the new windowsphone.com webpage.

    -----------------------------------------------------------------
    Oops...

    Something went wrong and we can't show you this page right now.
    Go to windowsphone.com
    -----------------------------------------------------------------

    Other links such as skydrive documents, and photos seems to be OK.

    I also get the same error going to devices.live.com and clicking on
    "Change Windows Phone 7 settings"


    Any clue?
    10-05-2011 01:24 AM
  2. TheWeeBear's Avatar
    Can't find the post rabit1, but i remember somone else getting that with IE, try another browser and see if it's any different. It worked for them. (Don't know why) :)
    10-05-2011 02:32 AM
  3. rabit1's Avatar
    Can't find the post rabit1, but i remember somone else getting that with IE, try another browser and see if it's any different. It worked for them. (Don't know why) :)
    I tried IE8, and I also tried latest FireFox. Still got the same error.

    Seems like very few has this problem.. I have ticked both option on my HD7, and it's now say connected on my HD7. But still, clicking Find My Phone, or Ring Lock or Erase, and also Account links on windowsphone.com give me the "Oooops...." error.

    Really appreciate anyone who can help me...
    10-06-2011 04:38 AM
  4. wbeckle's Avatar
    Was this ever solved?
    10-21-2011 12:53 PM
  5. rabit1's Avatar
    Unfortunately No. Just tried again today. Same problem. Help

    Sent from my HD7 T9292 using Board Express
    10-22-2011 11:13 AM
  6. nasal's Avatar
    Try changing the region you are browsing when logged in in the upper right corner, it worked for me, I had United States but my account is 'registered' in the UK. When I switched to the UK it worked fine!
    10-23-2011 07:30 AM
  7. rabit1's Avatar
    Try changing the region you are browsing when logged in in the upper right corner, it worked for me, I had United States but my account is 'registered' in the UK. When I switched to the UK it worked fine!
    Doesn't work for me.. Thanks anyway..

    Here I am at a PC in a computer Station at Mount Elizabeth Hospital. Using IE8.

    I have set my phone regional setting to Singapore
    Changed the country setting windowsphone.com on my web browser top right corner to Singapore.

    Did I miss anything?

    then click the Account link.. still got the same thing..
    Click My Phone then Find My Phone.. same error.

    Here's the error. I copied and pasted here:

    ===================================================
    Oops...
    Something went wrong and we can't show you this page right now.


    Go to windowsphone.com
    ===================================================


    I started to have a bad feeling this only happens to me :(((
    10-23-2011 08:37 AM
  8. wizake's Avatar
    it happens to me too. it's been happening since the new site.

    there are a few threads regarding this on answers.microsoft.com
    I dont know why, but it takes a LOT of time to fix things at Microsoft.
    10-23-2011 04:26 PM
  9. rabit1's Avatar
    Ok thx wizake. Pls let me know if you find a solution ok?

    Sent from my HD7 T9292 using Board Express
    10-23-2011 07:33 PM
  10. rluka's Avatar
    How many phones do you have listed in that website ?
    I had two (probably a mistake I’ve done in the past). The error always shows up with one of the phone, but when I switched to the other, that error doesn’t shows up.

    The error is very repeatable, by switching back to that phantom phone.
    11-02-2011 07:22 PM
  11. rabit1's Avatar
    I have just one phone listed in My Phone

    Btw, I haven't got this to work until now, and no helps from microsoft at all..
    I'm basically clueless as to even why and what is causing this error. So I don't know where to look for problem.

    Seems like not to many people has this problem
    11-03-2011 12:46 AM
  12. rabit1's Avatar
    How many phones do you have listed in that website ?
    I had two (probably a mistake Ive done in the past). The error always shows up with one of the phone, but when I switched to the other, that error doesnt shows up.

    The error is very repeatable, by switching back to that phantom phone.
    Hi rluka,

    How do you switch between those 2?

    and how to remove one if there are two?

    thanks
    11-15-2011 11:30 PM
  13. iqorek's Avatar
    The feature is disabled for some regions, please vote for re-enabling this feature for all
    "Ring, lock, or erase your phone" for all regions
    Thomas Kwaku likes this.
    01-01-2012 08:12 AM
  14. Thomas Kwaku's Avatar
    if i open facebook on my lumia920 it say oops something went wrong what should i do pls help me
    09-20-2014 05:38 AM
  15. Wasim Yousaf's Avatar
    Unfortunately No. Just tried again today. Same problem. Help

    Sent from my HD7 T9292 using Board Express
    07-02-2015 04:17 AM
LINK TO POST COPIED TO CLIPBOARD