1. Zachary Boddy's Avatar
    This probably doesn't even warrant a few sentences, but I'm getting real tired of the poor performance of this website. Not any phone, haha, but WP Central. Every other website runs fine and speedy on my laptop, I can play YouTube and have three other tabs open without a hick but every time without fail this website takes absolutely forever to load, and constantly crashes so I have to refresh mid-load. It's pretty frustrating, haha.
    I figure I'm not alone, or maybe I am. Wouldn't be the first time haha. But I think the people running this site could optimize it more than it is, right?
    10-01-2014 09:57 AM
  2. berty6294's Avatar
    I could possibly have the tiniest solution for your tiniest rant. Try deleting your cookies. I have had a similar experience and recently deleted my cookies and used IE tracking protection and all is good in the world again. I know what takes the longest to load on this site (by far) are the ads.
    HeyCori and xandros9 like this.
    10-01-2014 10:02 AM
  3. jasqid's Avatar
    Yeah. Load time sux.
    10-01-2014 10:04 AM
  4. Zachary Boddy's Avatar
    It runs slightly faster in the forums but it's still slow. And I have it set so that my cookies are deleted every time I close the browser. I got tired of deleting them manually after they built up for ever.
    10-01-2014 10:27 AM
  5. berty6294's Avatar
    It runs slightly faster in the forums but it's still slow. And I have it set so that my cookies are deleted every time I close the browser. I got tired of deleting them manually after they built up for ever.
    Try adding the tracking protection or an ad blocker. Again, the Ads are responsible for more than 50% the loading time!
    10-01-2014 11:26 AM
  6. rodan01's Avatar
    Rubino is too greedy, the site is full of ads that make it slow.
    10-01-2014 12:04 PM
  7. LockOnTech's Avatar
    Since I use tapatalk on my phone the most to use any of the mobile nation website, i have tried going here wpcentral and android central using my samsung galaxy tab 3 using chrome; there were no ad on there but it was kind of dreadfully slow navigating the site. Out of curiosity I went to wpcentral using my lumia 521, internet explorer forced closed back to my start page.
    10-01-2014 01:45 PM

Similar Threads

  1. It is the beginning of Q4!
    By manders500 in forum Nokia Lumia Icon
    Replies: 24
    Last Post: 10-19-2014, 08:52 AM
  2. Why can't I change my MS account?
    By WPCentral Question in forum Ask a Question
    Replies: 2
    Last Post: 10-01-2014, 02:44 PM
  3. Microsoft adds presentation app Sway to the Office software family
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-01-2014, 09:42 AM
  4. Why isnt anyone making colored backs for the 925?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-01-2014, 09:16 AM
  5. Does the Lumia 930 have 4G connectivity?
    By Arjun Agarwal in forum Ask a Question
    Replies: 3
    Last Post: 10-01-2014, 07:49 AM
LINK TO POST COPIED TO CLIPBOARD