1. Javichu1984's Avatar
    Hello everybody.

    Here are the failures I found after 1 week of use:

    - My Lock button is a little bit loose. As all the people I read with the volume button rocks, mine volume button is on average ok, a little loose, but OK, instead I had the lock button more loose. xD. I think is not a defect itself, is about its material, as everything is made of magnesium, they had to keep room fot the button, because as it tooks dirt and everything, is has more probability to get stuck. The solution should be Microsoft, instead of using a loose button, glue the click activator to the magnessium button cup. Hardware issue, not solution.

    - The brightness rattles a little at low levels. Is not linear, so for example, if you had your brightness below 1/2 and use Internet explorer, go back and forward, so as the web dimms (is an IE effect) the brightness do some "jumps". I don't know if is hardware or software related, as if you change the brightness the upper levels are quite smooth, but the downward levels are a little stteppy. You could try it, I think is not my units fault. So maybe Hardware issue.

    - The nVidia graphic drivers are too young. For example, when looking feedly feeds, the images, began to had horizontal lines inside it, you could pinch to zoom in, and zoom out, and they dissapeared, so Software issue.

    - The speaker position is bad. This is why we found the sound do quietly. Try the Surface 2 on lying on the top of a table, it has an improvement. Thats why, Microsoft choose the position of the speakers to reflect the sound to a surface, as they are oriented to the back of the device. Probably, the front location of the Nokia Lumia 2520 should be better. Also the volume curve is really bad, they could choose another logarithm, becouse until 40 in volume there is absolutely quiet sound, so is as you reduce the volume scale from 40 to 100... Software issue completely. If they choose another volume table, issue solved. NEW: Also I've found that the balance on the speakers are not right, the left speaker sound louder and with slightly different tone than right speaker.

    - Touch implementation on Desktop. For example, one thing I found absolutely $"%$%&/*!!!. Try to rearange the email accounts in Outlook 2013... IS completely imposible. Now, connect and try again... Is as simple as click, and move it... Why is this possible? Becouse the Drag 'n' lock function is not well implemented. As you keep your finger on an elemment for more then x seconds, you must see an indicator of lock, to be available to move its element... This is completely Software issue related.

    - Autobrightness implementation. Try to set your brightness to the 50%, and then cover with a finger the brightness sensor, located next to the front camera... After a few seconds, you could see the screen dims a little... Thaths not enough, the auto brightness, MUST use a wider range, becouse if you want so little range is not ussable... try to read at night with that level of brightness... Probably you will dream with ovnis after that xD. Is completely impossible. I had more devices, and the exact point should be at least, to modify the brightness fore more 80% of the scale, so for example, if you set the brightness at 50%, the auto brightness could change easily from less than 10% to over 90% with its sensor. (The optimal setting would be to be capable of adjust the hole scale, as it's auto -brightness, you should be able to forget completely the brightness slider). Software issue.

    And I think that's all, I will update the post, with more failures as soon as I find them. Luckily there are not more! :)
    Last edited by Javichu1984; 11-03-2013 at 06:25 AM.
    11-01-2013 06:20 AM
  2. Javichu1984's Avatar
    More things.

    - After some use my Surface 2 got some tiny scratches on the bottom of the device, where stands when the kickstand is open... There are small spots that loose it's paint, now there are 2, but if it had only 1 week of use, what about 2 years of use? All the surfaces were wood or glass, always tables, so in theory, there are no materials that could scatch this... Hardware issue. I thought that the surface was not painted, but it has some paint or cover over the VaporMG.

    - Another "epic fail" is that I couldn't answer to any post in the forums from my Surface 2. Simply when I try to answer, and select the text box to write down the answer, the keyboard pops in, but suddenly popos out and gone. I've tried everything and is impossible to keep the on screen keyboard, and obviously, impossible to write down in the forums... Software issue, does anybody has this problem?
    11-03-2013 06:22 AM
  3. kristalsoldier's Avatar
    I am not sure I can related to the "defects and failures" that you are referring to. I have had my Surface 2 now for about one week. In that time, and as per your listing:

    Lock Button: My unit does not seem to have the issue mentioned by you - I should also add that neither does the volume button.

    Graphics Drivers issue: Can't say I have experienced the problems you describe. I did not, however, that recently the Surface did receive a Win RT Drivers update.

    Speaker position: Can't say that I am bothered with it as I use headphones all the time and have faced no issue.

    Outlook and Touch implementation: Don't know as I don't use Outlook (though I will soon - after about 30 days or so). Otherwise, I find no issue with the Touch implementation in either the Modern UI space or in desktop space.

    Autobrightness: Again, I can't say I have faced the same issue as you.

    Scratches: There are none of my Surface thus far.

    Posting in Forums: I have not faced any problems whatsoever - either on this forum or on others (including on MacRumours!)
    11-03-2013 07:34 AM
  4. etphoto's Avatar
    .

    - Another "epic fail" is that I couldn't answer to any post in the forums from my Surface 2. Simply when I try to answer, and select the text box to write down the answer, the keyboard pops in, but suddenly popos out and gone. I've tried everything and is impossible to keep the on screen keyboard, and obviously, impossible to write down in the forums... Software issue, does anybody has this problem?
    I think its this site. Same thing happens to me. If you quote someone then you can type in a response (as I am doing now).

    Another issue is after plugging in a head phone and then unplugging it I get no sound from my speakers. Need to reboot in order to get the speakers working again. Could be a driver issue. Idk
    11-03-2013 09:02 AM
  5. ctitanic's Avatar
    I am not sure I can related to the "defects and failures" that you are referring to. I have had my Surface 2 now for about one week. In that time, and as per your listing:

    Lock Button: My unit does not seem to have the issue mentioned by you - I should also add that neither does the volume button.

    Graphics Drivers issue: Can't say I have experienced the problems you describe. I did not, however, that recently the Surface did receive a Win RT Drivers update.

    Speaker position: Can't say that I am bothered with it as I use headphones all the time and have faced no issue.

    Outlook and Touch implementation: Don't know as I don't use Outlook (though I will soon - after about 30 days or so). Otherwise, I find no issue with the Touch implementation in either the Modern UI space or in desktop space.

    Autobrightness: Again, I can't say I have faced the same issue as you.

    Scratches: There are none of my Surface thus far.

    Posting in Forums: I have not faced any problems whatsoever - either on this forum or on others (including on MacRumours!)
    This is a reflection of my owns experience with my S2.
    11-03-2013 02:29 PM
  6. ctitanic's Avatar
    I think its this site. Same thing happens to me. If you quote someone then you can type in a response (as I am doing now).

    Another issue is after plugging in a head phone and then unplugging it I get no sound from my speakers. Need to reboot in order to get the speakers working again. Could be a driver issue. Idk
    I used to have this issue in my old RT. I'm right now posting from my new one without any issue. So definitive, this is not a hardware issue but a configuration issue with the way that this site uses to identify the browser used to access the site.
    11-03-2013 02:34 PM
  7. ctitanic's Avatar
    Question to Javichu1984, have you checked the Reliability Monitor of your Surface 2?
    11-03-2013 02:37 PM
  8. calfee20's Avatar
    I had trouble with this site but not with posting. Tracking protection with the easylists fixed my sluggish stalling problems.
    11-03-2013 02:57 PM
  9. Javichu1984's Avatar
    Question to Javichu1984, have you checked the Reliability Monitor of your Surface 2?
    What do you mean with Reliability Monitor?
    11-03-2013 03:12 PM
  10. CarbideGuy's Avatar
    I have had two Surface 2's fail, neither lasting longer than 48 hours. The first failed during Windows updates (a known issue I'm told).
    The second unit completed the Windows updates but failed the next day. I think it was over heating as it was noticeably warmer at the top than the other unit that failed.
    Both units were LOT NO./DATE 1341 MODEL 1572 P3W-00001.
    I'll stick with my RT for now. Probably wait until new manufacturing batches arrive.
    11-03-2013 04:24 PM
  11. justforphun's Avatar
    Does anyone else have loose volume buttons?
    They are not as tight as the powerbutton, I can wobble them around.
    Hard to explain :-/
    11-04-2013 03:43 AM
  12. kristalsoldier's Avatar
    Does anyone else have loose volume buttons?
    They are not as tight as the powerbutton, I can wobble them around.
    Hard to explain :-/
    Actually, I have heard about this problem. A few others on other forums have also complained about it. I'll see if I can dig up a video on this that I had seen. f you are experiencing this, you are not imagining it at all. It's just that it is not a common problem.
    11-04-2013 03:47 AM
  13. justforphun's Avatar
    Ah okay, thanks for your reply.
    I will also make a video, just to clarifiy what I mean.
    11-04-2013 04:24 AM
  14. kristalsoldier's Avatar
    Ah okay, thanks for your reply.
    I will also make a video, just to clarifiy what I mean.
    See here:
    justforphun likes this.
    11-04-2013 05:31 AM
  15. justforphun's Avatar
    See here:
    Exactly like that. Is it a bug or a feature? :D
    Plus my strange battery life of about 6,5h make me worry.

    Aaaand I can't respond here in metro ie. Cursor jumps out of the reply field. Responding on desktop ie now. Meeeeh
    11-04-2013 12:41 PM
  16. kristalsoldier's Avatar
    As for the volume rocker, its not a feature...:>)) I'd recommend just live with it. It's not really a problem.

    As for your other problems, consider a reset. After I got my Surface - about a week back - I reset it once and completely restored it to factory default once. It seemed to solve most/ all issues - not that I had any aside from a niggling doubt about the battery life. Now the device seems to have settled down.
    11-04-2013 02:51 PM

Similar Threads

  1. Replies: 7
    Last Post: 10-14-2014, 05:12 PM
  2. Replies: 12
    Last Post: 05-13-2014, 02:17 AM
  3. Facebook chat and local scout.
    By jordanfernandes in forum The "Off Topic" Lounge
    Replies: 4
    Last Post: 11-04-2013, 12:28 AM
  4. Use one Windows Store account to download apps for whole family?
    By vipkl in forum Microsoft Surface Pro 2
    Replies: 6
    Last Post: 11-02-2013, 02:44 PM
LINK TO POST COPIED TO CLIPBOARD