1. Gergolos's Avatar
    Hey WPCentral,

    I finally got my Surface and wanted to collect all my experience (issues/ tricks/ bugs and so on) for all the other users. I will update my list every time I found something new!

    (updated:17. november 2013)

    Hardware conncetion issues:

    • I was quite sure I would be able to charge my phone through the USB port on my Surface. Actually I am going to use my phone for tethering a lot (for my Surface) and was hoping to use the port for charging the battery while doing so. I connected my phone (HTC 7 Pro/Arrive running WP 7.8) to my Surface. Both of them reacted (vibration/sound). My phone showed me it was being charged, but after a few seconds it would stop. No charging light indicator would go on..no charging would be done... Tested my girlfriend's Samsung Galaxy SII the same way: no problem at all... connected = charging! After that I checked the device manager from the control panel on my Surface and realized my phone would show up as an "unknown device". Trying to get the surface installing the needed drivers through the internet did not work out. So far I am not able to charge my phone's battery with my Surface... Do you know how I could change that? Update: I took a y-cable from my HDD (it has MINI-USB-cable on the one end and two normal USB cables on the other. One of those is used for data-connection and the other for extra power) and connected the power-only-end to my surface. Connected my usb-hub through the mini-usb port to that cable and then plugged in my phone to the hub: tadaaa! Phone is being charged. So conclusion: it is just a driver problem and somehow my Surface will cut the connection because of missing drivers, instead of just letting my phone connected to it...



    • A lot of times when I connected something to my Surface (so far I connected: usb keyboard, usb-mouse, usb-switch, micro-HDMI to HDMI adapter, HDMI to VGA+Audio adapter, HD-DVD drive from my XBOX 360, my phone, my old Zune, my HDD, USB-Stick, scanner) the driver installation screen from the desktop stopped the loading bar at some point and did not continue. It would load and load withouth the bar moving... After 20 minutes or so I closed the windows and everything was fine... no exclamation marks showing up at the control panel device manager list. But still I was wandering if this is "normal"? It did not happen to my USB drives, my Hubs and my Zune... but to all the other devices...
    • Was not able to send media to my PS3 and/or watch media on my PS3 jet...



    Hardware connections, which actually work (some of these I just tried out because it was fun...so not all of these are really for practical use...):


    • I was able to connect to a network HDD with my Surface. Could pin the folders to my Startscreen and as long as my drive was connected to my router I was able to open all the files stored on it.
    • I connected my usb mouse+keyboard to my Surface with a USB switch in between them. So now I can use my keyboard/mouse on my pc and my Surface by just pushing one button on the switch... everything works fine so far!
    • I use a microHDMI-HDMI adapter + a HDMI-VGA+Audio adapter for connecting my Surface to an external monitor. Everything worked fine. I can use the audio-port for connecting headphones and such... The only "issue" is the picture quality. The resolution is fine, but my monitor seems to have some minor problems with it. But as far as I think that is more a monitor and less a Surface issue...
    • I connected my Canon LiDE 110 scanner to my Surface. After some driver installing time it was installed and I could use it for scanning stuff (used the already installed scanner app). amazing...
    • Was able to connect my HDDVD-drive (XBOX 360) to my Surface. I could read DVDs and the data on them, but was not able to play the movies (both DVD and HDDVD) because of no App currently being available which can play DVDs... I think VLC will do that after finally coming out...but...well...I guess not a lot of users are going to watch DVDs on their Surfaces :D
    • usb sticks and HDDs work perfectly fine...
    • my Wacom Intuos 4 was detected but I could not really use it... my tablet was not projected well on the Surface display. Not all the surface was covered by it. So I could only use it for about 70% of the screen... but well... I guess nobody is going to use a Intuos 4 L tablet on a Surface either :D


    "other" (not hardware/driver) related issues/bugs and so on:

    • Almost every time I search for an App in the Windows Store the results seem to be a little bit odd... For example: I was not able to find the official WPCentral App. Because I knew there was one I check for all the Windows Store options. None of the "Find Apps in own language faster" and so on options were selected, so actually the store should give me "normal", not filtered results... But obviously it didn't. So I activated and deactivated this particular option ("apps in own language...") and closed the options menu. After the options windows disappeared the store search results had already changed. I could see WPCentral and also download it. This particular bug appears always. Every time I search for some apps, I have to activate/deactivate the options to see the real results...
    • I don't know why, but I can not Switch off the autocorrect function. As you can see in the last sentence the word "Switch" was capitalized. I can not Change it (here it is "Change"). If I Change the capital letter, it will Change it back. All the autocorrect-functions are turned off and I just don't understand why it wont help. This "bug" appears in different apps. The autocorrect function will Change My words in IE (Desktop -see update- and Metro) and in My email app! My mother tongue is German, so I guess it tries to really correct the words with german grammar... the Problem is: I often use more than three languages and can not use My Surface for typing if this Problem does not go away. I have to say: it really annoys me!
      Here is a link where this Problem is being discussed (seems to be a W8.1 Problem): http://answers.microsoft.com/en-us/i...68753cb?page=4 Update: If I use the desktop version from IE no autocorrect will try to "correct" my words. But still: Metro IE and email-App will change all the mistakes even though I don't have autocorrect activated... Interesting fact: while using the METRO IE I realized that autocorrect wont change everything. If I am typing somthing in the search bar from facebook, nothing will be changed. But if I try to post a statusupdate the autocorrect-bug will come back...
    • I can not use Youtube on My IE. When I use the Desktop Version of IE, it will Crash every time I open Youtube and use it for a while (sometimes right after opening the page). I can not make it work. Refreshin and so on does not help at all and I have to Close that particular tab. The "interesting" Thing is that the Metro IE seems to handle Youtube. Sometimes it will stop loading too, but a simple "refres" click will solve the Problem. Here is a thread about this same Problem (but on Surface Pro.). I guess this is once again a W8.1 Problem http://forums.windowscentral.com/mic...rface-pro.html


    • If I use the desktop version from Internet Explorer and try to download something, I can choose where to download that file. Normally IE should remember my chosen destination and save all the other files there. At least it should open that destination by default if I choose "save to"... I don't know if it is by design or a bug, but in my case IE remembers my chosen destination only for that particular tab. All the other tabs choose the default saving directory. If I save a file somewhere else all the other files being downloaded in that tab will also be saved in that same destination. But not the ones from other tabs... kind of well... not so cool...



    Some "tricks" for other users:

    • If you want to check your battery report you can do so by typing "powercfg \batteryreport" in your CMD app. If you do so, your Surface will save a HTML file with all the information you need. (location: C:\Users\Username\battery-report.html)



    So I hope this helps somehow...

    If you know some tricks which could help to solve my posted problems, please tell me :)
    Last edited by Gergolos; 11-17-2013 at 09:41 AM.
    HeyCori and kristalsoldier like this.
    11-14-2013 04:36 PM
  2. Gergolos's Avatar
    Here is an update (sorry for all the coming capital letters, i can not really Change them... it is one of the issues I found out yesterday)

    Issues:
    • I don't know why, but I can not Switch off the autocorrect function. As you can see in the last sentence the word "Switch" was capitalized. I can not Change it (here it is "Change"). If I Change the capital letter, it will Change it back. All the autocorrect-functions are turned off and I just don't understand why it wont help. This "bug" appears in different apps. The autocorrect function will Change My words in IE (Desktop and Metro) and in My email app! My mother tongue is German, so I guess it tries to really correct the words with german grammar... the Problem is: I often use more than three languages and can not use My Surface for typing if this Problem does not go away. I have to say: it really annoys me!

      Here is a link where this Problem is being discussed (seems to be a W8.1 Problem): Disabling the Autocorrect in Internet Explorer 11 Preview. - Microsoft Community
    • I can not use Youtube on My IE. When I use the Desktop Version of IE, it will Crash every time I open Youtube and use it for a while (sometimes right after opening the page). I can not make it work. Refreshin and so on does not help at all and I have to Close that particular tab. The "interesting" Thing is that the Metro IE seems to handle Youtube. Sometimes it will stop loading too, but a simple "refres" click will solve the Problem. Here is a thread about this same Problem (but on Surface Pro.). I guess this is once again a W8.1 Problem http://forums.windowscentral.com/mic...rface-pro.html
    11-17-2013 08:16 AM
  3. Gergolos's Avatar
    Ok, today's update number two:

    Issues (updates):
    -It seems that I don't have the autocorrect problem when I use the dekstop version from IE 11... But still my Surface will autocorrect when using Metro IE and other Apps.
    -Because of my phone not being able to charge it's battery when connected to my Surface I tried to investigate further... What was "interesting" was the fact that it actually has a power/data connection when connected to my Surface, but right after a few seconds it will disconnect. Not only the data-connection, but also the power-connection (so no charging possible). Thatswhy I tried something out: I took a y-cable from my HDD (it has MINI-USB-cable on the one side and two normal USB cables on the other. One of those is used for data-connection and the other for extra-power) and connected the power-only-end to my surface. Connected my usb-hub through the mini-usb port to that cable and then plugged in my phone to the hub: tadaaa! Phone is being charged. So conclusion: it is just a driver problem and somehow my Surface will cut the connection because of missing drivers, instead of just letting my phone connected to it...
    11-17-2013 09:34 AM

Similar Threads

  1. Black Friday Surface RT or wait for Surface 2?
    By ikissfutebol in forum General Desktop, Laptop & Tablet Discussion
    Replies: 5
    Last Post: 11-21-2013, 10:31 AM
  2. Black 'K' fell out of my blue case - It's a terrible day!
    By Kadin Lucas in forum Nokia Lumia 620
    Replies: 3
    Last Post: 11-16-2013, 01:09 AM
  3. Free Games for Gold coming to Xbox One
    By HeyCori in forum The Xbox Lounge
    Replies: 6
    Last Post: 11-15-2013, 09:28 PM
  4. Outlook.com Subfloders and Notifications
    By TheZuneLune in forum Windows Phone 8
    Replies: 2
    Last Post: 11-14-2013, 04:37 PM
LINK TO POST COPIED TO CLIPBOARD