1. JuryDuty's Avatar
    My last update on my Surface 2 was 4/4/14...I tried forcing it to update the past couple days, but Windows Update continually returns an error that, of course, is no where to be found in MS documentation.

    Basically, it's unable to search for/download any updates. I did a basic system refresh, but that didn't help. Any ideas?
    04-14-2014 09:55 AM
  2. BIGPADDY's Avatar
    Check for updates again then try a restart and see what happens.
    04-19-2014 08:18 PM
  3. Cobb's Avatar
    What I do is slide up from the bottom of the screen with the tiles. I then pick the gear icon, pick the bottom option and click check now. It either downloads or installs. I was stuck on the last update and when I went to reboot it said it would install an update on the reboot menu. :) YAY!!!!!
    04-21-2014 08:50 AM
  4. JuryDuty's Avatar
    Yeah, when I do that, it returns, "There was a problem checking for updates." And there's nothing else I can do. It seems I stuck. :(
    04-25-2014 11:15 AM
  5. Cobb's Avatar
    Click the check for update button or view details. It took me 2-3 days of screwing around with it to get it to download, then a reboot to install it. Gotta love windows 8.
    04-25-2014 05:57 PM
  6. JuryDuty's Avatar
    Well, I went so far as to reset the unit, wiping everything...and it still won't connect to update. LOL geez.

    Here's the interesting thing: the Surface specifically says, "You're not connected to the Internet" when I try to update and drill down to the problem.

    However, I can go to any web page and it pulls in fine--even new ones I've never visited. It's like the update process has just blocked the Internet connection when it runs...
    04-27-2014 03:16 PM
  7. JuryDuty's Avatar
    Well I spoke too soon! I followed a series of errors to an obscure Microsoft support article that talked about changing the date on your Surface...! That's when I discovered that the date on my surface was for the year 2067...and there was no way to change it. So I dug further into the OS until I finally found one place that let me change it. Once I put it back to 2014, suddenly everything clicked. SO weird--I know I never changed that, and it was set for automatic clock updates. I don't know WHAT happened there. Even then, the updates only worked once I unchecked half of them--then suddenly it took.

    Thanks all for your troubleshooting with me!
    04-27-2014 05:49 PM

Similar Threads

  1. Replies: 1
    Last Post: 04-14-2014, 09:45 PM
  2. How many update cycles?
    By michail71 in forum Other Operating Systems
    Replies: 4
    Last Post: 04-14-2014, 09:52 AM
  3. Safe to upgrade on this phone?
    By fahad kazi in forum Other Operating Systems
    Replies: 1
    Last Post: 04-14-2014, 09:45 AM
  4. Developer Update 8.1
    By rcorso in forum Other Operating Systems
    Replies: 1
    Last Post: 04-14-2014, 09:43 AM
LINK TO POST COPIED TO CLIPBOARD