04-14-2016 01:36 PM
39 12
tools
  1. PAC757's Avatar
    Got a band new 64gb LTE version today, "no battery detected", and "0% plugged in, not charging" right out of the box. Spent 3 hours online with tech support trying everything in their book, finally they said they will send a replacement, I really hope coming straight from Microsoft I can get one that's not defective, the manager at my local best buy said they just sent a bunch back to Microsoft, most of them because of this very same problem.
    09-25-2014 12:04 AM
  2. travis_valkyrie's Avatar
    It's not defective. I had this problem as well. It's just the firmware, if you still have the tablet, hold down volume up and power for 20 seconds, then release both at the same time and quickly tap power button.
    diofar likes this.
    09-25-2014 07:28 AM
  3. PAC757's Avatar
    It's not defective. I had this problem as well. It's just the firmware, if you still have the tablet, hold down volume up and power for 20 seconds, then release both at the same time and quickly tap power button.
    Thanks, I'll try that. Also I read over in a couple of different forums that it could be the charger, that the LED lighting up on the cable doesn't necessarily mean that the charger is good, it uses one wire in there to just light the LED, other stuff in the charger could be malfunctioning.
    09-25-2014 08:24 AM
  4. PAC757's Avatar
    It's not defective. I had this problem as well. It's just the firmware, if you still have the tablet, hold down volume up and power for 20 seconds, then release both at the same time and quickly tap power button.
    Ok I tried this, didn't fix it, back to red X and No Battery Detected, thanks anyway
    09-25-2014 01:36 PM
  5. SaltedSquirrel7's Avatar
    Unplug everything (keyboard, micro-SD card, any USB devices etc), hold the power button for five solid minutes and then try again.

    This worked for me and was recommended by MS! :)
    09-25-2014 04:25 PM
  6. rj135's Avatar
    I got my Surface 2 about a week ago and had the exact same issue as you. I tried everything but nothing seemed to work. Then I found out that the store I bought it from was visited by a Microsoft technician a few weeks ago and he told the staff that the "no battery detected" issue was something that could happen to new Surfaces and to tell customers to fully update it to fix it. They didn't tell me that when I bought it though, if I didn't find this out then I would have asked for a replacement like you. I tried to download the updates but I kept on getting an error when checking for them. It eventually worked and I fully updated it (let it install ALL updates it pre-selects, don't de-select any or add any, just the one's it chooses). You can do this by clicking "Check For Updates" and then "View Details" and then install. This forces the Surface to install them now instead of when it's idle. Restart it once its done updating and check for new updates. Complete this cycle until there are no new updates it says to install (I still have a couple of optional updates, but I'm leaving them well enough alone, if MS doesn't pre-select it LEAVE IT ALONE). I then shut it down and left it to charge overnight. When I turned it on in the morning it was fixed. The battery said "100% Fully Charged". I unplugged it and everything has been great ever since. I thought the battery may be damaged permanently but it's giving me incredible battery life so far. If you still have your old one, try this out. I hope your new one doesn't have this problem, if it does I hope this fixes it! Best of luck! It's so worth it in the end :)
    09-25-2014 08:44 PM
  7. Grodelj's Avatar
    I have experienced the same problem, when I got mine from ebay. I just left it charging for few hours and everything was back to normal.
    09-26-2014 03:20 AM
  8. PAC757's Avatar
    Thank you all for all the information, I tried it all, left it plugged in over night, 9 1/2 hours, turned off, then turned it on, 0% plugged in, not charging, unplug it and it immediately turns off. Replacement from Microsoft due to be delivered this afternoon, going to plug it in, leave it off and sit till tomorrow, and start the whole process over again, like all you guys have suggested.
    09-26-2014 06:05 AM
  9. PAC757's Avatar
    I have a question, when you guys did your updates, did you do it from the desktop or from the Metro / Modern screen from the Charms menu, that one seems to fail every time.
    09-26-2014 07:15 AM
  10. trance56's Avatar
    Microsoft got a bad batch of tablets. I had the same problem and took the surface back to the Microsoft store and that's what I was told.
    09-26-2014 07:30 AM
  11. PAC757's Avatar
    Ok FedEx guy showed up at 8am at work for something else, plugged in my replacement Surface at 8:10 , left it off and charging 5 hours, turned it on, went through the initial setup, turned off automatic time, changed the date and time to today, of course the "no battery detected" and red X are there. I am just letting it do the updates now. When they are completely finished, I'm turning it off, leaving it plugged in and charging at work all weekend, if it's still f'ed up on Monday morning, I'm driving to a Microsoft Store and telling them to make it right or give me a refund. And it's back to Android for me. This is a freakin $600 tablet, I expect more from Microsoft. This is the kind of situation where Apple kicks their ****, bought a used MacBook for my daughter, was totally screwed up, software was hosed, cracked keyboard, dropped it off at an Apple Store, picked it up 2 days later, fresh install of software and updated to the latest version, new keyboard, working 100%. All I had to pay for was the keyboard, no labor, no charge for the new version software.
    09-26-2014 12:32 PM
  12. travis_valkyrie's Avatar
    I'm not surprised how the replacement have the same issue as it appears to have the same launch firmware. Do the volume up and power trick, it always work.

    09-26-2014 05:33 PM
  13. zu5be's Avatar
    Solution: Update your surface to latest firmware. It takes a while and check for updates again and again to make sure nothing is left. Finally, shutdown your surface and leave it charging overnight or at least 1hr. Switch it on. See if it shows charging! Try connecting the charge cable in opposition directions.
    09-28-2014 02:53 AM
  14. PAC757's Avatar
    Found a solution on here, but don't remember where or the members screen name, but his solution was while the Surface is unplugged from the charger and off, press and hold down the power button for 5 minutes then turn it on. That worked, it went from not turning on at all when unplugged or saying "0% available, not charging" , when plugged in, to turning on unplugged and said 37% available. Plugged it in over night, unplugged the unit, turned it on and it said 98% available. Never could get it to 100% though, but I guess that's a Windows RT thing as I see many others not being able to get the Surface to charge to 100%.
    rj135 likes this.
    09-28-2014 09:21 AM
  15. trance56's Avatar
    Try to reinstall the battery driver.
    09-28-2014 09:24 AM
  16. PAC757's Avatar
    Try to reinstall the battery driver.
    I tried that. I'll see how it does after a few charge cycles. It seems the "not charging to 100 %" is a common problem on these things.
    09-28-2014 12:35 PM
  17. wazoomie's Avatar
    Any updates? I bought a Surface 2 a couple of days ago and I got the same problem. The device is sold out everywhere and I really don't want to bring it back and get my cash back.
    09-28-2014 01:07 PM
  18. Trevor Wolfe's Avatar
    Alright. Let's make sure the drivers for the battery is updated. Please swipe from the right, tap search and type in Device Manager.
    Krisley: On that page, you should see File, Action, View, Help.
    Krisley: Below, look for Batteries and tap it.





    Krisley: Once you're on Device Manager, tap on Batteries. Then tap and hold on Microsoft ACPI-Compliant Control Method Battery.
    Krisley: Another window will pop up, please tap on Uninstall.
    Krisley: To reinstall it, please tap on Action and select Scan for hardware changes.
    Krisley: You may need to restart the Surface after that.
    09-28-2014 01:14 PM
  19. wazoomie's Avatar
    I tried this just now but it didn't work.
    09-28-2014 01:19 PM
  20. trance56's Avatar
    Wazoomie try plugging it while turned off for 30 minutes and see it charges. That's what Microsoft told me to do and it worked For both my tablets.
    09-28-2014 01:51 PM
  21. wazoomie's Avatar
    I tried a couple of things I found online;


    • Uninstalling battery drivers, shutting the device off for 30 minutes, charging it while device still shut down
    • Shutting it down and hold volume up + power for 15 seconds, charge it for a bit.


    Finally my device is charging for the first time in four days! But it only goes up to 9% and now it's saying "plugged in, not charging".
    09-28-2014 03:21 PM
  22. rj135's Avatar
    Also try fully updating it as a few others and I have suggested. You might get an error when checking for them but keep trying. See my earlier post for more detail. Hope it works out :)
    09-28-2014 03:38 PM
  23. PAC757's Avatar
    @wazoomie

    I tried everything you did also, try this :
    Turn off your Surface and leave it on the charger for an hour or two, then while leaving it turned off unplug the charger from your surface, and press and hold down the on button and just keep holding it down for at least 5 minutes, ignore what ever your tablet does, it will flash the start up screen and turn off again just ignore that, then after at least 5 minutes passes, let go of the button, at this time your tablet will be off, then just push the on button till it turns on, go to the desktop and look at the battery it should say some percentage. Then plug it in, it should say charging. That's what worked for me.
    09-28-2014 04:26 PM
  24. Sebastian Speyrer's Avatar
    I had this same problem,and I I just reversed the direction of the charging piece. It does light up both ways if you stick it on. One way showed the no charge at all,I just reversed it and now the damn thing is charging.
    09-29-2014 10:59 PM
  25. wazoomie's Avatar
    I think my Surface is fixed. Thanks for all the help and tricks!

    The first thing I did when I got my Surface was installing all updates (53 in total). This did not resolve the issue. I think what resolved the issue for me was to uninstall the battery drivers and turning the device off for half an hour right after. Then I plugged in the charger and didn't boot the Surface for another half hour. When I did boot it, it showed the 9% charged (plugged in, not charging). For me it only charges now when the device is turned off, but I'm okay with that.
    rj135 likes this.
    09-30-2014 09:48 AM
39 12

Similar Threads

  1. Whatsapp messages no notification?
    By Steve Palgrave in forum Nokia Lumia 720
    Replies: 3
    Last Post: 10-02-2014, 06:51 AM
  2. What do you expect for the Surface 3?
    By rodan01 in forum Microsoft News & Rumors
    Replies: 2
    Last Post: 09-25-2014, 07:31 AM
  3. Are you guys noticing the new player going after Square? No WP...
    By Mallguvner in forum HTC One (M8) for Windows
    Replies: 1
    Last Post: 09-25-2014, 12:03 AM
  4. New update..?
    By Varun Bhargav in forum Ask a Question
    Replies: 3
    Last Post: 09-24-2014, 10:49 PM
  5. Cortana tells some new jokes
    By daveb in forum Cortana
    Replies: 1
    Last Post: 09-24-2014, 10:28 PM
LINK TO POST COPIED TO CLIPBOARD