Time for more discounts! Shop all the best Cyber Monday deals NOW

  1. kwickone's Avatar
    Wondering if any other early adopters are seeing this. I have a new i5 Surface Book. Charges fine with the normal Power adapter. I also got the new Surface Dock. The Surface Dock will NOT charge my Surface Book. It has power for sure, and the light on the part that plugs into the Book is lit.

    I have seen some tweets to at SurfaceSupport and it looks like others might be experiencing this as well.

    Anyone else seeing this?

    Thanks.
    10-26-2015 07:28 PM
  2. kdanielson's Avatar
    I am experiencing much the same problem, although my dock will charge for a while, then then stop, and then I need to unplug-replug to get it to start charging again. Hopefully a problem with the dock as I would hate to have to return the machine after all the time I have spent setting it up.
    10-27-2015 05:28 PM
  3. zombie0's Avatar
    Same problem here, sporadically. Disconnecting and reconnecting causes the charging to resume. Hopefully a software issue.
    10-28-2015 03:42 PM
  4. Hotty Toddy1's Avatar
    I'm having the same problem, but my docking station is not charging the Surface Book at all even though the light is illuminated. Did you ever get a resolution? I'm trying to figure out who to call about it.
    11-11-2015 06:54 PM
  5. zombie0's Avatar
    The only resolution I've had is a work-around: disconnect and reconnect the dock. Yes, that means all of my USB devices and external screens get reset. Yes, it's annoying as heck. But it does tend to work.

    Is that not working for you? If not, that's even worse than I've seen.
    11-11-2015 11:05 PM
  6. zombie0's Avatar
    The only resolution I've had is a work-around: disconnect and reconnect the dock. Yes, that means all of my USB devices and external screens get reset. Yes, it's annoying as heck. But it does tend to work.

    Is that not working for you? If not, that's even worse than I've seen.
    11-11-2015 11:05 PM
  7. mcheiron's Avatar
    I had a similar issue that my SB would not charge in the dock. I chatted with MS support and they had me uninstall the battery drivers, then do the hard reset (holder power up and power button for specific time, don't remember how long, but it was a couple seconds longer than the second Surface boot screen). That reinstalled the missing drivers and all is fine now.
    11-13-2015 09:17 PM
  8. julver's Avatar
    I had a similar problem and with my surface book.
    This is my solution;
    Open the device Manager
    Go to the batteries and open it.
    Uninstall both Microsoft Surface ACPI-Compliant Contro Method Battery Drivers
    Hold the on-off button and the high volume buttons simultaneously for 30 seconds.
    Restart your computer and your docking should be charging
    11-20-2015 02:02 PM
  9. DougID's Avatar
    My Surface Dock has also stopped charging my Surface Book. It was working until a few days ago. When plugged in, the other devices (LAN, USB, Sound) all work so the dock is receiving power and making a proper connection to the Surface Book.

    I've tried the suggestion to remove battery drivers and do a hard reset of computer. That didn't work for me. Completely removing, deleting and reinstalling drivers did not work also.

    My original power supply charges computer correctly, so I'm not sure it's an issue with the battery drivers.

    Anyone else determine a permanent fix?

    Thanks
    11-30-2015 09:44 PM
  10. jomargon's Avatar
    I experienced the same issue just now and doing these fixed it:
    1. Detach the SB screen from the keyboard.
    2. Plug the dock directly to the detached screen. The screen should now charge.
    3. Attach the screen to the keyboard. Plug the dock to the keyboard.
    Last edited by jomargon; 02-04-2016 at 10:57 PM.
    01-03-2016 02:11 PM
  11. rchmboston's Avatar
    Yes, I can confirm that pulling out the Surface Dock and plugging back in then shows the batteries charging. Thanks for the suggestion.
    01-15-2016 03:41 PM
  12. kidder4's Avatar
    Awesome suggestion. Plugging the dock directly into the detached screen got me up and running again!

    Thank you!
    02-04-2016 09:23 PM
  13. Jeff Hollon's Avatar
    i was having the same problem with my dock. also had issues with external displays dropping out constantly. I chatted with support and they send me out a new Dock without wanting mine back. This not only fixed the charging problem, but my external displays have been rock solid since tuesday when i got he replacement, not ONE SINGLE DROP. The original unit started with a serial number 0 and the new one starts with a 1 and seems like it is a much newer made unit. either way, my setup is complete now.

    From MS sending me a unit and not making me return the old one, it seems like they know there is a problem with the first batch(s) of docks and apparently they changed something in the building process that means they can't just fix the old ones. if you chat with them and tell them your video drops out or you have problems with USB and power charging through the dock, they will send you a new one. The new ones seems to be correct.
    02-05-2016 12:56 PM
  14. myfirst and lastname's Avatar
    to jomorgan,
    Your tip worked for my Surface Book. Thank you.
    02-12-2016 08:53 PM
  15. Carmine Bucalo's Avatar
    That worked for me too but I still had the problem return. I did a usb recovery using the downloaded recovery image. That fixed the problem totally. I had joined the insider preview fast ring on day one, and I think that may have caused my problem. I also had shutdown-restart issues and really wanted that fixed too. I did the 2-17-2016 firmware update but that didn't fix things totally. Now looks like I'm free and clear.

    Anyone have this problem and using Insider Preview? Anyone try a recovery-reset?
    02-21-2016 09:43 AM
  16. Scott Culbertson's Avatar
    This fixes the issue for mine.
    08-08-2016 03:11 PM

Similar Threads

  1. my sp4 screen keeps changing color when im scrolling a website.
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 10-29-2015, 11:03 PM
  2. Replies: 0
    Last Post: 10-26-2015, 07:01 PM
  3. Replies: 0
    Last Post: 10-26-2015, 06:47 PM
  4. Windows 10 Mail not syncing with iCloud?
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 10-26-2015, 06:07 PM
  5. Got a Surface Book? Make sure you check for Day 1 updates
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 10-26-2015, 06:00 PM
LINK TO POST COPIED TO CLIPBOARD