1. tedj101's Avatar
    Dan Rubino explained to us that this problem exists because the Surface Book is not following the default power profile which calls for the Book to go to into hibernate after sleeping for two hours. His temporary solution was to change the action when the lid is closed from sleep to hibernate. Many of us have done this and then tested the original configuration as each update came out without any change as a result of the update. Yesterday I considered the problem and realized that there is no magic to this power profile and that you can modify virtually any setting with the Group Policy editor.

    So, I went into the editor found the sleep settings and set mine to go into hibernate after 3600 seconds (that's one hour) when the unit is running on battery. I tested it today and found that 10 hours after closing the lid I still had 96% power left (down from 100% when I closed the lid). That's good performance to me, so I think this is a viable solution to the issue.

    OK, now for the details on how to do it. Open the start menu and type gpedit.msc in the "Cortana Bar". That will bring up the Group Policy editor. To get to the sleep settings you need to run through the following menu items: computer configuration, windows settings, administrative templates, system, power management, sleep settings. Put the number of seconds you want the computer to wait before going into hibernate into the appropriate sleep setting and you are good to go. (You can modify any of the other sleep settings as well. I only modified this one since I am not worried about power usage when the unit is plugged in.)

    I hope some of you find this useful.

    <TED>
    11-21-2015 04:50 PM
  2. ccpopham's Avatar
    You can also create shortcuts following this article. I put a sleep/hibernate shortcut on my desktop so that if I am going to step away I can immediately send it to sleep.

    http://www.pcworld.com/article/20909...-shutdown.html

    Posted via the Windows Central App for Android
    11-22-2015 06:48 AM
  3. carloscentral's Avatar
    Dan Rubino explained to us that this problem exists because the Surface Book is not following the default power profile which calls for the Book to go to into hibernate after sleeping for two hours. His temporary solution was to change the action when the lid is closed from sleep to hibernate. Many of us have done this and then tested the original configuration as each update came out without any change as a result of the update. Yesterday I considered the problem and realized that there is no magic to this power profile and that you can modify virtually any setting with the Group Policy editor.

    So, I went into the editor found the sleep settings and set mine to go into hibernate after 3600 seconds (that's one hour) when the unit is running on battery. I tested it today and found that 10 hours after closing the lid I still had 96% power left (down from 100% when I closed the lid). That's good performance to me, so I think this is a viable solution to the issue.

    OK, now for the details on how to do it. Open the start menu and type gpedit.msc in the "Cortana Bar". That will bring up the Group Policy editor. To get to the sleep settings you need to run through the following menu items: computer configuration, windows settings, administrative templates, system, power management, sleep settings. Put the number of seconds you want the computer to wait before going into hibernate into the appropriate sleep setting and you are good to go. (You can modify any of the other sleep settings as well. I only modified this one since I am not worried about power usage when the unit is plugged in.)

    I hope some of you find this useful.

    <TED>
    I decided to give this a shot, will report back in a few days with impressions :)
    I'm doing both plugged-in or on battery, because just today I left it charging overnight while sleeping and when I woke up it was ON with the fans spinning at top gear and very, very hot.
    11-22-2015 02:13 PM
  4. gootdude's Avatar
    This isn't a solution at all. You're just using hibernate, which has existed for years on all machines. You're ultimately not using a feature that the machine hardware supports, because the vendors can't provide proper drivers.

    Not sure why folks think it is acceptable to use hibernate on machines that support s3 sleep but don't actually power down properly.

    I have yet to see any PC that could actually support connected standby sleep, since the drivers are never there. It would be nice if Microsoft could pull it off, but since they're just sourcing random components from intel/marvell, you're not getting any better treatment.

    Microsoft just takes the latest driver produced by the vendor, updates the branding and ships it to the end user.
    11-22-2015 02:44 PM
  5. zerospace-net's Avatar
    This isn't a solution at all. You're just using hibernate, which has existed for years on all machines.
    Agreed. Even my SP3 got better battery life in connected standby than the Surface Book does. MS/vendors need to fix this. Hibernate is NOT a replacement for connected standby.
    11-23-2015 09:41 AM
  6. tedj101's Avatar
    You know, you and the previous poster keep talking about "connected standby". This thread was started talking about the way "sleep" works in the default power profile. Dan Rubino told us it is supposed to change to HIbernate after two hours in the default profile and it was not doing that. I showed people how to achieve that result. Now yo and the previous poster are criticizing me because what I suggested to achieve Hibernation isn't the same as "connected standby" - a topic that was not mentioned in the subject of this thread and which this thread was not intended to address. Perhaps you ought to start your own thread about "connected standby" and when you do, it would be interesting to hear what it is, where it is supposed to be in the Surface Book and where you got that information. I searched the Surface Book manual and it doesn't mention "connected standby".

    <TED>
    11-23-2015 03:15 PM
  7. photobriangray's Avatar
    I'll be more political, Ted. It is a workaround, not a solution, but I appreciate your suggestion and I may use it.
    11-23-2015 03:55 PM
  8. carloscentral's Avatar
    I have disabled this workaround because I've gotten two BSODs after waking from sleep since enabling it :(
    Will wait for a proper solution from Microsoft.
    Last edited by carloscentral; 11-23-2015 at 08:24 PM.
    11-23-2015 06:18 PM
  9. zerospace-net's Avatar
    You know, you and the previous poster keep talking about "connected standby". This thread was started talking about the way "sleep" works in the default power profile. Dan Rubino told us it is supposed to change to HIbernate after two hours in the default profile and it was not doing that. I showed people how to achieve that result. Now yo and the previous poster are criticizing me because what I suggested to achieve Hibernation isn't the same as "connected standby" - a topic that was not mentioned in the subject of this thread and which this thread was not intended to address. Perhaps you ought to start your own thread about "connected standby" and when you do, it would be interesting to hear what it is, where it is supposed to be in the Surface Book and where you got that information. I searched the Surface Book manual and it doesn't mention "connected standby".

    <TED>
    The problem, Ted, is that the drain happens during connected standby, not hibernation. Therefore, switching to a hibernation state (which does not allow the system to retrieve emails or do pretty much anything else, as it is in an "off" state with the system merely suspended), is not a "solution" for the battery drain which only occurs in connected standby. It is merely a workaround, and not an acceptable one for those who need/want the functionality of "connected standby". You presented this as a solution to my problem of the battery draining excessively during sleep, which is actually a state that MS is calling "connected standby" and is not the same as "hibernation" (which is a completely different power state option). This is most definitely NOT a solution for battery drain in sleep/connected standby, as the solution you present says simply to stop using connected standby. It's almost the same as telling me to simply shut the machine off to stop the battery drain. That's not a solution either. Make sense now?
    11-24-2015 11:12 AM
  10. tedj101's Avatar
    The problem, Ted, is that the drain happens during connected standby, not hibernation. Therefore, switching to a hibernation state (which does not allow the system to retrieve emails or do pretty much anything else, as it is in an "off" state with the system merely suspended), is not a "solution" for the battery drain which only occurs in connected standby. It is merely a workaround, and not an acceptable one for those who need/want the functionality of "connected standby". You presented this as a solution to my problem of the battery draining excessively during sleep, which is actually a state that MS is calling "connected standby" and is not the same as "hibernation" (which is a completely different power state option). This is most definitely NOT a solution for battery drain in sleep/connected standby, as the solution you present says simply to stop using connected standby. It's almost the same as telling me to simply shut the machine off to stop the battery drain. That's not a solution either. Make sense now?
    That's fine, but it is a different issue than the one that I was discussing. The default power profile is not supposed to leave you in sleep indefinitely. It is supposed to drop you into hibernate after two hours but it isn't doing so which results in much more power usage when you simply close your lid to close down. I simply showed people how to effect that result - ie a result that MS intended and didn't achieve for some reason. That is what I was addressing and it is a solution to that problem. I was pretty specific about the problem I was addressing in my original post - read the first sentence again. It explains I am presenting a solution to a specific problem posited by Dan Rubino. It's not a solution to any other problem and it didn't purport to be.

    As to whether what you say makes sense, you seem to have certain expectations that have not been met. You don't say where you got those expectations and I certainly don't have any such expectations nor have I seen any such expectations proselytized by Microsoft. Consequently, I have no way to know if what you say makes sense. If you expect the computer to retrieve e-mails and other unspecified other tasks, that is going to take power. I think that is why the default power profile ends that sort of activity after 2 hours.

    <TED>
    Daniel Rubino likes this.
    11-24-2015 01:45 PM

Similar Threads

  1. How to play blue-ray movies on windows 10?
    By NutmegState in forum Windows 10
    Replies: 11
    Last Post: 02-10-2017, 02:38 AM
  2. How can I force 4g?
    By nyjets12 in forum Nokia Lumia 1520
    Replies: 3
    Last Post: 12-21-2015, 06:56 AM
  3. How fix this: Make sure that the proxy settings are correct and click Try again.?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-22-2015, 10:03 AM
  4. How do I upgrade Win 10 to Win 10 pro with a product key?
    By Windows Central Question in forum Windows 10
    Replies: 0
    Last Post: 11-21-2015, 04:42 PM
  5. I updated to Windows 10 and can't download ringtones, why?
    By hugz618 in forum Microsoft Lumia 640 XL
    Replies: 0
    Last Post: 11-21-2015, 04:04 PM
LINK TO POST COPIED TO CLIPBOARD