1. Paul Blackham1's Avatar
    I'm sure this is an old topic now, but I am trying to use the Surface Book 2 for VR (steam VR/Oculus, not windows mixed reality), and there seems to be no solution, and no solid answer as to why it doesn't work.

    I had more or less given up hope on this, as it seems that the USB C port out apparently bypasses the NVIDIA GPU?... so wired connection to the HTC Vive or Oculus Rift for instance seems to be more or less a no-go (although please correct me if I'm wrong here, I would love to know). I tested the Vive on it about a year ago and it literally ran at less than 1 FPS on the Steam VR home screen.

    I since discovered that the Virtual Desktop app (sideloaded version) for the Oculus Quest is capable of streaming steam VR and Oculus rift games directly to the quest via wifi, which is surely a workaround to the USB out issue on the surface book.

    So now I'm stumbling upon a different issue... I don't seem to be able to get either Steam VR or the Oculus app to work on the Surface Book 2 at all!

    If I run the Steam VR performance test it always uses the integrated graphics card, even if i tell it to use only the dedicated graphics via the NVIDIA Control Panel.

    The Oculus app comes up with a big warning error "Oculus has encountered an error. Please restart your computer or contact Oculus Support" which I'm presuming is caused by the same thing? Either way, it gives no further details than that, so I’ve sent oculus logs over to them as part of my support ticket. This is the more disastrous issue, as it means I can’t even try virtual desktop at all, which would be the only way to connect to the Quest aside from through the Oculus Link (which I have tried with the correct cable, but it cuts off completely as soon as it tries to connect, presumably because the Oculus app is erroring).

    I have support tickets up with both Microsoft and Oculus on this, so I will try to post on this topic again if I get some answers, but I would be super grateful if I could get some help on this... even if it's just some closure as to why it will never work....

    Sidenote: I’m aware that the Surface Book 2 is not specifically a gaming laptop and am not expecting incredible results, I’m just trying to solve an issue that I can’t make sense of: On paper it is easily good enough to meet the bare minimum, so I would expect to at least be able to try.

    Thanks for your patience in reading this very verbose issue! Hopefully getting to the bottom of this will be useful to the community!
    01-13-2020 11:02 AM
  2. pkcable's Avatar
    @krisguy can you help here?

    Have you tried running the Steam VR test?

    01-13-2020 12:46 PM
  3. krisguy's Avatar
    I can't use my Vive with my Surface Book 2 either. I know for Steam, it expects the Nvidia/AMD GPU to be the primary one. I would assume that Oculus does the same thing, but I'm not sure if this is by design (like Valve did).

    Spec wise, it's not an issue. I remember years ago running into something like this for some of those rebadged gaming laptops coming in from China (worked for a rebadger/customizer a few years ago). I'll do my best to dig through my notes.
    Last edited by krisguy; 01-13-2020 at 12:55 PM. Reason: more depth
    pkcable likes this.
    01-13-2020 12:53 PM
  4. Paul Blackham1's Avatar
    Thanks for the help, and for the ref.

    Yeah, the Steam VR performance check was what told me that the dedicated graphics card wasn't being used:
    Bizzarely though, this time I got a really strong performance from the test, but still stated that it wasn't using the dedicated graphics...
    I'm not sure what I did differently this time. I don't remember changing power settings around, but that seems most likely.

    The error with Oculus looks like this by the way:
    01-13-2020 02:59 PM
  5. Paul Blackham1's Avatar
    Thanks for the help! That would be great!

    I wonder if Steam VR is reading off of the dedicated GPU, but is listing the integrated graphics for some reason, based on the performance I got from my last VR performance test (reply to @pkcable)

    I can't tell if the Oculus error is in any way related, it just seems odd that both are behaving badly...
    01-13-2020 03:04 PM
  6. Ryujingt3's Avatar
    I'm no VR expert in any way, but it seems like the Surface Book is not powerful enough for VR, at least Oculus.

    01-13-2020 07:55 PM
  7. Paul Blackham1's Avatar
    Yeah, I wouldn't expect it to be particularly good, I just wouldn't expect it to be incompatible.

    I'm pretty sure this forum post is from the first surface book... I think the surface book 2 hadn't been released in Jan 2017?. I'm using the top end 15" Surface Book 2, so it does have the GTX 1060, and fairly good specs all round. Still not a VR machine for sure, but my plan is to use it for development and testing rather than trying to play the more graphically intense games on there.
    01-14-2020 04:12 AM
  8. kyber5's Avatar
    Here is the solution:

    Disconnect your VR headset and close Steam.

    Step 1:

    Navigate to: C:\Program Files (x86)\Steam\steamapps\common\MixedRealityVRDriver\resources\settings
    (depending on your system configurations, the Steam folder might be in a different directory)

    Step 2:

    Open the file "default.vrsettings" by using the mouse right click and select "open with" -> then click "more apps" and select the notepad app

    Step 3:

    Scroll down until you find:

    // Disable DX12 support
    "forceDisableDX12": false,

    Change "false" to "true" so that it now says:

    // Disable DX12 support
    "forceDisableDX12": true,

    Close the "default.vrsettings" file and then open Steam. Plug in your VR headset and it should work.
    pkcable and HeyCori like this.
    03-21-2020 10:20 PM
  9. Stuart Turvey's Avatar
    OK so very late to this party but I have an SB2 and only got my Quest 2 two weeks ago. After researching forums and a several hours of trial and error I landed on whats needed to get VR working on my SB2 to play EA SW Squadrons. I figure its a recent tile so should apply to pretty much everything else thats out there - needless to say, its been made possible by various patches across the SB2, Oculus (and EA Squadrons) stack in the least two weeks.

    I'm not spectacularly technical so can't explain why what works (so please don't ask me questions) however this process worked for me and I documented it thoroughly just in case I'm ever faced with this nightmare again.

    [Edited by mod - email not permitted]

    For every other peasant that does not have access to a gaming PC an just wants to esperience VR on their beloved SB2 (and whilst not completely glorious, it is fantastic and completely playable) I hope this helps.
    Last edited by HelloNNNewman; 11-27-2020 at 10:19 PM. Reason: we do not allow links from new members for a reason. we also do not allow email addresses to be posted. Both are spam.
    11-27-2020 04:13 PM
  10. psh_vt's Avatar
    I just noticed this conversation. A while back I tried using a Vive with my Surface Book 2 and didn't succeed.

    The SB2 works so well with Windows MR, alas. (I still have my gear but don't want to commit to a now-discontinued technology.)

    Maybe I'm remembering wrong, but my memory is that my error with the Vive was the usb throughput, not the graphics. In any case, I was curious if anyone has tried a Vive on the Surface Laptop Studio.
    10-15-2021 01:02 PM

Similar Threads

  1. Snag a pair of Aukey's True Wireless Earbuds on sale for only $30 today
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 01-13-2020, 11:00 AM
  2. The well-reviewed Rexing V1 Plus dash cam is down to $80 for one day only
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 01-13-2020, 10:30 AM
  3. This one-day sale saves you $170 on LG's 55-inch Commercial 4K UHD HDR TV
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 01-13-2020, 10:11 AM
  4. This TaoTronics LED desk lamp on sale for $20 has a built-in USB por
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 01-13-2020, 10:00 AM
  5. Aukey's Fast Wireless Charging Pad is on sale for only $10 at Amazon
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 01-13-2020, 09:42 AM