1. toddpart's Avatar
    I love my Surface...for my usage, it is one step from perfection and that one step is really, really annoying me. It's the Messaging app that just can't seem to send a message if it tried. It connects to the Windows Messenger service via my Outlook.com account just fine. It shows my contacts and their status. It even receives messages just fine. It just can't send. Every time I try to send a message I get the same, annoying, red lettered, unhelpful, one line message..."We can't send this right now."

    This has been going on all weekend. I have uninstalled/reinstalled the 'Mail, People, Calendar, Messaging' app several times to try and resolve. I've done the same with the new Skype app thinking there might be a conflict there. I've even factory reset my Surface twice and reinstalled all apps trying to solve this one.

    Is anyone else having this problem, any fixes or ideas?
    KC Hicks likes this.
    10-30-2012 06:24 AM
  2. KC Hicks's Avatar

    I'm having the same issue on my day old surface unit. I've tried the same steps you have but cant seem to get it to work. Did you find a fix for it?

    11-15-2012 11:18 AM
  3. Jagsfan28's Avatar
    I am also having the same issue. I thought it may have been just me. My surface is only a day old. I haven't tried any of the steps mention already, and I guess it wouldn't do any good unfortunately. Hopefully Microsoft can address this.
    11-16-2012 01:27 PM
  4. SlickShoesRUCrazy's Avatar
    I am having the same issue. My messaging hub stopped working two or three days ago now. have uninstalled/reinstalled two or three times now. Also did a soft reset. still nothing.

    checked my outlook.com account and everything looks just fine and same with my win phone.

    kind of annoyed. My brothers message hub on his surface works fine right now.

    Kind of weird lol. I hope Microsoft sorts this s**t out soon.
    11-17-2012 12:48 AM