1. narv's Avatar
    So for the longest time I've been able to remote connect to my desktop computer from my windows RT machine. Last night, I decided to just go ahead and put the windows 8.1 preview to see what it's about. One of the things I noticed is I can't seem to use RDC anymore to connect to my desktop. Nothing has changed otherwise. However, when I do look at the system properties for remote, I only have the assistance section, and not the remote desktop section like I do on my PC. Was this feature removed for RT?

    Thanks.
    08-16-2013 06:32 AM
  2. jaimeastin's Avatar
    From the start menu, type or search for remote desktop. Also, download the metro rdc app and try there too. Make sure the network you are on is trusted... I don't know... I would think nothing is missing...

    Although I am an advocate to eventually drop desktop mode, it is still one of the most important things windows tablets have! I hope the RDC is still there...
    08-16-2013 06:52 AM
  3. azcruz's Avatar
    I've been using Remote Desktop on my Surface RT since 8.0 and now 8.1 Preview. What version of Windows 8 do you have on the remote machine?
    08-16-2013 06:59 AM
  4. narv's Avatar
    @azcruz I have windows 8 pro on the remote machine.

    @jaimeastin I have the remote desktop client open, since it's what I used before. I didn't try the app so I guess i'll try that when I get home from work this afternoon. The network should be trusted, I mean I've used it before, last time I used it was last weekend.. Nothing has changed on my end. The ports are still forwarded on the router, using the same Microsoft account (on both machines), and I checked the settings (again, windows 8 pro) and it is checked to allow connections.
    08-16-2013 07:36 AM
  5. bradbamford's Avatar
    I only have the assistance section, and not the remote desktop section like I do on my PC. Was this feature removed for RT?
    No, the remote desktop section was never there on the RT version.
    That setting is only for incoming remote desktop which RT doesn't allow.

    Make sure you have port 3389 open on your PC's windows firewall. For testing just turn off Windows firewall on your PC.

    Also, you don't need ports forwarded on your router unless you are trying to access your PC while away from your home network.
    08-16-2013 07:48 AM
  6. azcruz's Avatar
    @narv, on your desktop go to System Properties, Remote tab, Allow Remote Connections is good?

    Then just initiate RDC from your RT and specify the name of your desktop PC.

    Sent from my LT25i using Tapatalk 4
    08-16-2013 08:47 AM
  7. narv's Avatar
    @bradbamford Okay.. I wasn't entirely sure if I had it there or not before so thanks, at least I know it's not missing now. I do use it to connect to my desktop computer from outside of my home network which is why the port forwarding is setup. I didn't try turning the windows firewall off but i'll give that a go and see what happens.

    @azcruz I did check that the allow remove connections is checked, and I tried with the 2nd option for authorized users on and off. as well as making sure my user name was added in the list there.

    I went to whatismyipaddress.com to make sure I was connecting with the correct IP. Maybe i'll try rebooting the machine, see if that works.. ya never know.

    Also, since it seems I never posted the actual error message (though im sure you could all guess it as the standard "doesn't work" one):
    The client could not connect to the remote computer. Remote connections might not be enabled or the computer might be too busy to accept new connections. It is also possible that network problems are preventing your connection. Please try your connection again later. If the problem continues to occur, contact your administrator.
    Thanks all for the help.. I'll try it out and get back to you all in a few here.
    08-16-2013 10:03 AM
  8. bradbamford's Avatar
    Try it on your local network first...that will help in diagnosing where the problem is.
    08-16-2013 08:51 PM
  9. hotphil's Avatar
    I had similar issue last week. I didn't confirm, but I put it down to a recent Windows Update re-enabling Windows Firewall. Grrrr.
    08-18-2013 11:34 PM
  10. DaveSC's Avatar
    RDP works fine on WinRT8.1
    Use the metro app or run the command mstsc (winkey + R to bring up run dialog). Type in the IP or the Hostname if on the local network for your pc. As stated above if you want to RDP from a remote location you need to open port 3389 in your firewall and point it at the machine you want to control. I would suggest using a different port like 13900 on the outside then 3389 on the inside so the RDP bots don't find your connection easily. This also allows you to setup multiple machines on your network with rdp connections even if you don't have multiple ip's without the need for a Terminal Services Gateway. PC 1 = 13900, PC 2 = 13901 and again on the inside 3389.
    08-25-2013 10:17 PM

Similar Threads

  1. SMS/Phone Filter Not Working on Amber
    By mbhforum13 in forum Windows Phones
    Replies: 69
    Last Post: 11-11-2013, 12:48 PM
  2. Replies: 71
    Last Post: 08-24-2013, 08:26 PM
  3. Photographs stored on SD Card
    By Adrian15 in forum Windows Phones
    Replies: 2
    Last Post: 08-17-2013, 08:07 PM
  4. On screen back button?
    By Andrea Giallombardo in forum Microsoft News & Rumors
    Replies: 2
    Last Post: 08-16-2013, 05:32 AM
  5. Nokia Pro cam for video on L920
    By liamjanin in forum Windows Phones
    Replies: 1
    Last Post: 08-16-2013, 04:03 AM
LINK TO POST COPIED TO CLIPBOARD