1. SteviePat's Avatar
    Hi all,

    I've received my 3rd Surface 2 and still continue to have issues with it. Looking for some help here as I can't figure this new issue out. Pretty much my final throw of the dice other than the official MS support before I send this one back and wave goodbye to what should have been a lovely and productive device......

    So - Surface arrives and I set it up. Connect to my wifi and off it goes to get my profile, updates, firmware upgrades etc and the usual setup process. This all finishes and I log on and start updating/installing some apps. The first issue is after about 5 minutes when I lose the app store, and when I go to browse IE I find I have no access to the internet. I figure I'll do a restart and check as well if there are any updates still to actually install (there were) so I leave it to go do that.

    When I get back in, I'm fine for 5 minutes and then the same issue occurs. I start looking at my wifi, which has a solid connection to my router. I pull up the command prompt and check I have an IP address - all good. I ping the router - success. Then I ping BBC - Homepage - and I get timeouts.

    All other devices (Win 7 pc, iPad, iPad mini, WP8) have no issues with internet access and are browsing like champs so the router appears to be fine. So I bite the bullet and go for a full restore from scratch, ensure all updates are installed and try again.

    Same scenario - after what I think is a successful restore, I start hitting the same issue a short while after being able to successfully use apps, IE, browse the app store. So the Surface is managing to connect over wifi, setup my profile, install updates etc, then give me a short period (maybe up to 30 minutes) of me thinking all is well, before going back to having no internet access. Apps tell me there is no internet, Facebook can't update, can't browse the app store, nothing on IE etc.

    Strangely then, I find that within command prompt I can't ping BBC - Homepage, but I can ping it by IP address so I consider DNS is the issue and flushdns, and restart. Still the same symptoms - an initial connection and access to the internet then back to nothing. Again, my wifi connection is good, my router shows me connected and I can ping to the router directly from the Surface. It just won't let me get any further than the router. I'm certain my router is all good as the 1st Surface I had (returned due to a fault with the sd card reader) was fine with internet connectivity.

    If anyone has any suggestions please let me know - I've tried the above as well as obvious things like the network troubleshooter (tells me everything is fine just that Microsoft Corporation is unavailable). I really am at the end of my tether with the Surface - I bought my wife a Galaxy Tab for Christmas which worked out the box and hasn't given me a single issue. This is my 3rd Surface due to faults with the other 2, and as much as I want to love this sleek device that I think would be perfect from my needs, I can't continue to massage it to life every day and get 5/10 minutes of usability. I'll also be opening a case with MS as I said and see if they have any ideas.

    Thanks.
    01-04-2014 05:14 AM
  2. maclancer's Avatar
    I don't trust the surface at all, I rather buy a Nokia 2520 than a surface.
    01-04-2014 05:27 AM
  3. MDak280's Avatar
    Hmm that's kind of discouraging to hear. I want to buy a Surface 2 soon but it looks like Microsoft is having production issues as well as quality control issues. Hopefully mine turns out fine.

    I hope you don't mind me asking, but did you order your Surface online or walk in and buy it from a Microsoft store?

    I hope Microsoft can help you resolve your issue!
    01-04-2014 05:56 AM
  4. Paul Nicholas's Avatar
    Hello, my surface 2 is perfectly fine so I can't help you in that regard but...

    Thanks to an unusual setup I use a PC to get a wi-fi signal then use a Wi-Fi router to share the internet with other devices in my home. (Don't ask it's a complicated set-up)

    Anyway onto my point, my router seems unable to get the DNS server details from the ISP so I used Open DNS Internet Security or DNS Service for your Business or Home - OpenDNS and inserted the server IPs into my Wi-Fi router and hey presto my DNS woes where gone.

    As for your app store disappearing, I've never heard anyone say anything like that.
    01-04-2014 06:06 AM
  5. SteviePat's Avatar
    Hmm that's kind of discouraging to hear. I want to buy a Surface 2 soon but it looks like Microsoft is having production issues as well as quality control issues. Hopefully mine turns out fine.

    I hope you don't mind me asking, but did you order your Surface online or walk in and buy it from a Microsoft store?

    I hope Microsoft can help you resolve your issue!
    Hi there,

    Ordered it online from Tesco Direct - fantastic service can't fault them. Couldn't find anywhere to pick up and test a Surface locally (I am in UK, Scotland).
    MDak280 likes this.
    01-04-2014 06:49 AM
  6. SteviePat's Avatar
    Hello, my surface 2 is perfectly fine so I can't help you in that regard but...

    Thanks to an unusual setup I use a PC to get a wi-fi signal then use a Wi-Fi router to share the internet with other devices in my home. (Don't ask it's a complicated set-up)

    Anyway onto my point, my router seems unable to get the DNS server details from the ISP so I used Open DNS Internet Security or DNS Service for your Business or Home - OpenDNS and inserted the server IPs into my Wi-Fi router and hey presto my DNS woes where gone.

    As for your app store disappearing, I've never heard anyone say anything like that.
    Hi,

    Re app store disappearing I mean it won't connect and states there is an issue. Sorry if that wasn't clear.

    On the live chat with MS support right now - been through all the usual steps of removing/updating the Wifi driver and currently are testing using specified DNS servers. Embarrassingly he's recommened Google DNS server 8.8.8.8 and 8.8.4.4.! Still troubleshooting......
    01-04-2014 06:50 AM
  7. SteviePat's Avatar
    Hmm that's kind of discouraging to hear. I want to buy a Surface 2 soon but it looks like Microsoft is having production issues as well as quality control issues. Hopefully mine turns out fine.

    I hope you don't mind me asking, but did you order your Surface online or walk in and buy it from a Microsoft store?

    I hope Microsoft can help you resolve your issue!
    Hi,

    Ordered mine from Tesco Direct in the UK. They've been excellent with the returns I have made (one with a sd card reader which was offset so wouldn't read the card, 1 with a cracked case).
    01-04-2014 06:57 AM
  8. Eren68's Avatar
    Sorry to hear your trouble. It's bad when someone has a crap experience when others are getting the great experience you should be having.

    You seem tech savvy so I'm not going to insult you with router lease times and how many devices are currently connected via wifi. (My Surface wouldn't connect to my fiance's router due to 12 other devices being connected.....crappy router I guess) My presumption here is at least one of previous faulty ones connected for longer in exactly the same set up, so it does seem like another faulty tablet. In which case:

    Personally, I'd cut my losses with your supplier, get refunded and order somewhere else. The 2nd you received was cracked, the 1st had a faulty card slot, the 3rd one with wifi issues..... Tesco may well be in receipt of either a Monday morning or a Friday afternoon production run pallet. It DOES happen. I've witnessed it first hand.

    You can get the Pro from Currys for 499, which will give you back the apps that you miss, OR, you could order your Surface 2 again from a different source. I got mine from John Lewis with a 2 year warranty. So far (touch wood) it's been a great experience.

    Prior to this, I'd call Microsoft tech support and pre-empt their usual questions by having another router in hand to test with them. Hope this works out.
    01-04-2014 06:57 AM
  9. jaimeastin's Avatar
    So.. Sorry to hear of your troubles.

    What are your WiFi settings? I know you said other devices connect fine, but what is security type settings and such? Have you change d the power settings on the surface, for better performance!?

    My surface rt was sometimes temperamental with WiFi, especially in the store. My surface 2 has been solid.
    01-04-2014 07:07 AM
  10. SteviePat's Avatar
    Sorry to hear your trouble. It's bad when someone has a crap experience when others are getting the great experience you should be having.

    You seem tech savvy so I'm not going to insult you with router lease times and how many devices are currently connected via wifi. (My Surface wouldn't connect to my fiance's router due to 12 other devices being connected.....crappy router I guess) My presumption here is at least one of previous faulty ones connected for longer in exactly the same set up, so it does seem like another faulty tablet. In which case:

    Personally, I'd cut my losses with your supplier, get refunded and order somewhere else. The 2nd you received was cracked, the 1st had a faulty card slot, the 3rd one with wifi issues..... Tesco may well be in receipt of either a Monday morning or a Friday afternoon production run pallet. It DOES happen. I've witnessed it first hand.

    You can get the Pro from Currys for 499, which will give you back the apps that you miss, OR, you could order your Surface 2 again from a different source. I got mine from John Lewis with a 2 year warranty. So far (touch wood) it's been a great experience.

    Prior to this, I'd call Microsoft tech support and pre-empt their usual questions by having another router in hand to test with them. Hope this works out.
    Thanks mate,

    Yup I am tech savvy (MCP) but always open to any suggestion as although I think I know my stuff, I'm also not infallible. Have been through all the basics (through gritted teeth) with MS tech support and allowed them to have me re-try most of the options I've already gone through. Have already revisited the router and removed any and all stale connections from devices previously connected.

    At the moment (and hopefully not going to jinx it now) but we seem to have it narrowed down to DNS and since specifying the Google DNS servers, I've had a stable connection for a while now. Although it is still a mystery to me how all other devices on my network are using the default DNS servers provided from my ISP without issue, I'll take a working device over solving the mystery for the moment. So right now - am up and running and can now start using the Surface and finally getting it setup the way I want it. I'll swap the Google servers for the OpenDNS later on after a period of stability, and hopefully this weekend will prove its working. I'll post an update on Sunday evening so there is closure or otherwise. Cheers.
    01-04-2014 07:15 AM
  11. SteviePat's Avatar
    So.. Sorry to hear of your troubles.

    What are your WiFi settings? I know you said other devices connect fine, but what is security type settings and such? Have you change d the power settings on the surface, for better performance!?

    My surface rt was sometimes temperamental with WiFi, especially in the store. My surface 2 has been solid.
    Hi there,

    WPA + WPA2 Mixed Mode for wifi, and I haven't changed the power settings at all as yet so they will be whatever the default was. I've just posted an updated on how it appears to have been DNS which was the issue - hopefully see it stable over the weekend.

    Cheers for the input!
    01-04-2014 07:18 AM
  12. Eren68's Avatar
    Pleased to hear this, but I'd still be a tad concerned as these things should work straight out of the box, ie just dial in your wifi password and away you go. Still, you're up and running now, so hopefully when all the updates and new firmware is pulled down, it will be a permanent fix to a very strange problem
    01-04-2014 07:38 AM
  13. pds2208's Avatar
    I have something similar, or maybe its the same issue. If I look at the connection, it says it can't get internet access. If I disable and re-enable the interface it works fine. For ages. BUT, this also happens to all my PCs too but not my apple kit. I suspect it has something to do with windows 8.

    Sent from my Nexus 7 using Tapatalk
    01-05-2014 12:43 PM
  14. SteviePat's Avatar
    Final update - all is well. Manually setting the DNS servers has worked a treat and I now have a fully working Surface. Still no idea how this has happened but just happy its been working all weekend.

    Cheers.
    MDak280 likes this.
    01-05-2014 05:05 PM
  15. jMawl's Avatar
    Glad you resolved your issue. I have a similar type of problem, but it is with a laptop PC. My Surface 2 works great with my wifi, as do 3 desktop PCs (Windows XP and 2 Win 7), a Sony VAIO laptop (Win 7), a MacBook Pro, a windows phone, 2 iphones, 2 ipads, a wifi printer, an Xbox 360, and a PS3...I just realized how much crap I have connected to my wifi :) Anyway, my Dell Precision laptop has had a weird wifi issue ever since I updated to Windows 8.1 (it is the only thing I have running 8.1 except for the S2). Whenever the laptop goes to sleep, it loses wifi. My wifi runs both 2.4 and 5.0 GHz bands with different network ids. If I lose signal, I can either restart my computer (which may or may not fix the problem) or I can switch between the two bands a couple of times and it eventually fixes itself. It is really odd. It sees and connects to the networks, but sometimes it has a "limited" (i.e., no) connection. I know this is a Surface 2 forum, but any thoughts would be appreciated.
    01-05-2014 06:37 PM

Similar Threads

  1. Headphone Socket Issue, broken?
    By harrywilde in forum Windows Phones
    Replies: 5
    Last Post: 10-09-2014, 04:16 AM
  2. 2 Issues. Please Help !!!
    By isicles in forum Windows Phones
    Replies: 11
    Last Post: 01-12-2014, 03:13 PM
  3. New to the 520 but not WP
    By NYRbeezer in forum Windows Phones
    Replies: 3
    Last Post: 01-03-2014, 09:15 PM
  4. New App: Clean PNR Status for Indian Railways
    By Akasmik in forum App Spotlight
    Replies: 1
    Last Post: 01-03-2014, 08:35 PM
LINK TO POST COPIED TO CLIPBOARD