1. Ray Adams's Avatar
    Hello all,

    I just bought Surface 3 from BestBuy. After installing all updates and FW and found that 5GHz WiFi is awfully slow! I have 50Mbps internet connection, but speedtest on Surface only shows 0.16Mbps for download (totally incorrect) and 6Mbps for download (exactly my upload speed).
    But when I switch to 2.4Ghz access point, I am getting full speed down/up!

    I have good router and Surface shows 400Mbps connection to router on 5Ghz, but download speed is awful!

    Anyone sow such behavior on Surface 3?
    07-27-2015 11:12 PM
  2. michail71's Avatar
    I've seen mine report a slow connection off of adapter properties but download much faster.

    But 5Ghz can sometimes fall off at range or through walls. I think the antenna in the surface isn't the greatest from what I have seen.
    07-27-2015 11:29 PM
  3. Ray Adams's Avatar
    I do not think this is a problem. I mean if 2.4 works, why 5 doesn't? I am sitting withing 2 foots from router. I have 2 iPads, 2 iPhones, Windows Phone and android tablet. Also 2 Roku connected to the same 5Ghz network. None of them have such problem!
    07-27-2015 11:59 PM
  4. michail71's Avatar
    That is odd then. I usually get about a 500-700+ Mbps 802.11 AC sync rate and get 59/12 on speed tests. But I've seen it show 4 Mbps while downloads were still running around 20-30 Mbps.
    07-28-2015 01:09 AM
  5. sazie's Avatar
    I have the exact same issue with my new Surface 3... thought it was just me though!
    sectime likes this.
    08-01-2015 12:53 PM
  6. Ray Adams's Avatar
    I just returned tablet back to Bast Buy. After upgrading to Win10 WiFi was not fixed and tablet mode in Wi10 is terrible! I though I can replace my iPad with Surface, but unfortunately it is impossible! Lack of apps, useless in touch mode. A lot of other issues :( .
    08-06-2015 12:06 AM
  7. michail71's Avatar
    Edge on the Surface 3 seems to have a hard time with speedtest.net. It gets all laggy and occasionally has odd results. I can see it dropping UI frames on the test.
    08-09-2015 03:27 PM
  8. michail71's Avatar
    Just reporting back on some testing I did. I had much better performance on 5Ghz AC than I did on 2.4. I was able to always get faster 5 Ghz speeds around my house but the distance seems to impact the Surface more than it does my other devices. My PC at the far end of the house can get a solid 89/12 from my Comcast 802.11AC modem while the Surface gets around 20-30 Mbps in the same location. Switching to 2.4 Ghz gave me around 6 Mbps.

    If I'm next to the modem it can do 50-89 Mbps but still seems to struggle with a solid speed.
    08-09-2015 08:12 PM

Similar Threads

  1. Replies: 1
    Last Post: 07-28-2015, 07:56 AM
  2. 6tag update 5.5 on windows 10
    By cory1717 in forum Windows Insider Program
    Replies: 2
    Last Post: 07-27-2015, 10:42 PM
  3. Replies: 1
    Last Post: 07-27-2015, 09:30 PM
  4. App installs/updates stuck on pending, how can I get them to finish downloading?
    By Windows Central Question in forum Windows Phones
    Replies: 0
    Last Post: 07-27-2015, 09:07 PM
  5. Sooo... what happens on the 29th?
    By jwhipple in forum Windows 10
    Replies: 1
    Last Post: 07-27-2015, 06:11 PM
LINK TO POST COPIED TO CLIPBOARD