1. Dewg's Avatar
    Running S3 with TH2 (1511) update. Just after connecting my Surface to a Microsoft Wireless Display Adapter (miracast), my apps stopped working correctly. Many apps such as Disney free fall games and slot machine style games would hang on their splash screens for 30 seconds before loading. Some games such as Xbox Rabbids Big Bang would hang at their splash screen for 30 seconds and then crash to desktop.

    I did a factory reset and setup the S3 from scratch (no restore). Everything was running smoothly for about a week. I then did a System Restore Point (prepared this time). Then I connected it to the Miracast again. Same thing happened - app my apps started messing up. Restart, shut down, nothing solved it. So I restored the system back to the restore point (took 5 mins!). Apps started working properly again.

    Is anyone else having this problem? Is your S3 on Windows 10 with the November update (TH2) applied? Make sure you turn on System Restore (I have a 128GB S3 so I set System Restore to use 3% of the drive) and set a restore point just before you connect to Miracast.
    Last edited by Dewg; 02-15-2016 at 11:17 AM.
    11-28-2015 12:52 PM
  2. tbsteph's Avatar
    I'm sure you rather have a fix but my S3 works with the WDA without issue. Have you downloaded the WDA app from the Store? As I recall when I ran that app there was a firmware update for the adapter. Good Luck.
    Dewg likes this.
    11-28-2015 03:09 PM
  3. Dewg's Avatar
    Yes, running latest firmware released on the 26th. I'll test again tomorrow. It must be a display driver issue or DX software problem.
    11-29-2015 02:28 AM
  4. Dewg's Avatar
    After two Surface 3's, I finally figured it out! For those that have the same issue - after connecting your Surface 3 to a Miracast device (like the Microsoft Wireless Display Adapter), your Unity apps start crashing or taking 30+ seconds to load:

    Remove the Miracast adapter from Device Manager - the apps start working normally again!

    To do this - open Device Manager
    Click View - Show Hidden Devices
    Find the Miracast device you connected to (usually in a section that says "Miracast")
    Delete (or uninstall) it.
    Close Device Manager

    That's it! You may have to do this each time you connect your S3 to Miracast - but it seems to work!
    02-15-2016 11:19 AM
  5. fabiomarp's Avatar
    I have a S3 2gb 64 MB with Windows 10 totally updated and when I use MS WDA, it works randomly switching between pretty mirroring and stuttering , specially with Netflix. The process manager shows high disk, memory and processor activity. It's frustrating. If I use the Surface with the hdmi cable, everything works fine. I am realizing that it just can't the streaming and mirroring at the same time. What do you think? Am I correct?
    03-16-2016 09:02 PM

Similar Threads

  1. Non continuum Miracast?
    By jjmorgan64 in forum Windows 10
    Replies: 7
    Last Post: 12-14-2015, 02:24 PM
  2. Replies: 9
    Last Post: 11-28-2015, 04:12 PM
  3. Hello not possible on reboot or start up?
    By shaunydub in forum Windows Phones
    Replies: 2
    Last Post: 11-28-2015, 10:43 AM
  4. White Fluffy Deadly closes out this month's AdDuplex HERO App lineup
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 11-28-2015, 10:00 AM
  5. Replies: 0
    Last Post: 11-28-2015, 09:40 AM
LINK TO POST COPIED TO CLIPBOARD