1. unstoppablekem's Avatar
    I got the Surface Pro 2 launch day from the Microsoft online store. It has been an excellent machine, but the screen had dead pixels, and some other issues (you can see my other thread about the issues if you want). Just a few hours ago, I was watching a video, and the battery died. So I went to charge, and it's BEEN charging for 2 hours, yet still remains at 5%. I tried plugging it into different outlets, but still shows 5%. I mean, it SAYS it is charging, but it doesn't seem like it. Windows hasn't asked me to replace the battery, so I don't know if it is defective or not.

    What do you think? Defective or not? Here is the screenshot for some proof.

    screenshot-28-.jpg
    Attached Thumbnails screenshot-28-.jpg  
    12-22-2013 06:39 PM
  2. ioaniro's Avatar
    Try what MBytes says in the other thread for resetting the tablet:
    http://forums.windowscentral.com/mic...n-battery.html
    unstoppablekem likes this.
    12-22-2013 06:56 PM
  3. unstoppablekem's Avatar
    Try what MBytes says in the other thread for resetting the tablet:
    http://forums.windowscentral.com/mic...n-battery.html
    Yes, it worked! Thread closed!
    12-22-2013 07:34 PM

Similar Threads

  1. I still didn't get my SkyDrive free 20GB email.
    By Dadstar0410 in forum OneDrive
    Replies: 100
    Last Post: 01-27-2014, 09:22 PM
  2. "What kind of phone is that?"
    By hopmedic in forum Windows Phone 8
    Replies: 32
    Last Post: 12-30-2013, 09:45 PM
  3. Replies: 24
    Last Post: 12-26-2013, 12:15 PM
  4. Could this be the culprit of my terrible battery drain?
    By Marconis4 in forum Windows Phone 8
    Replies: 9
    Last Post: 12-23-2013, 03:34 PM
  5. My 1520 with its WP family of the passed 10 years.
    By sk1d_mark in forum Nokia Lumia 1520
    Replies: 8
    Last Post: 12-23-2013, 11:37 AM
LINK TO POST COPIED TO CLIPBOARD