1. cre8tivspirit's Avatar
    I have noticed in the last couple of weeks my battery life was running down at a quick rate. I've noticed that it would be warm to the touch when I'd come back to use it and at first I thought it might not be going to sleep because of the Freedom Case I recently purchased but that doesn't seem to be the case. I didn't have the the case on it today and during a church meeting, the battery drained in just 3 hours while using One Note. I've had One Note open for longer periods before and never had a problem.

    Has anyone else experienced a battery drain over the last couple of weeks? Could a recent Windows update have caused this? Right now, my SP2 Pro is only good for about 3 hours of use before I have to plug the charger in. This makes it pretty much useless to me now.
    08-31-2014 03:36 PM
  2. xboxonthego3's Avatar
    Have you installed any new recently applications or games? It could be a new program somehow draining your battery. Or worse it might possibly be a virus or malicious software running behind the scenes.

    Also have you ever tried adjusting your power options? You can set the processor to different percentages while it's on the battery to improve battery life.

    Hopefully this is helpful! Let us know what you find out.
    08-31-2014 05:40 PM
  3. cre8tivspirit's Avatar
    Nothing new installed recently, other than updates. Power setting is Balanced. Same as it's been since I first set my Surface up. Last time this happened, it was the result of a bug in one of the updates.
    08-31-2014 08:47 PM
  4. NeoGrandizer's Avatar
    I've noticed the odd battery drain from time to time on my SP2 as well. The back would be super hot and the battery drains down to half (glad I have the power cover taking the brunt of it). I've linked it to a local windows system process constantly using up to 40% CPU. Thus pushing it to the 2.x GHz range and causing the heat buildup and battery drain. I terminate the process and it behaves normally again. Not sure what is causing it.
    09-02-2014 12:01 AM
  5. cre8tivspirit's Avatar
    Interesting. What's the name of the windows process so I can check and see if mine is doing the same?
    09-02-2014 06:58 AM
  6. NeoGrandizer's Avatar
    It's a Service Host that gives me problems from time to time. I can't recall which one. All I know is it will spike the CPU usage above 20%-40% and will not go down. This causes the CPU to turbo boost thus generating severe heat and having the fans kick in.

    In my case, I suspect it's a hanged process that isn't letting go of resources when its done.
    09-02-2014 12:07 PM
  7. cre8tivspirit's Avatar
    Well I found my battery drainer. It was XMarks for IE. Followed your lead and started checking processes that were running and found xmarks was consistently running at about 35% of my CPU, all the time. Removed the software and my battery problem went away.
    09-05-2014 09:14 PM

Similar Threads

  1. ATIV Odyssey SCH-i930 with new battery in MINT shape.
    By DavidinCT in forum Marketplace Archive
    Replies: 21
    Last Post: 12-16-2014, 09:53 PM
  2. After full reset, battery life is incredible.
    By maclancer in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 09-01-2014, 05:10 PM
  3. Windows RT Battery problem
    By Daniel Gandolfo in forum Microsoft Surface for Windows RT
    Replies: 3
    Last Post: 09-01-2014, 01:59 PM
  4. Outlook 2013 on SP3 and Heating/Battery
    By spasell in forum Microsoft Surface Pro 3
    Replies: 2
    Last Post: 09-01-2014, 11:32 AM
  5. Replies: 1
    Last Post: 08-31-2014, 02:13 PM
LINK TO POST COPIED TO CLIPBOARD