1. TacoKingYo's Avatar
    Hi all,
    I have a Surface Pro 2. The charger it came with lasted me 2.5 years, burned out a few months ago. Seemed about right.
    But, now its replacement is starting to show the same side effects, despite me treating it well: it only works in certain positions, its charge is still sketchy, etc.
    I've been noticing that the battery life has been dropping quite a bit. Also not uncommon, just normal wear and tear...
    But, even with my docking station, it will be "plugged in, not charging." This is fairly new, and I don't think it's too common....
    I'm not running many processes. As of right now, Skype with 7 Chrome tabs open. I even closed out of a lot of background processes I don't use (onedrive, itunes, etc) and it's still going from "plugged in, not charging" to "plugged in, charging" every ~5 seconds.
    What should I do?
    Thanks
    01-11-2016 01:21 AM
  2. Chintan Gohel's Avatar
    Hi all,
    I have a Surface Pro 2. The charger it came with lasted me 2.5 years, burned out a few months ago. Seemed about right.
    But, now its replacement is starting to show the same side effects, despite me treating it well: it only works in certain positions, its charge is still sketchy, etc.
    I've been noticing that the battery life has been dropping quite a bit. Also not uncommon, just normal wear and tear...
    But, even with my docking station, it will be "plugged in, not charging." This is fairly new, and I don't think it's too common....
    I'm not running many processes. As of right now, Skype with 7 Chrome tabs open. I even closed out of a lot of background processes I don't use (onedrive, itunes, etc) and it's still going from "plugged in, not charging" to "plugged in, charging" every ~5 seconds.
    What should I do?
    Thanks
    The charging port on your surface might be loose or some other connection inside the surface. If you can find a technician, try taking it to them
    01-11-2016 06:26 AM
  3. TacoKingYo's Avatar
    The charging port on your surface might be loose or some other connection inside the surface. If you can find a technician, try taking it to them
    Thank you so much! That could definitely be the problem! I will have it checked out soon :)
    01-11-2016 10:14 PM

Similar Threads

  1. The issues I've experience in a month of ownership
    By Callum_Smith in forum Microsoft Lumia 950
    Replies: 9
    Last Post: 03-08-2016, 12:26 PM
  2. Microsoft Band 2 Charging Stand
    By jmerrey in forum Marketplace Archive
    Replies: 10
    Last Post: 01-14-2016, 12:48 PM
  3. Wireless charging shells on sale for $9
    By HeyCori in forum Nokia Lumia 830
    Replies: 1
    Last Post: 01-13-2016, 02:12 PM
  4. Lumia 635 certificate issue
    By k72 in forum Ask a Question
    Replies: 3
    Last Post: 01-11-2016, 06:54 AM
  5. Charging problem Lumia 640
    By MrCreeper1008 in forum Windows 10 Mobile
    Replies: 2
    Last Post: 01-11-2016, 06:45 AM
LINK TO POST COPIED TO CLIPBOARD