1. SteveW25561's Avatar
    My 2017 Surface Pro won't connect to a Synology wireless AC network (Synology RT2600AC_MR2200AC mesh) if 802.11r is enabled (802.11r is a protocol for fast roaming between access points and runs with 801.11AC).

    We have over 20 other devices that connect seamlessly to the network even with 802.11r enabled, but if I leave 802.11r enabled, the Surface Pro won't connect - Windows 10 reports "Cannot connect to network." As soon as I disable 802.11r, it connects without issue. This is the ONLY device in the entire household that won't connect when 802.11r is enabled. We have >20 other wireless devices that are not an issue (including many iOS devices, Macs, Chromebook, Alexa, Sonos).

    This laptop connected to all other WiFi systems without issue prior to this.

    Is there a way to make 802.11r work on this system? It's new enough that I thought it would be supported (bought June 2017).
    12-08-2018 08:49 PM
  2. TechFreak1's Avatar
    My 2017 Surface Pro won't connect to a Synology wireless AC network (Synology RT2600AC_MR2200AC mesh) if 802.11r is enabled (802.11r is a protocol for fast roaming between access points and runs with 801.11AC).

    We have over 20 other devices that connect seamlessly to the network even with 802.11r enabled, but if I leave 802.11r enabled, the Surface Pro won't connect - Windows 10 reports "Cannot connect to network." As soon as I disable 802.11r, it connects without issue. This is the ONLY device in the entire household that won't connect when 802.11r is enabled. We have >20 other wireless devices that are not an issue (including many iOS devices, Macs, Chromebook, Alexa, Sonos).

    This laptop connected to all other WiFi systems without issue prior to this.

    Is there a way to make 802.11r work on this system? It's new enough that I thought it would be supported (bought June 2017).
    Have you tried updating to the latest drivers?

    www.microsoft.com/en-us/download/details.aspx?id=55484
    12-09-2018 12:43 AM
  3. SteveW25561's Avatar
    Thanks for the reply. I did update to the drivers you linked (although my system was already updated and reported the same driver version before and after) - unfortunately, no difference - still cannot connect if 802.11r is activated.

    Adapter properties (which I can get when the Surface Pro is connected while 802.11r is OFF):
    SSID: xxxxxxx
    Protocol: 802.11ac
    Security type: WPA2-Personal
    Network band: 5 GHz
    Network channel: 149
    IPv4 address: 192.168.1.201
    IPv4 DNS servers: xxx
    xxx
    xx.xx.xx.xx
    DNS suffix search list: local
    Manufacturer: Marvell Semiconductor, Inc.
    Description: Marvell AVASTAR Wireless-AC Network Controller
    Driver version: 15.68.9125.57
    12-09-2018 03:15 PM
  4. TechFreak1's Avatar
    Thanks for the reply. I did update to the drivers you linked (although my system was already updated and reported the same driver version before and after) - unfortunately, no difference - still cannot connect if 802.11r is activated.

    Adapter properties (which I can get when the Surface Pro is connected while 802.11r is OFF):
    SSID: xxxxxxx
    Protocol: 802.11ac
    Security type: WPA2-Personal
    Network band: 5 GHz
    Network channel: 149
    IPv4 address: 192.168.1.201
    IPv4 DNS servers: xxx
    xxx
    xx.xx.xx.xx
    DNS suffix search list: local
    Manufacturer: Marvell Semiconductor, Inc.
    Description: Marvell AVASTAR Wireless-AC Network Controller
    Driver version: 15.68.9125.57
    Hmm, do you have any other Surface devices in your household?

    I'm guessing it may be an issue with the Marvel WiFi Adapter but that depends if you have other Surface Devices that use a Marvel WiFi chipset.

    Secondly, have your tried with 2.4 Ghz, 2.4ghz + 5ghz and mixed mode. I'm not familiar with the Synology settings but generally there is a setting for 20 / 40 mhz co-existence (often called mixed mode in some routers).
    Last edited by TechFreak1; 12-12-2018 at 06:46 AM. Reason: Spelling
    12-12-2018 01:39 AM
  5. SteveW25561's Avatar
    I have no other Windows or Surface devices in the house.

    The auto selection mode is meant to allow the router to choose which 5GHz or 2.4 gHz band, and allows a single SSID for all of them and the mesh.

    The Surface only fails to connect if 802.11r is enabled, and works perfectly if 802.11r is disabled, with no other changes in configuration.
    12-12-2018 03:58 AM
  6. TechFreak1's Avatar
    I have no other Windows or Surface devices in the house.

    The auto selection mode is meant to allow the router to choose which 5GHz or 2.4 gHz band, and allows a single SSID for all of them and the mesh.

    The Surface only fails to connect if 802.11r is enabled, and works perfectly if 802.11r is disabled, with no other changes in configuration.
    1) Thanks for confirming, that rules out one test to identify if it's the Marvell Chipset as it's known to have caused issues in the past in other Surface devices.

    2) I'm aware :) hence why I asked if you had to tried any settings so it would help us find a solution.

    3) Noted, can you confirm the firmware version running on the router and the version of SRM in use?

    So I can have a look at the settings myself, I am also looking getting MR2200AC but that is dependent on other factors. Thus this serves three purposes - 1) helping you identify a possible solution, 2) helping others that may have similiar issues with Surface devices with 802.11r and 3) as well as helping me identify possible pain points for my own network in a mesh set up and others I may come across.

    Never the less, finding a solution will involve testing various combination of settings yourself. The other option is of course not practical - a remote desktop connection to test the router settings.
    12-12-2018 06:58 AM
  7. SteveW25561's Avatar
    I'm on Synology Router manager SRM 1.2-7742 Update 4

    Got it working - Synology support responded with the following:

    --------
    After our developer's checking, 2017 Surface Pro's Wi-Fi chip and 802.11r may have weak compatibility.

    If the Surface Pro needs to use 802.11r protocol, please go to Wi-Fi Connect > Wireless > try disabling the PMF Support and check if this issue still exists.

    img_0.png
    ----

    Disabling PMF resulted in the Surface Pro connecting without problems while 802.11r remains enabled.
    TechFreak1 likes this.
    12-14-2018 02:18 AM
  8. TechFreak1's Avatar
    I'm on Synology Router manager SRM 1.2-7742 Update 4

    Got it working - Synology support responded with the following:

    --------
    After our developer's checking, 2017 Surface Pro's Wi-Fi chip and 802.11r may have weak compatibility.

    If the Surface Pro needs to use 802.11r protocol, please go to Wi-Fi Connect > Wireless > try disabling the PMF Support and check if this issue still exists.

    Click image for larger version. 

Name:	img_0.png 
Views:	3 
Size:	132.0 KB 
ID:	140283
    ----

    Disabling PMF resulted in the Surface Pro connecting without problems while 802.11r remains enabled.
    Awesome, good to hear it's working now and cheers for sharing the solution.

    Although some what concerning that it was Protected Management Frames causing the connection issues, Microsoft may need to update their drivers or it could be the Marvel Chipset itself.
    12-22-2018 04:39 PM
  9. gernerttl's Avatar
    Awesome, good to hear it's working now and cheers for sharing the solution.

    Although some what concerning that it was Protected Management Frames causing the connection issues, Microsoft may need to update their drivers or it could be the Marvel Chipset itself.
    It's probably a drivers issue since PMF doesn't seem to be a hardware standard.
    12-23-2018 12:42 PM
  10. TechFreak1's Avatar
    It's probably a drivers issue since PMF doesn't seem to be a hardware standard.
    It probably is, we won't know unless there is a specific mention in the change log for driver updates for the Surface pro.
    12-23-2018 09:04 PM

Similar Threads

  1. Pilot and record flights in 4K UHD with the $100 Yuneec Breeze Drone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-08-2018, 12:00 PM
  2. We're giving away THREE pairs of Surface Headphones!
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-08-2018, 09:00 AM
  3. Game Bar now lets you view and share screenshots in-game
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-07-2018, 05:00 PM
  4. Is the Surface Pro 6 good for gaming?
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-07-2018, 03:11 PM
  5. This 32GB Nintendo Switch was discounted just in time for the holidays
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-07-2018, 03:00 PM
LINK TO POST COPIED TO CLIPBOARD