1. Jugler's Avatar
    Hey guys!

    Has any one tried using bluetooth headphones with the Surface Pro 3? I have the motorola S10-HD, which I use with my Venue Pro 8, Cellphone, Surface RT, and they work perfectly.

    When using them with the Surface Pro 3 they just connect for a few seconds then disconnect, then reconnect over and over, some very limited times got them to work and play music. Most of the time they wont work tho.

    Any idea or any possible solution? This is my 2nd Surface Pro 3, and in both of them had the same issue.

    Thanks,
    ​J
    rdubmu likes this.
    07-29-2014 05:31 PM
  2. yonghong's Avatar
    I tried my BT headphone with SP3, it's working ,but with ipad&iphone the BT work hundred times better than SP3, it sucks ,drain battery a lot ,one time I turn off my BT headphone ,The SP3 is still play music 12 hours,finally dead on my sleeve, sucks ,never use it to listen much with BT.


    Sent from my 4318CTO using Tapatalk
    rdubmu likes this.
    07-30-2014 01:24 PM
  3. jrohland's Avatar
    I reported this same problem in the bugs thread at post #70.
    rdubmu likes this.
    07-30-2014 04:30 PM
  4. MRKV's Avatar
    I use a pair of Jabra Revo BT headphones and haven't had a problem with them at all
    rdubmu likes this.
    07-30-2014 06:19 PM
  5. hopmedic's Avatar
    I just linked my SP3 with my JBL Power-up two nights ago, and once connected, it worked flawlessly for several hours.
    rdubmu likes this.
    08-05-2014 08:45 AM
  6. cschmach's Avatar
    Hey guys!

    Has any one tried using bluetooth headphones with the Surface Pro 3? I have the motorola S10-HD, which I use with my Venue Pro 8, Cellphone, Surface RT, and they work perfectly.

    When using them with the Surface Pro 3 they just connect for a few seconds then disconnect, then reconnect over and over, some very limited times got them to work and play music. Most of the time they wont work tho.

    Any idea or any possible solution? This is my 2nd Surface Pro 3, and in both of them had the same issue.

    Thanks,
    ​J
    I have the Motorola S11-HD headphones and was having issues with them staying connected as well. I also have a Bose SoundLink Mini that I sometimes connect to my SP3 via Bluetooth without any issues (mostly wired through my monitor). I received my SP3 Docking Station yesterday and I was prompted for a Microsoft update for Audio Devices. Now I have no issues at all with my Motorola S11-HD's staying connected. The update changed my volume controls on my task bar and added an volume mixer. It may have been there before, but now it actually shows which device my audio is coming from.
    rdubmu likes this.
    08-16-2014 06:09 PM

Similar Threads

  1. Youtube for windows phone ?
    By goalkick520 in forum Ask a Question
    Replies: 12
    Last Post: 07-31-2014, 08:52 AM
  2. Replies: 16
    Last Post: 07-30-2014, 01:40 PM
  3. Does the Dell Venue 8 pro come with 8.1?
    By Ryzzlle in forum Ask a Question
    Replies: 7
    Last Post: 07-29-2014, 08:28 PM
  4. Official release date and time for your country
    By switch side method in forum Ask a Question
    Replies: 2
    Last Post: 07-29-2014, 05:34 PM
  5. Post you Instagram names here !!!! And follow everyone !!
    By darladaisy in forum Applications
    Replies: 2
    Last Post: 07-29-2014, 03:14 PM
LINK TO POST COPIED TO CLIPBOARD