1. smoheath's Avatar
    Just wanted to know if anyone else is encountering the problems in facing. I updated to Windows 10 and it updated quickly without any issues. The I noticed that Wifi wasn't working. It's the dang Marvell wireless adapter, it won't work. It's always been wonky. I went to device manager and tried reinstalling the drivers which were stored locally. That didn't work. I uninstalled the device and reinstalled and that didn't work. I tried the airplane mode on/off trick. That didn't work. I've had this issue with 8.1 but it usually was an easy fix. I tried to do the hardware reset by holding down the vol up and power buttons. I don't think this works in Windows 10 for some reason.

    I'm in the process of "refreshing" my surface pro 3 to see if it fixes it. Also, the brightness wasn't adjustable. It's pretty embarrassing that Microsoft can't get the drivers working on Windows 10 for their flagship PC. Anyone else experiencing these issues?
    07-29-2015 02:21 AM
  2. Jikangire's Avatar
    I am having a similar issue myself. After updating to Windows 10 Pro using the updater in Windows I too started having WiFi connection issues. My Surface Pro 3 will connect to the internet for about 30 seconds, then disconnect, then connect again for 30 seconds, and repeat. I really hope this issue is resolved ASAP!
    07-29-2015 02:57 AM
  3. lukeap69's Avatar
    Oh that's terrible. I guess my Windows 10 failed update is a blessing in disguise? :)

    Posted via the Windows Central App for Android
    07-29-2015 03:06 AM
  4. Chris-Simmons's Avatar
    Yes, I am having the same issues with the Marvell wireless adapter.
    Being trying for the last half hour to get it working but no luck. The Marvell AVASTAR Wireless-AC Network Controller is listed in Device Manager but I have zero network adapters listed.
    07-29-2015 04:24 AM
  5. Chris-Simmons's Avatar
    Managed to solve my issues by rolling back to Windows 8.1 (from the Recovery menu), uninstalling a VPN client I had installed as I thought it might be causing issues with the network adapters, and then re-downloading Windows 10 and running the update again.

    This time everything worked well and Wi-Fi is happy.
    Unsure if it was the VPN client, might have just been second time lucky!
    07-29-2015 06:22 AM
  6. Frankie Kung's Avatar
    Yes, I have same issue with zero network adapter. And I also have few VPN client installed. I 'm trying to uninstall those VPN client now ( no restore back in this moment) to see the result.
    07-29-2015 06:28 AM
  7. kenjancef's Avatar
    Updated my SP3 last night, have had no issues at all with WiFi, and I don't have any VPN software installed, so that just might be the issue. I read that a 1GB update is rolling out today, maybe there will be a fix hidden in there somewhere....
    07-29-2015 08:43 AM
  8. lucuma's Avatar
    I am having the same issue. In fact my USB wired ether net adapter doesn't work either (sp3). I wonder how I'll download such update to fix this.
    07-29-2015 09:15 AM
  9. smoheath's Avatar
    All my problems were fixed by reinstalling Windows 10 while keeping my files intact. I did lose all my programs though. Most of my stuff is easily downloadable from the store so I'm not too worried. One perk is that it's almost like a clean install. It was all relatively quick as well.
    07-29-2015 09:50 AM
  10. DMW3d's Avatar
    I had the same problem. I rolled back to 8.1, uninstalled my VPN client (and a few other things for the fun of it), and am about to try the upgrade again. Unfortunately, it's downloading the upgrade (all 2699 MB of it) again...
    07-29-2015 11:04 AM
  11. DMW3d's Avatar
    That did it. I'm up and running.
    07-29-2015 01:22 PM
  12. Grimlock's Avatar
    The surface pro 3 drivers are available on MS as a set- it's worth a shot trying to reinstall them.

    I updated from the ISO to W10 and did not keep anything and haven't had any driver issues. I really think it's worth doing a clean install after upgrading to W10 to avoid any headaches that could potentially happen immediately or down the road.

    One thing I was wondering is if the W10 ISO has all the surface pro 3 drivers included. I wasn't able to get the auto update to work so opted for the ISO install.
    07-29-2015 01:37 PM
  13. eusty's Avatar
    One thing I was wondering is if the W10 ISO has all the surface pro 3 drivers included. I wasn't able to get the auto update to work so opted for the ISO install.
    Yes it has :)
    08-03-2015 04:01 PM
  14. homeedition88's Avatar
    I solved some of the problems to installing latest firmware update from : https://www.microsoft.com/surface/en...?os=windows-10

    Download SurfacePro3_Win10_150723_0.msi and install it. It solved system & system interrupts problems for sure. Service Host problems are gone too. Let's give it a try :)
    08-03-2015 05:07 PM
  15. Avery Andrews's Avatar
    Installing the Surface3_Win10_150723.msi update at from the appropriate ms download page solved my problem, which was a sudden inability of the wireless chip to enable itself (on a surface 3, not LTE). Perhaps caused by an attempt to install an update that went wrong somehow (windows update thought it had a partially downloaded one when the machine fell into this state on morning wakeup).
    01-12-2016 08:19 PM
  16. Boyleaux's Avatar
    Thanks for the above link to the updates Surface3_Win10_150723.msi update has brought wifi back on line. Great help thank you!
    02-11-2016 11:49 AM
  17. Chasnmatail's Avatar
    After Upgrading to Windows 10 on Surface Pro 3 the WiFi stopped working and Network Settings reported the Marvell Wireless Hardware or Driver were the cause of the problem. I googled the problem and saw suggestions ranging from Rollback to Windows 8 & uninstall Cisco VPN or install a fresh copy of Windows OS. But, being naturally lazy I too a shot at Device Manager and found a little Yellow triangle with exclamation mark on the Marvell device listed under Network Adapters. I disabled it and enabled it and the Yellow triangle with exclamation mark cleared up and vola I am connected wifi again. Believe it or not was easy as that.
    06-06-2016 11:09 PM
  18. NEVA DAWN JENNINGS1's Avatar
    Also.i ahve windows 10 and mine is no.where n the device.lait it a bunch of others but none connect it says connect lile.qith ether net like umm I am paying for wifi
    11-15-2016 09:35 PM

Similar Threads

  1. Why I couldn't upgrade to Windows 10 in pc?
    By Karthik DK in forum Windows 10
    Replies: 10
    Last Post: 08-06-2015, 11:56 AM
  2. Replies: 1
    Last Post: 07-29-2015, 02:29 AM
  3. How to install Windows 10 after Technical preview?
    By Windows Central Question in forum Windows 10 Insider Preview
    Replies: 4
    Last Post: 07-29-2015, 02:09 AM
  4. Port Win8.1 start screen to your win10 installation?
    By eddieDOTexe in forum Windows 10
    Replies: 0
    Last Post: 07-29-2015, 02:09 AM
  5. Windows 10 Review
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 07-29-2015, 01:45 AM
LINK TO POST COPIED TO CLIPBOARD