1. Jikangire's Avatar
    Good evening everyone! I was really excited to be able to install the update to Windows 10 Pro on my Surface Pro 3 tonight, but unfortunately my excitement was cut short. After the Windows 10 upgrade completed successfully, without any issues, I logged in to Windows and the first thing I notice was no internet connectivity. I checked my network settings and was able to select the WiFi SSID that I normally connect to. Windows then connects to the internet for about 30 seconds, then the connection drops. About 30 seconds later the connection is reestablished, and another 30 seconds it's gone again. This cycle repeats over and over again. Has anyone else run into this problem since upgrading? What do you suggest I do to fix this issue? Thanks for any help you can provide!
    07-29-2015 01:32 AM
  2. Bigfireq's Avatar
    I had problems with the Wifi when I installed over the weekend, but I did a reset yesterday, and since then I haven't seen the problem. I don't know if it was a problem upgrading, or if the big patch that came out today took care of it.
    07-30-2015 02:48 AM
  3. Jikangire's Avatar
    When you say you did a reset, what exactly do you mean?
    07-30-2015 04:29 AM
  4. PrynceKee's Avatar
    I'm having this exact same issue on my laptop. It's worse it seems when my laptop isn't plugged in and drops the wifi in like 5 mins tops. I thought it was the power management settings and change it to maximum performance for on battery and plugged it. But, it still drops the connection. My drivers are up to date. Don't know if it installed a newer driver and I need to revert to an older one or what. But, it's annoying and I'm loving windows 10 otherwise so I don't want to go back to Windows 8. Anyone have any solutions?
    07-31-2015 09:14 PM
  5. Jikangire's Avatar
    Update: After installing the latest "System Firmware Update 7/23/2015" today, I now have no internet connectivity at all. The connection says it's "Limited", however in the taskbar it states "No internet access."
    08-02-2015 01:34 AM
  6. Jikangire's Avatar
    I decided to go ahead and completely wipe my Surface Pro 3 and install Windows 10 from scratch, (USB drive installation). Doing this seems to have completely solved the WiFi issue as everything is working perfectly now. Chalk it up to the OS upgrade issues VS doing a fresh install.
    Bluerain likes this.
    08-02-2015 06:24 AM

Similar Threads

  1. Updated to Windows 10, Driver Issues
    By smoheath in forum Microsoft Surface Pro 3
    Replies: 17
    Last Post: 11-15-2016, 08:35 PM
  2. I reserved a Windows 10 copy but when will I get the upgrade of Windows 10?
    By Windows Central Question in forum Windows 10
    Replies: 1
    Last Post: 07-29-2015, 01:35 AM
  3. Replies: 1
    Last Post: 07-29-2015, 01:29 AM
  4. How to install Windows 10 after Technical preview?
    By Windows Central Question in forum Windows 10 Insider Preview
    Replies: 4
    Last Post: 07-29-2015, 01:09 AM
  5. Replies: 1
    Last Post: 07-29-2015, 12:57 AM
LINK TO POST COPIED TO CLIPBOARD