1. kenjancef's Avatar
    Anyone have a "recommended USB 3.0 hub for the SP3? It seems I can't find one that works, especially with Windows 10. I've tried a few (manufacturer names escape me at the moment), but they all seem to not connect properly. The latest one is a unit called j5Create, which I got from Best Buy. When I plug it in, all I get are the connect/disconnet USB tones, and it never stabilizes until I unplug it. I shouldn't have to install any drivers for a hub, so nit sure what's going on.

    Any thoughts?
    08-18-2015 01:53 PM
  2. anders.ostling's Avatar
    Did you connect The hub to external power? The USB port on the SP3 is infamous for the low powered USB port.


    Skickat frn min iPad med Tapatalk
    08-18-2015 02:12 PM
  3. kenjancef's Avatar
    Did you connect The hub to external power? The USB port on the SP3 is infamous for the low powered USB port.
    Yea, the ones I tried all had external power. The last one, the j5Create, didn't even work at all if it wasn't plugged in, which I thought was kinda weird... Oh well, I'll just keep trying...

    Thanks for the reply... :)
    08-19-2015 08:56 AM
  4. bradatharmony's Avatar
    I just bought an Orico P10-U3 hub and connected to my SP3 dock. It works without a hitch....I haven't tried connecting it directly to the SP3.


    Sent from my 2015 Ram Ecodiesel.
    08-19-2015 03:47 PM

Similar Threads

  1. Why is Fresco Logic FL2000 USB 3.0 display adapter not working?
    By Windows Central Question in forum Windows 10
    Replies: 10
    Last Post: 12-20-2017, 05:49 PM
  2. Replies: 10
    Last Post: 08-30-2015, 07:55 AM
  3. Any recommendations on a Win 10 Mobile Tablet?
    By floppyedonkey in forum Windows 10 Mobile
    Replies: 6
    Last Post: 08-27-2015, 09:41 AM
  4. Replies: 0
    Last Post: 08-17-2015, 11:23 AM
  5. USB cable connection with Lumia 435
    By Chris Clayton1 in forum Windows Phone 8.1
    Replies: 0
    Last Post: 08-15-2015, 05:54 AM
LINK TO POST COPIED TO CLIPBOARD