1. Adorath's Avatar
    Hey guys,

    I use the SP3 Docking Station on my desk as workstation. Everything is working fine.

    Until last firmware update. Now my external display isn't working anymore!

    Anyone else having this problem or knows a fix for it?

    Thanks for your help!
    10-04-2015 11:02 AM
  2. daigen's Avatar
    I'm having the same issue
    10-25-2015 02:40 PM
  3. Hans Swolfs's Avatar
    same thing here :(

    all updates are installed, driver is up to date...
    It works perfectly when connected straight to my SP3 but that's missing the point of a dock...
    11-09-2015 01:51 PM
  4. Hans Swolfs's Avatar
    Talked to Microsoft and they are going to send a new one but don't think that'll help...
    11-09-2015 04:15 PM
  5. Hans Swolfs's Avatar
    and for some other reason, it just started working again? Did nothing but power on my SP3 this evening...
    11-10-2015 06:18 PM
  6. Hans Swolfs's Avatar
    So a new dock arrived today while my current one still works...
    11-13-2015 08:35 AM

Similar Threads

  1. Insider update
    By bomand in forum Windows 10 Mobile Insider Preview
    Replies: 7
    Last Post: 04-23-2016, 01:53 PM
  2. Weird issues with Surface Pen and OneNote
    By vc-10 in forum Microsoft Surface Pro 3
    Replies: 2
    Last Post: 10-18-2015, 05:37 AM
  3. SP3 won't load up - stuck at the Surface logo
    By pgg101 in forum Microsoft Surface Pro 3
    Replies: 6
    Last Post: 10-05-2015, 03:43 AM
  4. How long does the Windows 10 Xbox One update take?
    By A54D in forum The Xbox Lounge
    Replies: 1
    Last Post: 10-04-2015, 12:10 PM
  5. Inconsistency in displayed content between Win8 and 10, how can I fix it?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 10-04-2015, 09:29 AM
LINK TO POST COPIED TO CLIPBOARD