1. EMitchell's Avatar
    I finally got around to installing some Windows updates, including a FW update from 10.29.15 (?). Everything went smoothly, except now my volume buttons, power button and home buttons don't work. I remember when I first got my Surface Pro3 it was like this as well, but I don't remember what I did to resolve it. I do remember these buttons are enabled / disabled together.

    I checked the Surface Home Button setting in Device Manager, it says The Device Cannot Start (code 10). I uninstalled the driver (didn't delete), and rebooted. No change.

    Any suggestions?
    12-09-2015 04:56 AM
  2. eusty's Avatar
    Like you I saw this after installing W10, and like you I can't remember what I did to get them back!

    You could try reinstalling the drivers
    12-14-2015 05:33 PM
  3. EMitchell's Avatar
    Resolution: turns out there was a corrupted .inf file. Working with MS tech support, we narrowed it down to that, deleted the .inf file, deleted the driver, and rebooted. Reinstalled the driver, everything is back to normal.
    eusty and djdjalel93 like this.
    12-21-2015 11:24 AM
  4. Wangsy1005's Avatar
    Hi,
    I'm experiencing the same problem on my surface 3; Could you tell me the specific file needs to be deleted?
    Rly appreciate your help!
    djdjalel93 likes this.
    01-01-2016 11:58 AM
  5. djdjalel93's Avatar
    Hello,
    please could you be more specefic about the .inf file, the full name, I m having the same problem clearely.
    Peace.
    01-25-2017 01:38 PM
  6. EMitchell's Avatar
    Hello,
    please could you be more specefic about the .inf file, the full name, I m having the same problem clearely.
    Peace.
    Unfortunately I don't remember, it's been too long. I wish I would have taken notes.
    01-29-2017 04:30 PM
  7. jahciple's Avatar
    Unfortunately I don't remember, it's been too long. I wish I would have taken notes.
    Try updating to the latest Windows 10 drivers.
    03-06-2017 11:40 PM
  8. fishhead_soup's Avatar
    Old post same problem with my solution, at least on my Surface3.

    Go to

    Device Manager > System Devices > Surface Home Button > Enable

    Sure volume rocker now works, however so does the home button and occasionally the narrator turn on. If its not one thing...
    11-19-2017 09:15 AM
  9. DJSweeney's Avatar
    Found a solution to the power, volume and start button not working on my Surface 3 running Windows 10...

    Since this was originally an upgrade from Windows 8.1, Device Manager had "Surface Button" listed under System Devices, NOT "Surface Home Button". This apparently blocked installation of the correct driver.

    Solution (for me) was (in Device Manager, under System Devices) to right-click on "Surface Button", select "Uninstall Device", check the "Delete the driver software for this device", and click the "Uninstall" button. After uninstall, reboot the Surface.

    Once I rebooted, Windows 10 properly detected and installed the "Surface Home Button" and all my buttons are working as expected.
    05-18-2018 06:27 AM

Similar Threads

  1. Lenses feature not working
    By Chintan Gohel in forum Windows 10 Mobile Insider Preview
    Replies: 5
    Last Post: 01-04-2016, 10:30 AM
  2. New button layout - not a fan
    By D3V011 in forum Microsoft Lumia 950 XL
    Replies: 10
    Last Post: 12-09-2015, 01:53 PM
  3. Not received Denim update!
    By daymouse in forum Nokia Lumia 930
    Replies: 3
    Last Post: 12-09-2015, 05:49 AM
  4. Propellerhead's Figure lets you quickly create beats on Windows 10 and Windows 10 Mobile
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-09-2015, 12:42 AM
  5. Replies: 0
    Last Post: 12-08-2015, 11:12 PM
LINK TO POST COPIED TO CLIPBOARD