1. d1stort1on's Avatar
    My Surface Pro 3 generally works very well. I've sort of discovered a problem where if Adobe Creative Cloud is installed, response to the touch screen in apps gets really inconsistent and buggy. Essentially, if CC is installed, the screen won't register touches or swipes correctly. For example, Chrome wasn't registering closing the window to tapping on links, Mail wasn't registering swipes to delete or taps to select/view an email. I'm wondering if it is because of all the stuff Adobe has running in the background. Has anybody else experienced this?
    03-23-2016 04:27 PM
  2. gernerttl's Avatar
    Try updating Adobe CC. There were some updates recently.
    04-01-2016 04:32 PM
  3. EMitchell's Avatar
    Tough to say. I've got Adobe CC installed, and every now and then things do start acting up with touch responses, and even mouse clicks. I hadn't associated it with CC, I just thought it had been long enough since my last reboot that it was time. Rebooting seems to clean everything up.
    04-05-2016 08:53 PM
  4. d1stort1on's Avatar
    Well I tried again (probably the fourth time now, lol). I needed Acrobat and thought I might as well put photoshop and illustrator back on and turned off a lot of the background functions in the Creative Cloud App. Wonky at first, but it was downloading updates. After that it seemed ok (just OK not great), but again it started to get bad. I think reboots may have helped since I was doing that too. Ended up completely uninstalling CC and OMG, the whole surface was more responsive and quicker. I really think all the background stuff CC is doing really craps up the system.
    04-06-2016 04:37 AM

Similar Threads

  1. lumia 950 win 10, in app login problems
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 04-15-2016, 10:12 AM
  2. Replies: 10
    Last Post: 03-29-2016, 12:52 PM
  3. Bluetoooth problem
    By Arizona Willie in forum Microsoft Lumia 640 XL
    Replies: 4
    Last Post: 03-23-2016, 06:42 PM
  4. Replies: 1
    Last Post: 03-23-2016, 02:42 PM
  5. W10m official Lumia 640 wifi problem
    By prasanna moholkar in forum Ask a Question
    Replies: 2
    Last Post: 03-23-2016, 01:40 PM
LINK TO POST COPIED TO CLIPBOARD