1. TechBob's Avatar
    I have had my SP3 for about a month, a refurb from Microsoft. This is actually my second, as the first one overheated pretty easily. This one has been fairly cool, until today. I watched, or tried to watch a movie from Amazon Prime and it was less than successful. First, let me say that I tried multiple browsers including Chrome and Firefox. What I found is that the screen would start jumping around, the full screen would drop out and the back got very hot. This was with both browsers. I also found that when I was watching the video, parts of the movie were hard to watch. Normally lit scenes looked absolutely fine with expected brightness, but dimly lit scenes were way too dark, virtually blank. Those same scenes are viewable on my other devices, both Android and Windows.

    Has anyone else experienced this? Suggestions?
    04-01-2016 11:04 PM
  2. realwarder's Avatar
    Sounds like a video driver issue. Use Device Manager and check for an update on the Intel HD Display driver. If none exist, may be worth downloading the beta from Intel Downloads website for the 5th Gen Intel HD Laptop Display Driver. You can unzip and use upgrade from folder to install.
    04-01-2016 11:40 PM

Similar Threads

  1. Why is my Nokia Lumia 520 wifi feature not working?
    By Windows Central Question in forum Nokia Lumia 520
    Replies: 1
    Last Post: 04-02-2016, 01:19 AM
  2. Replies: 1
    Last Post: 04-02-2016, 12:51 AM
  3. Is my phone broken, I'm stuck on the start pin code screen after upgrade?
    By Windows Central Question in forum Microsoft Lumia 640 XL
    Replies: 1
    Last Post: 04-01-2016, 11:51 PM
  4. Replies: 1
    Last Post: 04-01-2016, 07:25 PM
  5. EA kicks off Origin Spring Sale with up to 50% off PC games and DLC
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-01-2016, 06:11 PM
LINK TO POST COPIED TO CLIPBOARD