1. tjg55's Avatar
    I have WOW cable, 500 Mbps speed. My iPhone 8 actually clocks in at 530 Mbps most days. The most I can achieve with my Surface Pro 3 is 130 Mbps. I called WOW tech support, and they said its clear they are delivering 500 Mbps, so this must be a settings issue (or limitation) with my Surface Pro 3. I am using the 5.0 channel on WiFi, and sitting about 10 feet away from the WOW modem/router unit. THanks.
    02-16-2018 08:21 AM
  2. xandros9's Avatar
    How are you measuring speed?
    02-16-2018 10:03 AM
  3. grape8pe2's Avatar
    The best I can get with local Wi-Fi transfers on my SP3 (my Internet speed is only 100Mbps) is about 250-300Mbps. My access point is a Ubiquity AC Lite. Hope this helps.
    02-25-2018 07:23 AM

Similar Threads

  1. How to pick the right AMD Ryzen CPU for your PC
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-16-2018, 08:10 AM
  2. Xbox One 1440p support coming 'very soon' to Xbox One X and Xbox One S
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-16-2018, 06:50 AM
  3. How to fix Windows Mixed Reality software download errors
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-16-2018, 06:10 AM
  4. Replies: 0
    Last Post: 02-16-2018, 05:47 AM
  5. Microsoft Store fails to load code: 0x00000193
    By Nate W in forum Windows 10 Mobile
    Replies: 0
    Last Post: 02-15-2018, 07:19 PM
LINK TO POST COPIED TO CLIPBOARD