1. Rafaelcab's Avatar
    I just upgraded from the Pro 3 to the Pro 4 and am loving the better heat and fan management of the new system, but it seems that when I restart or power on the surface it sits for a while on the logo screen before coming. Also I am finding small bugs here and there, just yesterday it froze on me while surfing the web. Anyone else having my or any issues? I upgraded to windows 10 on my pro 3, but it was so terrible I reverted back to windows 8.1. I feel that windows 10, though the potential is there for a great operating system, it was half baked and rushed to market or maybe its just my luck.
    10-27-2015 10:33 AM
  2. ParoleGA's Avatar
    What kind of issues were you having on your Pro 3? Just curious. I have been running my Pro 3 on Win10 for quite a while now, and haven't had any issue at all. I don't run tablet mode often, and it spends most of its time in a dock on my work desk. I did have an issue with the USB and Ethernet ports on the dock for a minute. I thought it was a bad dock, but then saw a "needs to finish installing" message in the action center. Finished, and no more issues. I also don't use Edge (extensions or not for me).
    10-27-2015 10:47 AM
  3. Nutmegz's Avatar
    Biggest problem I have with windows 10 is it's scaling still sucks big time. Have to scale, I can't see anything at 100% scaling.
    10-27-2015 10:49 AM
  4. Rafaelcab's Avatar
    What kind of issues were you having on your Pro 3? Just curious. I have been running my Pro 3 on Win10 for quite a while now, and haven't had any issue at all. I don't run tablet mode often, and it spends most of its time in a dock on my work desk. I did have an issue with the USB and Ethernet ports on the dock for a minute. I thought it was a bad dock, but then saw a "needs to finish installing" message in the action center. Finished, and no more issues. I also don't use Edge (extensions or not for me).
    I used my pro 3 on the go most of the time, but the issues that I had after upgrading was that it would always get hot quickly in-turn kicking on the fan and because of that the battery life was horrible. Also as I mentioned above with my pro 4 when restarting or powering on it would be stuck on the surface logo for a good minute before actually booting up.
    10-27-2015 12:12 PM
  5. ParoleGA's Avatar
    I used my pro 3 on the go most of the time, but the issues that I had after upgrading was that it would always get hot quickly in-turn kicking on the fan and because of that the battery life was horrible. Also as I mentioned above with my pro 4 when restarting or powering on it would be stuck on the surface logo for a good minute before actually booting up.
    Ah, gotcha. Interesting how different use scenarios can turn up bugs someone else might not see. My fan does kick on occasionally, but I don't notice it more than I did on 8.1. I also hadn't noticed a battery life hit, but spending most of its life in a dock, I probably wouldn't. I also don't shut it down often, so if there is a hang on boot up, I wouldn't see it. It does wake from sleep plenty quick.
    10-27-2015 12:40 PM
  6. Nutmegz's Avatar
    Try restarting the SP4 without the keyboard attached. I notice it takes a lot longer with the keyboard attached then without.
    10-27-2015 01:48 PM
  7. Rafaelcab's Avatar
    Since the update to support the windows hello camera features. my battery life has been horrible. When not in use the battery drained from 73% to 46% in 4 hours. is the battery drain normal if not any fixes I can do?
    10-28-2015 11:08 AM

Similar Threads

  1. Type Cover with Fingerprint ID Not Needed?
    By DLong4 in forum Microsoft Surface Pro 4
    Replies: 25
    Last Post: 03-04-2017, 01:24 PM
  2. Replies: 4
    Last Post: 04-27-2016, 08:14 AM
  3. Can't sync Windows 10 Mail error code 0x85002012, how can I fix this?
    By Windows Central Question in forum Windows 10
    Replies: 1
    Last Post: 10-27-2015, 11:56 AM
  4. Slack for Windows desktop updated with new MSI installer, Chromium 45 support and more
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 10-27-2015, 10:00 AM
  5. How do I get rid of message threads on the Lumia 435 phone?
    By Windows Central Question in forum Microsoft Lumia 435
    Replies: 1
    Last Post: 10-27-2015, 09:26 AM
LINK TO POST COPIED TO CLIPBOARD