1. iPhoneatWork's Avatar
    I have noticed that within the last two weeks when I type using the Surface Pro 4 keyboard that I will get an occasional short squeak or squeal from the speakers. It sounds like some sort of an error with the sound card. It usually happens when I hit the shift key when typing, but I can't reproduce the error. I happens about 4-5 times daily.

    Anyone else have this happen? I'm trying to figure out if its the keyboard producing an error or if it is Windows 10 or the hardware itself.

    Can someone try my method below and see if you have the same problem?

    Thanks!

    Update: So I can now reproduce the problem. If I restart the Surface 4, log-in to to windows, then once logged in immediately press ctrl-z on the keyboard...it squeals. I can reproduce this every time. I will try a usb keyboard next.

    Update 2: Tried usb keyboard and had same issue. This is a sound card driver issue it seems. I deleted both sound drivers from the devices panel...then ran a windows update check. It reported that the system hardware update of 12/17/15 needed to be downloaded again. Applied the update, rebooted, and same problem. I will have to wait until next hardware update in hopes of fix.
    Last edited by iPhoneatWork; 12-29-2015 at 04:05 PM.
    12-29-2015 02:40 PM
  2. MikeHummel's Avatar
    Did you get this issue fixed? I had the same issue and I found out what it was.....Just wanted to check before I go into what the issue is..
    01-03-2016 08:08 AM
  3. Justin Dixon2's Avatar
    Care to share the solution?
    01-03-2016 04:16 PM
  4. iPhoneatWork's Avatar
    I ended up reformatting and reloading Windows 10 to correct the issue. All is well now. It must have been corrupted software in Windows. At least I now know it's not a hardware issue.

    Thanks!
    01-04-2016 10:41 PM
  5. Grimmric's Avatar
    It seems like they sometimes ships with a bad installation of win 10.
    I could't do a system recovery drive. Only got an error.
    So i had to do a new install of win 10 and that fixed the problem.
    01-05-2016 01:30 AM

Similar Threads

  1. Step count from phone to Band 2
    By indiW in forum Microsoft Band & Band 2
    Replies: 8
    Last Post: 12-30-2015, 04:58 PM
  2. Lumia 550: How do I show the incoming contact when they call me?
    By Windows Central Question in forum Microsoft Lumia 550
    Replies: 1
    Last Post: 12-29-2015, 03:15 PM
  3. Grab TechMatte's USB Type-C cable for just $7 at Amazon with coupon code
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-29-2015, 01:42 PM
  4. Replies: 1
    Last Post: 12-29-2015, 10:33 AM
  5. Uk three sim say I'm using phone as hot spot when its turned off
    By crispinchurch in forum Windows 10 Mobile
    Replies: 0
    Last Post: 12-29-2015, 08:51 AM
LINK TO POST COPIED TO CLIPBOARD