1. Steveborough's Avatar
    Anyone else experiencing this: While CPU is at nominal utilization I often experience significant lag doing mundane things like:
    • typing into Cortana, keystrokes are delayed by 3 or so seconds
    • Launching a new tab in edge takes 5 seconds
    • the cursor moves in slomo when moving around the screen
    • My favorite game, Asphalt 8 is unplayable due to significant frame drops and control lag
    • Launching Task Manager is the equivalent of launching Photoshop on an 486 and consumes 40% CPU for 25 seconds


    Nothing has changed other than updates on my i5 8GB RAM, I thought the days of reinstalling the OS on your computer every 4 months was over! My SP4 is running like pure crap right now! Mainly wondering if a recent update may have bonked my system.

    Update:
    seems to be a problem with Cortana that many others are also experiencing, killing the "Cortana" process (automatically restarts) seems to fix it for a while.
    Last edited by Steveborough; 12-28-2016 at 10:51 PM.
    CrownedMartyr likes this.
    12-28-2016 10:40 PM
  2. rdubmu's Avatar
    I am not experiencing this.
    12-29-2016 03:13 AM
  3. michail71's Avatar
    I see some of these things periodically. Sometimes keyboard lag happens.

    Most issues are usually Edge acting up but usually it's nice and fast.
    12-29-2016 03:36 PM
  4. excalibur1814's Avatar
    "reinstalling the OS on your computer every 4 months was over! My SP4 is running like pure crap right now! "

    It is. How do we know what you've installed? Chrome, iTunes, other software?! Each time you venture towards Cortana it will go online so how fast is your connection? There's SO many possibilities as to why.
    12-30-2016 01:31 PM
  5. CrownedMartyr's Avatar
    I have been experiencing the same exact thing for the past week or so. Certain activities seem fine, but others like opening emails in Outlook or even typing in Notepad are extremely slow, with very low CPU utilization. I've tried disabling all non-Microsoft services and programs at boot which did not resolve the issue. Booting to Safe Mode did, however.

    It's bad enough that I may try reinstalling Windows.
    01-14-2017 02:15 PM
  6. mclark2112's Avatar
    Same thing here, frequent slowdowns or freezes. Seems that OneNote and Outlook are always involved. I have the i7 16gb RAM Surface, this is a recent thing. Must be a bad update to something.
    01-14-2017 03:25 PM
  7. CrownedMartyr's Avatar
    Just out of curiosity - does anyone have any Egnyte products installed? I discovered that it was Egynte Drive that was causing my performance issues. Uninstalling the software fixed this for me.
    excalibur1814 likes this.
    01-15-2017 09:03 AM
  8. CraigCole's Avatar
    Edge makes my SP4 grind to a halt. If I have Facebook open in a tab for more than 30 minutes it's deadly; ditto for Tweet Deck. Something about this browser just sucks the system's resources.
    01-16-2017 05:58 PM
  9. Steveborough's Avatar
    150Mbs symmetrical, only windows store apps plus Office 2016, PhotoShop CC and Traktor 2; resident programs, just OneDrive and Defender... such a sh!tshow...its like owning a moody cat!
    02-23-2017 11:21 PM

Similar Threads

  1. Using 2 UHD monitors with sp4 dock?
    By richard granberg in forum Microsoft Surface Pro 4
    Replies: 1
    Last Post: 12-28-2016, 04:49 AM
  2. Better pen for pencil sketching on SP4
    By Curtis Reynolds in forum Microsoft Surface Pro 4
    Replies: 2
    Last Post: 12-25-2016, 08:45 PM
  3. More SP4 fan activity since latest cumulative update
    By HarnessTech in forum Microsoft Surface Pro 4
    Replies: 0
    Last Post: 12-21-2016, 04:32 PM
  4. SP4 I5 4gig model and lightroom
    By Edenwolf in forum Microsoft Surface Pro 4
    Replies: 5
    Last Post: 12-18-2016, 05:12 AM
  5. Surface Pro 3 dock with SP4
    By rdubmu in forum Microsoft Surface Pro 4
    Replies: 2
    Last Post: 12-14-2016, 02:28 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.