1. Patrice Miron's Avatar
    My Surface Pro 4 - i5, 256gb is driving me crazy ...

    W10 OS : 1703

    Since more than 6 months my type cover is not working. From times to times it was, for a short period of time (1-2 days) but stopped right after.

    I tried to refesh and do the super mega refresh thing with iso... I tried the Volume up \ Power button combination that's booting the device in Bios mode. I tried the disconnect and reconnect of the keyboard with no success.

    I keep having a feeling it has to do with the fact that I used a second screen for a lot of times. Maybe it's the 4k that ending up messing it up.

    I looked a lot online and while there were a lot of people talking about these issues, it was almost always separetly.

    Interestingly, the type keyboard does appear in my device manager.

    Anyway, I am about to throw it away since I tried everything, even called MS but ending up having more knowledge that the guy I was speaking to.

    So I turn here as my last chance, I am willing to try everything.

    thanks in advance !
    07-24-2017 07:49 PM
  2. techiez's Avatar
    I think you should demand a replacement
    07-25-2017 03:23 AM
  3. rdubmu's Avatar
    It could be an issue with the keyboard itself or the connectors to the pro to or from the pro 4
    07-25-2017 01:27 PM
  4. Patrice Miron's Avatar
    I think you should demand a replacement
    Humm , I am out of warranty since Jan 17....

    The cost of it is around 400$ us.

    I feel a little bit betrayed by MS...

    But I sure do think about it !
    07-28-2017 04:24 PM
  5. Patrice Miron's Avatar
    It could be an issue with the keyboard itself or the connectors to the pro to or from the pro 4
    So I got myself a brand new keyboard, did not work....

    I cleaned up my connections using 99.9 alcohol, did not work out either...

    Is there a way to scan the device to know about these issues, like having information if hardware is malfunctioning?
    07-28-2017 04:27 PM
  6. womble_be's Avatar
    I'm not sure if this will fix your problem but a few weeks ago my surface stopped recognising the keyboard existed (after a windows update). I tried all sorts including cleaning contacts and a reset of the surface nothing worked.

    in my case the "Surface type cover filter device" did not appear in device manager but HID keyboard did.

    Searching the internet I found this which fixed it immediately...

    It is not quite the normal power+volume up that people suggest to get into UEFI to see if the keyboard works there. They say this means the keyboard is broken but my keyboard did not work in UEFI either but the following fixed it.

    1. With your surface on. Press and hold power button for 30 seconds.

    2. Wait 10 seconds

    3. Press Volume up + Power for 15 seconds. The UEFI screen will come on (maybe more than once) but keep the buttons pressed. If after 15 seconds the UEFI screen is displayed keep the buttons pressed until it disappears.

    4. Wait 10 seconds.

    5. Press power to switch on as normal.

    The keyboard was working. I went to Windows update and it was also downloading a new set of drivers (maybe this was coincidence...but it was a couple of days after i had installed the last update of drivers so not expected...Strangely it was downloading all sorts of drivers not just the keyboard).



    I hope this helps. Like you I was getting really desperate.

    If this doesn't work and the "surface type cover filter device" does appear in device manager, I saw somewhere to try deleting it in device manager and restarting it (but maybe you already tried this.

    Best of luck
    07-28-2017 06:30 PM
  7. womble_be's Avatar
    Sorry about the formatting...I had it all beautifully spaced out in paragraphs...but it was all stripped out when I submitted it.
    Patrice Miron likes this.
    07-28-2017 06:32 PM
  8. jdfxp2018's Avatar
    Same problem here.

    Surface PRO 3 128GB

    Not just you and I, I researched and verified that many users this week have the same problem.

    I have 2 Type Cover and none works. As long as I reinstalled Windows one hour worked, the other day was no longer working. It seems to me that Surface can not load the drivers when connected or restarted.
    07-29-2017 05:54 PM
  9. jdfxp2018's Avatar
    07-29-2017 06:10 PM
  10. Patrice Miron's Avatar
    Thanks for the time you took but it did not work ....
    08-01-2017 01:13 PM
  11. Patrice Miron's Avatar
    One thing that is weird is that rigth after the Srrface loading screen and the moment the lock screen is loading, my mouse on my keyboard is moving like for 2 seconds everytime I restart ou power up my surface....
    08-01-2017 01:15 PM
  12. John Jackson15's Avatar
    this may sound too obvious but make sure you are not in tablet mode and you have auto rotation on.
    08-09-2017 08:58 PM
  13. mnatch's Avatar
    My Surface Pro 4 - i5, 256gb is driving me crazy ...

    W10 OS : 1703

    Since more than 6 months my type cover is not working. From times to times it was, for a short period of time (1-2 days) but stopped right after.

    I tried to refesh and do the super mega refresh thing with iso... I tried the Volume up \ Power button combination that's booting the device in Bios mode. I tried the disconnect and reconnect of the keyboard with no success.

    I keep having a feeling it has to do with the fact that I used a second screen for a lot of times. Maybe it's the 4k that ending up messing it up.

    I looked a lot online and while there were a lot of people talking about these issues, it was almost always separetly.

    Interestingly, the type keyboard does appear in my device manager.

    Anyway, I am about to throw it away since I tried everything, even called MS but ending up having more knowledge that the guy I was speaking to.

    So I turn here as my last chance, I am willing to try everything.

    thanks in advance !

    Hi Patrice, I have a Surface Pro 3 and my type cover is not working either. Surface cover filter device is missing from the Device manager and I tried all sorts of resets and two-button shutdown, installing the updates again. Nothing seems to be working. I'm really frustrated as well. The only option given to those who are out of warranty is pay another 450 pounds and even then there seems to be no guarantee that it'll work. This clearly seems to be a software issue. Guys, please take it to social media with the hashtag #SurfaceProSucks . At least then, Microsoft will hear to our pleas when enough number of consumers show their frustration. It's really annoying with literally no support from Microsoft.
    11-09-2018 02:56 AM

Similar Threads

  1. Replies: 13
    Last Post: 09-12-2017, 09:40 AM
  2. Replies: 2
    Last Post: 07-26-2017, 05:54 AM
  3. How to connect multiplayer between pc and android?
    By raul rocks in forum Windows 10
    Replies: 2
    Last Post: 07-24-2017, 09:39 PM
  4. Is there a magnetic cover for the surface pro without a keyboard?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 07-24-2017, 04:44 PM
  5. Try some over-ear Bluetooth headphones for just $20 right now
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-24-2017, 04:40 PM
LINK TO POST COPIED TO CLIPBOARD