Shop Holiday deals at:Amazon | Walmart | Best Buy | Microsoft | Dell

  1. raxy21's Avatar
    I got my SP2 1week back and updated it to recent February update and i am seeing screening flickering issue when i watch a movie the screen brightness automatically decreases and increases even with adaptive brightness switched off,
    how to correct this issue?
    03-09-2014 08:06 AM
  2. MBytes's Avatar
    Your friend, from MBytes (GoodBytes there).
    Surface Tweak Tool for Surface Pro 2 - Release!

    :)

    Still in the works. New version coming soon.
    raxy21 likes this.
    03-09-2014 11:35 PM
  3. raxy21's Avatar
    Your friend, from MBytes (GoodBytes there).
    Surface Tweak Tool for Surface Pro 2 - Release!

    :)

    Still in the works. New version coming soon.
    Thank you i will try it when i get home.��
    03-10-2014 07:51 AM
  4. raxy21's Avatar
    Your friend, from MBytes (GoodBytes there).
    Surface Tweak Tool for Surface Pro 2 - Release!

    :)

    Still in the works. New version coming soon.
    may be it still in beta days why it is not working perfectly for me it reduces the flickering issue but not completely.
    03-11-2014 01:31 PM
  5. MBytes's Avatar
    may be it still in beta days why it is not working perfectly for me it reduces the flickering issue but not completely.
    Works for me. What is your driver of your Intel graphic card (you can see this on the System information section of Surface Tweak Tool:
    I have (I did not install the new March firmware yet): 10.18.10.3262

    If you draw a large gradient (preferably full screen) from white to black, do you see stepping?
    Does it happen all the time? Or only when on battery or when plugged in only?

    Of course, I assume you restarted your system when you changed the setting in Surface Tweak tool.
    03-11-2014 02:03 PM
  6. raxy21's Avatar
    Yes i restarted it and it happens only on battery and yesterday i just updated it to march firware but it shutoff my WiFi so i reverted it back now still on February Intel driver which i downloaded from Microsoft support.
    03-13-2014 09:19 AM
  7. MBytes's Avatar
    I installed the March firmware yesterday, and everything works perfectly on my side.
    Can you explain the screen flickering issue. Is it really turning off and on all the time?
    Or the screen dimms down and back up?
    Or something else?
    03-13-2014 09:44 AM
  8. randomscandinavian's Avatar
    My impression is that screen flickering here refers to the jerky delayed way the display adjusts to a darker/lighter screen image, am I right? It kind of cycles through a few steps to get where it is going. It takes a few seconds instead of an immediate adjust or a quick smoth fade. This is not directly related to banding since it is the same with the intel drivers as well, although less prominent. Perhaps because there are more gradients to step through so the adjustment seems less jerky.

    I wouldn't be surprised if this is just how the Surface display power/brightness control is wired. Something we have to live with in that case. I think most people don't even see it. I do.
    raxy21 likes this.
    03-13-2014 05:57 PM
  9. MBytes's Avatar
    My impression is that screen flickering here refers to the jerky delayed way the display adjusts to a darker/lighter screen image, am I right? It kind of cycles through a few steps to get where it is going. It takes a few seconds instead of an immediate adjust or a quick smoth fade. This is not directly related to banding since it is the same with the intel drivers as well, although less prominent. Perhaps because there are more gradients to step through so the adjustment seems less jerky..
    Open the Intel Control Panel:
    1- Go to Display -> Color -> Advanced. Set Color Gammut to Vivid Colors -> Apply
    2- Back to the home screen, click on Video -> Set Everything to Application Settings -> Apply
    3- Then go under Advanced. Set Total Color Correction to Disabled. -> Apply
    4- Click on Video on top , and select Image Enhancement. Set Skin Tone Enhancement to Disable, and Sharpness to Application Settings.
    Now click on Advances, set Contrast Enhancement to Disable, set Film Mode Detection to Disable, and Noise reduction to Application Settings -> Apply.

    Almost done fixing Intel crap default settings
    5- Click on Video on top again -> select: Gamut Mapping. Set Gamut Compression to Disabled -> Apply
    6- Now back to the main screen, click on Power -> On Battery. Set Display Power Saving Technology to Disable -> Apply

    Now if I didn't forget anything, your problem should be fixed.

    I know flickering, I am sensitive to PWM driven LED backlight LCD display. That is also why I hate LED Christmas tree that are not high quality as I feel the light flickering at a high rate. Cheap panels uses PWM (Pulse width modulation) to control the backlight, good displays uses much more costly dimmer circuit, and requires much more costly LEDs that works with a dimmer circuit. I picked the Surface Pro 2 because it uses a dimmer circuit from 30% brightness and up, anything bellow is on PWM, however because it is low light, it doesn't affect me. So I am very happy.

    You may be able to see it in action, by sliding smoothly and slowly the screen brightness up and down in Windows, at around 30% and bellow it should not look smooth transition of brightness as it is at higher brightness.
    Last edited by MBytes; 03-13-2014 at 07:49 PM.
    03-13-2014 07:39 PM
  10. raxy21's Avatar
    Open the Intel Control Panel:
    1- Go to Display -> Color -> Advanced. Set Color Gammut to Vivid Colors -> Apply
    2- Back to the home screen, click on Video -> Set Everything to Application Settings -> Apply
    3- Then go under Advanced. Set Total Color Correction to Disabled. -> Apply
    4- Click on Video on top , and select Image Enhancement. Set Skin Tone Enhancement to Disable, and Sharpness to Application Settings.
    Now click on Advances, set Contrast Enhancement to Disable, set Film Mode Detection to Disable, and Noise reduction to Application Settings -> Apply.

    Almost done fixing Intel crap default settings
    5- Click on Video on top again -> select: Gamut Mapping. Set Gamut Compression to Disabled -> Apply
    6- Now back to the main screen, click on Power -> On Battery. Set Display Power Saving Technology to Disable -> Apply

    Now if I didn't forget anything, your problem should be fixed.

    I know flickering, I am sensitive to PWM driven LED backlight LCD display. That is also why I hate LED Christmas tree that are not high quality as I feel the light flickering at a high rate. Cheap panels uses PWM (Pulse width modulation) to control the backlight, good displays uses much more costly dimmer circuit, and requires much more costly LEDs that works with a dimmer circuit. I picked the Surface Pro 2 because it uses a dimmer circuit from 30% brightness and up, anything bellow is on PWM, however because it is low light, it doesn't affect me. So I am very happy.

    You may be able to see it in action, by sliding smoothly and slowly the screen brightness up and down in Windows, at around 30% and bellow it should not look smooth transition of brightness as it is at higher brightness.
    My impression is that screen flickering here refers to the jerky delayed way the display adjusts to a darker/lighter screen image, am I right? It kind of cycles through a few steps to get where it is going. It takes a few seconds instead of an immediate adjust or a quick smoth fade. This is not directly related to banding since it is the same with the intel drivers as well, although less prominent. Perhaps because there are more gradients to step through so the adjustment seems less jerky.

    I wouldn't be surprised if this is just how the Surface display power/brightness control is wired. Something we have to live with in that case. I think most people don't even see it. I do.
    yes it is the same problem display adjusts to brighter or darker scene in a video very slowly. I thought it was the flickering issue, how to correct it?
    03-15-2014 09:13 AM
  11. taymur's Avatar
    I realized its because of the charger connection, make sure its tight. That's what happened to me.
    03-15-2014 09:17 AM
  12. MBytes's Avatar
    yes it is the same problem display adjusts to brighter or darker scene in a video very slowly. I thought it was the flickering issue, how to correct it?
    Follow the instruction that I listed, and your problem will be solved.
    03-15-2014 10:06 AM
  13. squadz's Avatar
    I realized its because of the charger connection, make sure its tight. That's what happened to me.
    This.
    03-17-2014 06:19 PM

Similar Threads

  1. Lumia 920 screen discoloration
    By Parteek Agnihotri in forum Windows Phones
    Replies: 3
    Last Post: 09-25-2014, 02:57 PM
  2. Random screen crack
    By 01mggt in forum Windows Phones
    Replies: 2
    Last Post: 03-10-2014, 12:02 PM
  3. Potential Start Screen UI change in WP8.5
    By DreadVenom in forum Other Operating Systems
    Replies: 9
    Last Post: 03-09-2014, 06:17 AM
  4. Wet apply screen protectors
    By siddharth1102 in forum Windows Phones
    Replies: 0
    Last Post: 03-08-2014, 09:03 AM
  5. Lumia 1520 screen damaged - New out of box
    By Toussaint Jongen in forum Windows Phones
    Replies: 10
    Last Post: 03-08-2014, 01:26 AM
LINK TO POST COPIED TO CLIPBOARD