Surface Duo is on salefor over 50% off!

  1. Jugler's Avatar
    So I bought my Surface Pro 3 today, everything about this device is awesome.

    In the first hours I was happily showing off to everyone at work how to write notes even when the device was locked by clicking the Pen and OneNote coming up, it worked every single time, like in the ads.

    Then I updated everything, installed Visual Studio and some of my metro apps (facebook, netflix, hulu)

    After that I tried to use the pen to go from lockscreen to OneNote with no success, I know it tries to do something because when I press the button twice it goes from lock screen to put your password screen, but it no longer wakes the Surface up or lets me writes notes while locked.

    When its unlocked it still lets me go to onenote when pressing the button.

    Havent found any config menu or stuff to move around.... tried removing the surface pen and pairing it again with no success...

    Anybody else in my situation??
    06-20-2014 09:24 PM
  2. loganross2014's Avatar
    Same issue here. Hopefully they will fix it.
    06-20-2014 11:43 PM
  3. Cleavitt76's Avatar
    Do either of you have the new firmware installed? It was released yesterday and I think it addresses some issues with sleep/wake and the pen. You have to go through Windows Update a couple of times to see the firmware and other updates. The first pass only brings up a single pre-requisite update.
    06-21-2014 01:15 AM
  4. jhoff80's Avatar
    You'll also want to make sure OneNote is up to date by manually checking for updates in the Store.
    06-21-2014 01:20 AM
  5. cdf3's Avatar
    Mine didn't work when I pressed it once while it was sleep.
    After double clicking it, I was taken to the screen prior to the lockscreen.
    I then pressed the button again, and it took me to OneNote.
    After that I've been able to awake my device with a single click.
    Not sure if this will happen again after it goes into a deep sleep.
    06-21-2014 01:26 AM
  6. Jugler's Avatar
    There are no updates left.
    The strange thing is it was working perfectly when I took the Surface out of the box, once I ran all the updates and installed a few things it stopped working. Not very keen on restoring the surface and reinstalling visual studio...
    06-21-2014 02:08 AM
  7. manicottiK's Avatar
    It probably wasn't Visual Studio itself, but it was the Hyper-V feature that's often installed with VS, particularly if you installed the WP dev stuff, since the emulators run in VMs. Hyper-V is not yet compatible with Connected Standby (and there's not yet a public ETA for Microsoft adding it) . Connected Standby is what lets the computer is slightly aware -- enough to respond to the pen button.

    Choices: 1) remove the Hyper-V feature to regain Connected Standby or 2) live without Connected Standby and the fancy pen button feature.

    I went with choice 1. Of course, I can't work on my mobile apps without reinstalling Hyper-V first. Ugh.

    I've just uninstalled Hyper-V (leaving VS installed) and the pen works again.

    (I also posted this as a separate thread so that the actual cause is more clear in the thread title.)
    Last edited by manicottiK; 06-21-2014 at 09:48 AM.
    Jugler likes this.
    06-21-2014 09:37 AM
  8. jhoff80's Avatar
    Just posted a reply to that other thread too, but it's probably helpful here as well:

    I saw something on Twitter about this:

    Top tip for #wpdev on Surface Pro 3.. to temporarily disable hyper-V to get full connected standby, bcdedit /set hypervisorlaunchtype off
    To turn it back on again bcdedit /set hypervisorlaunchtype auto. Requires a reboot but advantage is you don't need to blow away hyperv
    Oh and bcdedit /enum shows you the current hyperv launch state
    From https://twitter.com/Clarkezone
    Jugler and Cleavitt76 like this.
    06-21-2014 09:51 AM
  9. Bigfireq's Avatar
    I have the same problem, and I don't have Visual Studio. It's one of the updates.
    06-21-2014 11:41 AM
  10. Jugler's Avatar
    Hey guys, lots of thanks for the info about HyperV, just saw the other post then came in here to see the responses as well.

    I can confirm this was my issue, after I disabled HyperV and rebooted I was able to use the pen as intended, and regained the connected standby (that I also lost).

    Just remember to run the commands as administrator, made a simple batch file to enable/disable for when I want to code.

    Thanks a lot!
    06-21-2014 03:39 PM
  11. Jugler's Avatar
    Actually it started happening again, i have sleep working and hyper V disabled, it worked a couple of times, but now it started misbehaving again. I can press the button and it takes me to One Note when unlocked, but when I have the computer locked it just goes to the "type your password screen" instead of opening OneNote... weird...
    06-21-2014 11:51 PM
  12. astondg's Avatar
    If this is caused by Hyper-V then that is super cr@p. Hyper-V (and it's emulated network adapters) is already preventing the Smart Glass app from working and that's existed since Smart Glass was released so I don't hold hope for this latest issue to be sorted any time soon.
    06-22-2014 03:50 AM
  13. mozman68's Avatar
    I'm glad I have no idea what Hyper-V is and have no plans to use it....
    kittengirl likes this.
    06-22-2014 08:49 AM
  14. mparker's Avatar
    Given how poorly hyperv works with a wireless connection I just run vmware instead. Hyperv is great on a server but just isn't yet ready for mobile use.
    06-22-2014 09:31 AM
  15. Bigfireq's Avatar
    It's not Hyperv. It's an intermittent problem that was mistakenly associated with hyperv. I never installed Visual Studio and I have the same problem, it sometimes works perfectly and then sometimes works as described in this thread. I haven't seen a rhyme or reason to it.
    06-23-2014 03:00 AM
  16. BaritoneGuy's Avatar
    It's not Hyperv. It's an intermittent problem that was mistakenly associated with hyperv. I never installed Visual Studio and I have the same problem, it sometimes works perfectly and then sometimes works as described in this thread. I haven't seen a rhyme or reason to it.
    There may also be another intermittent problem at work here, but Hyper V is definitely also a culprit. Hyper V disables connected standby which this feature requires to work properly.
    06-23-2014 03:21 PM
  17. TywinnLannister's Avatar
    I know you said you installed the update, did you install the Windows Update or the Microsoft Office updates?
    I had the same issue as well, after I installed the Office updates, it remedies it.

    The reason why I mentioned this is because I thought the windows updates would include office as well, but it did not. So I have to download separately.
    06-23-2014 03:48 PM

Similar Threads

  1. Replies: 3
    Last Post: 06-22-2014, 01:33 PM
  2. Will this work? (If not, maybe a better suggestion?)
    By Jas00555 in forum Microsoft Surface Pro
    Replies: 16
    Last Post: 06-22-2014, 10:48 AM
  3. Windows button not working
    By Lisa Petker in forum Microsoft Surface Pro
    Replies: 1
    Last Post: 06-20-2014, 11:23 PM
  4. Links not working in the wp central app
    By abhinav720 in forum Ask a Question
    Replies: 3
    Last Post: 06-20-2014, 09:15 PM
  5. battery saver not working?
    By aaronmacarthy in forum Other Operating Systems
    Replies: 1
    Last Post: 06-20-2014, 07:40 PM
LINK TO POST COPIED TO CLIPBOARD