1. spasell's Avatar
    3 weeks ago I downloaded the latest firmware.

    Since that time, but battery is literally half of what it was. I have had it on for 4.5 hours and went from 100% to 15%.

    Brightness is at 50%.

    I am not using BT

    Using wifi.

    No games...no video. What is open?

    IE, Outlook, Gmail, and using Excel and Word for work. Answering email and looking at various sites.

    No music,.

    I look at what's running in background and I don't have much running. The back is not even running that hot.

    I don't understand this. Every single new update my SP3 hasn't improved. It's gotten worse. I used to get 9-10 hours doing the same activities and now, it's so bad and I am getting very frustrated. I don't get it.
    12-08-2014 03:58 PM
  2. noobchief's Avatar
    I'm not experiencing this, is your sp3 i7? But after the latest firmware, the Wi-Fi bug appeared. :(
    12-08-2014 04:08 PM
  3. spasell's Avatar
    I'm not experiencing this, is your sp3 i7? But after the latest firmware, the Wi-Fi bug appeared. :(
    No i5. got it on launch day. I managed to get a machine with zero issues that others had. Ran great. No problems. Problems started incrementally after updates appeared. I mean, really? You update to fix stuff and it gets worse?
    12-08-2014 04:23 PM

Similar Threads

  1. How do I retrieve my phone contacts after formatting my Lumia 1520?
    By Windows Central Question in forum Ask a Question
    Replies: 4
    Last Post: 12-10-2014, 02:16 AM
  2. Replies: 3
    Last Post: 12-10-2014, 12:31 AM
  3. Why is my umia 730 having heating and battery problems?
    By pandiarajan k in forum Windows Phones
    Replies: 3
    Last Post: 12-09-2014, 06:50 AM
  4. My Venue 8 will not charge the battery anymore, why?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-08-2014, 01:16 PM
  5. Replies: 1
    Last Post: 12-08-2014, 09:35 AM
LINK TO POST COPIED TO CLIPBOARD