1. Byrese's Avatar
    So I've had my sp3 since summer. Even back then I've had issues signing onto wifi in public places like Starbucks. It still persists though it has gotten better.

    Anybody else dealing with this? Fixes?
    01-19-2015 03:53 PM
  2. CliveSinclair's Avatar
    My SP3 is 7 weeks old - never had any WiFi (SP3) related issues. Manufacturers are constantly upgrading or changing parts during manufacture - maybe the build dates have something to do with the 'documented' WiFi issues. If it is an hardware issue, no amount of firmware issues will fix it.
    01-20-2015 01:09 AM
  3. Byrese's Avatar
    My SP3 is 7 weeks old - never had any WiFi (SP3) related issues. Manufacturers are constantly upgrading or changing parts during manufacture - maybe the build dates have something to do with the 'documented' WiFi issues. If it is an hardware issue, no amount of firmware issues will fix it.
    You knew I think it might just be the sites wifi; all the ppl, a weaker signal then my home (or another person's house). I went to a Starbucks the other day that used Google wifi...absolutely no problems. I think my main problems are with ATT wifi.
    01-22-2015 04:26 PM
  4. Kevin Harvell's Avatar
    My Wi-Fi issues seem to be resolved thanks to the last firmware they recently released. Not having to turn off Wi-Fi then turn it back on when switching connections.
    01-25-2015 06:34 PM
  5. belgiantrotter's Avatar
    for me its the opposite.. I never had any problems
    the recent firmware update i now get disconnected from guest/public wifi's.

    anybody knows how to restore the old wifi drivers? the rollback button is greyed out
    01-26-2015 02:24 PM
  6. shamrockhead's Avatar
    ive had mine for under a week, got all the updates, haven't had any problems with wifi so far
    02-05-2015 05:28 AM
  7. JohnClarkson's Avatar
    I had finally fixed my wifi issues by rolling back an update. That was around October I believe. Then after the January update all the wifi issues came back. Mainly it won't connect after the computer goes into any kind of power save mode. Most of the time requires a reboot of the machine.
    02-09-2015 11:12 AM
  8. eds817's Avatar
    Got my SP3 just before Christmas and didn't have any WiFI issues until I installed Win10TP. Now I'm sitting less than 10 feet from my router and it won't connect. Very frustrating.
    02-10-2015 06:56 PM

Similar Threads

  1. Replies: 2
    Last Post: 06-05-2015, 02:59 AM
  2. Issues after updating to Denim
    By zainsul in forum Windows Phones
    Replies: 30
    Last Post: 05-08-2015, 03:13 PM
  3. How to manually switch Wifi bands on the Surface Pro 3
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 01-19-2015, 01:00 PM
  4. Why am I unable to register my device?
    By WP8Expert in forum Software Development and Hacking
    Replies: 0
    Last Post: 01-19-2015, 06:33 AM
LINK TO POST COPIED TO CLIPBOARD