1. Mikado_Wu's Avatar
    Hello all,

    I can not seem to get the new Firmware to install on my SP3. I have 10 SP3's here at work and only 1 has been updated. It is a new one that is not on the domain yet. I have tried turning off update services and clearing out those files. Still nothing. I found a couple other threads out there with the same issue, but no resolutions yet. I am only at 7 posts so far, so I can not post the links yet.

    Any advice would be helpful.
    05-21-2015 07:28 AM
  2. CliveSinclair's Avatar
    My two SP3's installed OK, but touch screen is like... not working, any touch has a delay of 10-15sec!!!

    Trackpad and keyboard ok.
    05-21-2015 08:03 AM
  3. hotphil's Avatar
    Open a support case with Microsoft. If you got multiple devices with the same issue, that's a good case for them to work on (from both sides).
    Surface Pro firmware updates have a history of not/(re)installing​ and being a bit unpredictable.
    05-21-2015 08:19 AM
  4. zei20t's Avatar
    I have 2 SP3s, both installed ok. but the i3 model failed first. ran it again after power-off. seemed to go ok.
    05-21-2015 07:08 PM
  5. enthuz's Avatar
    I'm unable to install it too. Mine kicks off the restart before it finishes and strangely leaves me logged in after a reboot.
    05-21-2015 08:43 PM
  6. eusty's Avatar
    It "just worked" when it updated last night, not sure it's because it's the i5 as it the posts above metion i3's?
    05-22-2015 10:05 AM
  7. Cipol's Avatar
    I had the same issue and we have pin point to GPO WSUS settings. Once we have removed WSUS server from GPO System firmware May 19 2015 installed successfully. At least that is what is worked for us.
    05-22-2015 12:37 PM
  8. zei20t's Avatar
    You use WSUS? My guess is they (sys admins) haven't approved the updates for surface
    05-24-2015 07:02 AM

Similar Threads

  1. Gears reboot loop - not sure what to do next
    By EpidemikE1 in forum Windows Phones
    Replies: 9
    Last Post: 07-29-2015, 12:46 AM
  2. Can I install project Spartan on windows 7/8/.1?
    By reem zedek in forum Windows 10
    Replies: 2
    Last Post: 05-21-2015, 01:08 PM
  3. [L630] Won't send texts getting an error message did not send try again later?
    By Windows Central Question in forum Windows Phones
    Replies: 1
    Last Post: 05-21-2015, 05:44 AM
  4. Why can't my 920 see new contacts details which was added with my computer gmail?
    By Windows Central Question in forum Windows Phones
    Replies: 0
    Last Post: 05-21-2015, 12:26 AM
LINK TO POST COPIED TO CLIPBOARD