1. spasell's Avatar
    Apparently really no one knows what the issue is now that we have "upgraded" to Windows 10 and apparently I'm not the only person with battery problems.

    Fully charged, close the lid, I have even put it into battery saver, I lose 10-15% in 3 hours with zero apps or programs open. This has been going on since I upgraded on the 29th.

    Attached are screen shots. I don't have location on. I do not have Cortana on. Basically neutered all the cool things that 10 can do because the battery life is HORRIBLE since the upgrade.

    If anyone had the same issues and can tell me what's going on I'd appreciate it. And PLEASE PLEASE don't tell me that I need to, once again, do a fresh install. If that's the case, I'm going straight back to using my MacAir because I'm tired of starting over every time there's an update that doesn't work or upgrade that cannot seem to work properly.

    It says in battery report that Cortana is using battery but I do not have it on... Turned it off 4 days ago.
    I ran the powercfg/sleepstudy and you can see what's causing this. Driving me crazy.

    Now I am getting on a plane across country and won't make it the entire way since I lost 16% battery in 3 hours doing nothing

    Thanks

    screenshot-19-.jpgscreenshot-20-.jpg
    08-10-2015 11:35 AM
  2. spasell's Avatar
    screenshot-22-.jpg

    Looked to see what was running. I just pulled my SP3 out of my bag. It's in Airplane mode. And yet, the back is very warm. What in the hell is happening here?

    I noticed the two things running constantly and it was using 22% CPU over and over continuously.

    Anyone have ANY ideas here?

    Something is definitely messed up on this thing. I am now down to 60% and I've had the screen on for a total of 22 minutes... All the rest of the time it's been in my bag with the cover shut.
    08-10-2015 12:47 PM
  3. rdubmu's Avatar
    Do u put it in sleep mode, also why don't you just shut down the machine if you are not using it


    Sent from my iPhone using Tapatalk
    08-10-2015 09:58 PM
  4. zei20t's Avatar
    Weirdly, my i3 SP3 runs well, battery is all good etc and it seems to sleep well. WiFi is disabled after waking (not Flight Mode) - usual story

    My i7 SP3 smashes battery, awake or asleep. also wakes from sleep with wifi disabled. really annoying! its only after the latest firmware (from what I can tell) that has caused this.
    08-11-2015 01:46 AM
  5. homeedition88's Avatar
    Yeah same issues here. Awful battery life, constant CPU and Fan runs and today I saw my first BSOD (Blue screen of dead) Apps crashes, email app sucks, store app crashes also. I try so hard to use my SP3 for my daily basis and it fails every time with Windows 10. Sorry to say but today I realised that when I do something import for my job I just open my Macbook pro instantly. I do it without even think. So I gave up and now I only use it as a very expensive tablet. It maybe sound too negative but I would like to say it "Again I'm disappointed by M.S" Gush...
    08-11-2015 12:30 PM
  6. zei20t's Avatar
    The cumulative update that happened today fixed a few things on my i3 SP3, but wont know if the same update fixes my i7 SP3 until I get home tonight..........
    08-11-2015 07:45 PM
  7. taymur's Avatar
    i have no battery issues, battery is just as it when i was on 8.

    and btw, Microsoft said that windows 10 in its current state should be the same as it was on windows 8, and they will even improve it more soon, as they are not satisfied with it.
    08-12-2015 10:34 AM
  8. Talldog's Avatar
    I have all the updates and refreshed firmware on my i5/256 SP3. When I took it off the charger this morning, the battery was 100%. After an hour, it was down to 77% doing nothing but browsing a few tech forums on Edge and running Task Manager to watch the CPU. The CPU was constantly 25-40% (mostly System and System Interrupts) even when I wasn't doing anything but staring at the screen. After closing the cover it slowed down, but still using 6-7%/hr.
    08-12-2015 11:15 AM
  9. Guzzler3's Avatar
    I have noticed after doing an upgrade or fresh install with all the updates and such, is there is whole bunch of background work going on.

    One thing I've found that helps is to go to the power settings and set it to never power off while plugged in, connect the power cord, then leave it on overnight and let it 'do it's thing'. Then in the morning reset it back it's defaults and go on from there.
    08-12-2015 10:33 PM
  10. spasell's Avatar
    I rebooted everything, and it appears to have worked, although I am figuring out that Cortana on just kills the battery.

    I did three separate tests last week.

    1st 3 days with Cortana (and subsequently Location) on, from 100%, closing the keyboard cover, in 4 hours, I went down to 82, 78, and 74%. Nothing else running at all in the background. All apps and programs shut down.

    I then shut off Cortana and Location, and under same circumstances, I was at 89, 92, and 96% battery in 4 hours.

    I do think it's very strange that I still lost 11 and 8% on the first two tests. I don't get it.

    This past weekend I left office at 100%, closed keyboard cover, and left SP3 in my bag all weekend. Didn't power on until 8am this AM and I was at 86% so a 14% drop in over 48 hours which I guess I should just accept.
    08-17-2015 09:36 AM
  11. spasell's Avatar
    I have all the updates and refreshed firmware on my i5/256 SP3. When I took it off the charger this morning, the battery was 100%. After an hour, it was down to 77% doing nothing but browsing a few tech forums on Edge and running Task Manager to watch the CPU. The CPU was constantly 25-40% (mostly System and System Interrupts) even when I wasn't doing anything but staring at the screen. After closing the cover it slowed down, but still using 6-7%/hr.
    I noticed that System and System Interrrupts were off the charts watching Task Manager and could not figure out why. So I did something I eas told to try a while back with issues when 8.1 first came out for SP3. Holding the power key and volume down key for 10-12 seconds, screen goes black, and keep holding it for a total of 20 seconds. Then power back up.

    That corrected the issue of System and System Interrupts killing the battery. I still lose 7-10% battery over a 24-36 hour period but it's far better than the 28-33% I was losing and the SP3 feeling very warm in my bag. Now it does not.
    08-17-2015 09:41 AM
  12. Dewg's Avatar
    I've found that "Hey Cortana" prevents the system from being able to deep sleep. If you run "powercfg -requests" from an elevated prompt, see if anything is preventing your system from sleeping.
    08-17-2015 01:32 PM
  13. Hieu Nguyen6's Avatar
    I have met several problems for a week ago. High CPU performance with onenote, word,...Or even when SP3 idle , system still load > 10% CPU. And when i go home from the class, battery is out. I can't believe it. What happen with SP3 in windows 10.
    08-25-2015 12:26 AM
  14. Skippy07's Avatar
    I too was having horrible battery issues after upgrading to Windows 10. I did some poking around the interwebs and found a thread where a Microsoft employee was asking folks to post their powercfg/sleepstudy from their Surface Pro 3s. http://answers.microsoft.com/en-us/s...1ad9fc3?page=1

    After reading through the thread and looking at what people were finding, I was seeing quite a few people seeing issues with their Micro SD card readers. So I pulled my Micro SD card and my battery issues were gone. I can't say it's quite as good as it was with Windows 8.1, but it's WAY better and totally usable now.

    On page 9 of the thread I linked above, the MS employee that started the thread did indicate that they're aware of the SD Card reader issue and are investigating so that a fix can be delivered ASAP.

    Hopefully this will help some of you here. It sure did help me.

    Good luck,
    Skippy
    Dadstar0410 likes this.
    09-02-2015 05:40 PM
  15. photobriangray's Avatar
    Frustrating bug when you forget to take the card out after pulling in photos...
    09-04-2015 02:57 PM

Similar Threads

  1. Replies: 21
    Last Post: 07-08-2016, 04:49 AM
  2. I'm having problems logging on Windows 10, can I get some help?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 08-10-2015, 01:49 PM
  3. Missing EMails following update to Windows 10, how can I get them back?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 08-10-2015, 11:27 AM
  4. Windows Central App Offline Lists
    By browryan in forum Ask a Question
    Replies: 0
    Last Post: 08-10-2015, 11:21 AM
  5. Microsoft says if you want landscape for the Start screen vote for it (like you always could)
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 08-10-2015, 11:20 AM
LINK TO POST COPIED TO CLIPBOARD