1. Talldog's Avatar
    Since the latest round of updates, I've noticed that battery life has been a little better, but it's inconsistent and frequently still pretty bad (losing >20%/hr just web browsing). Two days ago, I had 3 Edge tabs open browsing a few sites (including this one) and I noticed my Surface was hot and the fan was going for no apparent reason. I started Task Manager and saw that Edge was using 25% CPU. Since then I've been using IE when I'm on battery power, and it's made a big improvement in my battery life. It's not hot, and the fan isn't on. Not sure why (lack of ad blocker, maybe?) but there you go.
    09-02-2015 05:44 AM
  2. Witness's Avatar
    Not sure, but whatever it is, I really want to go back to 8.1 now. Between OneDrive's missing placeholder, power drain, crappy Photo app and wonky little graphical issues it's kind of a bust on the SP3. The only thing that's holding me back is that I don't have time to go through the process.
    09-02-2015 11:15 AM
  3. homeedition88's Avatar
    Yes it kills and for a reason. One of them is because no ad block. Ads especially with flash based, stole your cpu power. It is a new browser and have got a lot of bugs. Hangs and recovering tabs consume a lot of CPU power. But still for power consumption it is as good as chrome (which is very power hungry browser)
    09-02-2015 04:11 PM
  4. Wes Smith's Avatar
    It could very well be a memory leak too. Next time it happens see if you can notice how much memory its consuming.
    09-02-2015 04:39 PM
  5. Talldog's Avatar
    It could very well be a memory leak too. Next time it happens see if you can notice how much memory its consuming.
    I just fired up Edge and opened 3 tabs. Within a few minutes, my Surface was getting hot with CPU between 25 and 50% and memory over 2Gb. Shut down Edge and it cooled off quickly.
    09-02-2015 07:28 PM
  6. Wes Smith's Avatar
    damn that doesn't sound good. I tried on mine the same thing and cant replicate. suspect it might be certain websites that its getting stuck in a loop and cranking up that high cpu and mem usage.
    09-03-2015 02:18 PM
  7. Talldog's Avatar
    I think I'm just going to use IE until the next Edge update comes out. I like it, but it needs work.
    09-04-2015 08:03 AM
  8. anon(7901790)'s Avatar
    I'm using Firefox now, and the heating issue has pretty much gone away.
    09-07-2015 02:29 AM
  9. MBSMD's Avatar
    Edge sucks. Few features and is a battery killer. Fans ramp up on my SP3/i5.

    Chrome has all necessary features, but is also a processor hog.

    Firefox seems lean on the processor. Fans don't ramp up like with MS Edge. UI is too small to be touch comfortable though and the on-screen keyboard doesn't pop up on its own.

    Hate to say it, but my iPad is a better web browsing device.
    09-15-2015 12:55 AM
  10. Michael Alan Goff's Avatar
    Edge sucks. Few features and is a battery killer. Fans ramp up on my SP3/i5.

    Chrome has all necessary features, but is also a processor hog.

    Firefox seems lean on the processor. Fans don't ramp up like with MS Edge. UI is too small to be touch comfortable though and the on-screen keyboard doesn't pop up on its own.

    Hate to say it, but my iPad is a better web browsing device.
    Firefox nightly fixes the keyboard issue you're having. The scrolling is pretty bad, though.
    09-15-2015 03:48 AM
  11. Engineers's Avatar
    This^. I was wondering if this was just happening to me. About 10 minutes after turning on my SP3, the system is using most of the available memory. And this happens all the time. It is even worse when I use Edge. But even if I don't use Edge my fans are running fast and hot. Battery life sucks. I basically can't run my SP3 for more than 1 hour without restarting because the system is using so much memory and every thing gets slow and I have windows poping up saying my memory is low. Basically W10 made my SP3 unusable.

    I've been trying to get info on this but every time I ask the question I get bashed as a Microsoft hater from all the fanboys that claim W10 is great.
    09-30-2015 04:25 PM

Similar Threads

  1. My game is not searchable in the Windows Phone store on the smartphone
    By babazookz in forum General Phone Discussion
    Replies: 2
    Last Post: 09-04-2015, 04:10 PM
  2. How do I send my phone book from my Nokia Lumia 530?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 09-02-2015, 05:40 AM
  3. Replies: 0
    Last Post: 09-02-2015, 05:05 AM
  4. Why it is slow? How do I solve it?
    By sourav ghosh969 in forum Windows Insider Program
    Replies: 0
    Last Post: 09-02-2015, 04:22 AM
  5. Why can't I access the Nokia Store?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 09-02-2015, 04:19 AM
LINK TO POST COPIED TO CLIPBOARD