1. ray963's Avatar
    Hello WC nation, this is my first post over here since I'm usually a reader on the site.

    Lets dive in to keep it short:

    The first SP4 i got had a back light leaking from the bottom side ( the keyboard attachment side) and that was enough for me to go and replace it.

    The second SP4 was a whole new level of surprises

    Software issues:
    - Touch screen stopped responding on 5 occasions where i didn't bring along the keyboard or the mouse and i had to force shutdown the SP by holding the power button.
    - Took hours to update and upgrade.
    - The audio driver crashed causing the device to restart.
    - After updating to the latest updates available one of Windows Hello features disappeared. The on that says ( For extra security, require turning your head left and right to unlock the screen). Funny enough none of the MS support member knew what i was talking about even after granting him a remote access!! the in store didn't knew about this feature too.
    - The device was heating up and the fan kick in from just browsing!!!!!! so what do you think about streaming

    Hardware:
    - The Pen stopped working even though it was showing that it's paired.
    - There was a back light leaking from the same area but i was trying to convince myself that it's me not the SP4
    - From the same side the screen was raised/detached. I don't know how to describe it, it is hard to see for some people but if you moved your nail gently from the screen to the edge you will hit the Magnesium screen edge but on my device your nail will have a free fall.

    My third and current SP4:

    Hardware:
    - Nothing so far aside from some back light leaking that far less than the previous ones. I am still doubting myself

    Software:
    - Touch screen got unresponsive twice so far but i had the mouse with me and simply restarted the device.
    - Feels like it's a little bit slower than the first 2 SP4 ( boot time wise ). No way to measure that now.
    - I am still facing the heat issue ( even while I am writing this post, nothing else is running, NOTHING ).

    I am interested if anyone faced any of the issues that i had!
    Nearly forgot, SP4 I7 16GB 265GB
    Maybe in another post I will write the good things about this device which is a lot.
    01-07-2016 09:30 AM
  2. alexd88's Avatar
    i have problems with the screen is loose an when i push very light on the centre up where the camera and sensors are appears screen light bleed , and the centre down. i am going for a replacement.
    01-07-2016 10:21 AM
  3. Tom Campbell2's Avatar
    I bought the same model SP4 I7 16GB 256HD and mine has been working fairly well.

    On heat... I have Visual Studio 2015, Edge (several tabs) and a Virtual Machine (using 8GB of RAM) running and I only hear the fan run occasionally. Usually, Netflix does not cause the fan to start running right away.

    I do have a little bit of light leaking about 2 inches from the right on the bottom. The leakage is about 1 1/2 inches wide, but, it's not drastic, and I mostly only notice it when the room is dark and the screen is black.

    I have not had the touch screen become unresponsive at all.

    I have had issues when the machine puts the display to sleep. The whole sleep/off thing is just a bit off, so I usually shut it down at night. During the day, if I run into an issue, I usually have to hard reboot it (holding down the power button for 10 seconds or so.)

    I've had no problems with my pen not working.

    I did have Windows Hello spaz out on me. The red light came on but the screen never lit up. It's only happened once or twice. I had to hard reboot in each case.

    I am running Windows Insiders build 11082.
    01-07-2016 10:40 AM
  4. ray963's Avatar
    alexd88
    You Should get a replacement, and let them know that you are not the first one to have this issue.
    Last edited by ray963; 01-07-2016 at 06:58 PM.
    01-07-2016 06:48 PM
  5. ray963's Avatar
    Tom Campbell2
    I really don't know why I am having the heat issue

    On the other hand I just faced the exact same problem you mentioned today with sleep/wake up twice and i had to do a hard reboot too

    I just checked the build number and it's 10240.
    01-07-2016 06:56 PM
  6. Barry Holsinger's Avatar
    I have same touch screen lockup issues, and just like you, the "For extra security..." option is also suddenly gone.
    02-13-2016 01:04 AM

Similar Threads

  1. Where is my search bar
    By fallingleaves in forum Windows 10
    Replies: 2
    Last Post: 01-11-2016, 03:24 AM
  2. Again Camera problem, need help i'm going crazy
    By Bokisa4444 in forum Windows Phones
    Replies: 2
    Last Post: 01-08-2016, 08:55 AM
  3. My Windows 10 laptop won't start up, what should I do?
    By Windows Central Question in forum Windows 10
    Replies: 1
    Last Post: 01-07-2016, 09:49 AM
  4. Why can't i get my brother printer software to download, or sonos ?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 01-07-2016, 09:35 AM
  5. Problem with Store
    By Nay Patel in forum Ask a Question
    Replies: 1
    Last Post: 01-07-2016, 09:20 AM
LINK TO POST COPIED TO CLIPBOARD