08-04-2016 08:12 AM
38 12
tools
  1. shawnthor's Avatar
    I purchased my SP4 on Amazon (seller "mojoacc") and it has been trouble-free. The first thing I did was a full reset, before setting everything else up and installing all Windows updates and app updates. I had read some threads here and in other forums about some issues, so I decided to be pro-active about it by doing the following:
    • Downloaded a clean ISO of Windows 10 from https://forums.windowscentral.com/e?...token=ishSeNUL (64-bit).
    • Mounted the ISO (right-click, select mount), then took note of the drive letter it was assigned to be used in the next step.
    • Opened PowerShell (run as admin) and ran this command: dism /online /cleanup-image /restorehealth /source:WIM:E:\sources\install.wim:1 (Note: it did find issues and it corrected them).
    • Still in PowerShell, I ran this command: sfc /scannow (Note: again, it did find issues and it corrected them).
    • Restarted.

    It has been running like a dream ever since.
    Did you need to obtain a product key for Windows 10 Pro from your Surface to do the clean wipe? What is the tech bench upgrade program? Additionally, how has your battery life been?

    Thanks.
    06-04-2016 04:27 PM
  2. anon(601415)'s Avatar
    You just go to the link and download the appropriate ISO. Nothing else needed because all it is doing is using that ISO to retrieve corrupted files.

    Battery life hasn't really changed. I get 5-6 hours depending on what I'm doing, and that's after implementing the power tweaks here and here.
    06-04-2016 04:38 PM
  3. shawnthor's Avatar
    I purchased my SP4 on Amazon (seller "mojoacc") and it has been trouble-free. The first thing I did was a full reset, before setting everything else up and installing all Windows updates and app updates. I had read some threads here and in other forums about some issues, so I decided to be pro-active about it by doing the following:
    • Downloaded a clean ISO of Windows 10 from https://forums.windowscentral.com/e?...token=s7a_iUkk (64-bit).
    • Mounted the ISO (right-click, select mount), then took note of the drive letter it was assigned to be used in the next step.
    • Opened PowerShell (run as admin) and ran this command: dism /online /cleanup-image /restorehealth /source:WIM:E:\sources\install.wim:1 (Note: it did find issues and it corrected them).
    • Still in PowerShell, I ran this command: sfc /scannow (Note: again, it did find issues and it corrected them).
    • Restarted.

    It has been running like a dream ever since.
    Thanks for all of the help. I have updated and installed software on my Surface, do you think this will do anything for my system? Also, when doing the scf /scannow, should the directory be pointed to the c:\ or c:\windows \system32? Been sitting at 11% complete the scan for a long time now.
    Last edited by shawnthor; 06-04-2016 at 09:14 PM.
    06-04-2016 08:33 PM
  4. ALToronto's Avatar
    How is your battery life?
    I get 4-5 hours scribbling in OneNote, browsing, looking at pdf's, and using Outlook, Excel and Word mostly with pen input. I love cursive writing! I hadn't done any in about 20 years before I bought my first Surface two years ago.

    If I decide to waste a bit of time with Solitaire, the battery really heats up and runs down very quickly.
    06-05-2016 04:58 PM
  5. anon(601415)'s Avatar
    Thanks for all of the help. I have updated and installed software on my Surface, do you think this will do anything for my system?
    Hopefully. I had already almost everything I needed when I did it.

    Also, when doing the scf /scannow, should the directory be pointed to the c:\ or c:\windows \system32? Been sitting at 11% complete the scan for a long time now.
    Doesn't matter where you are in the PowerShell or Command Prompt when you run it. It does take quite awhile to complete.
    06-05-2016 05:18 PM
  6. Steveborough's Avatar
    Best Buy, 4 total devices all abysmal and had all or most of these flaws:
    - 1 device didn't turn on, Replaced
    - all had severe light bleed around the edges - worst I've seen in a decade
    - terrible power management, fans on all the time, Somewhat fixed now via firmware updates but different experience from device to device)
    - audio popping, somewhat fixed but still happens when you change the on-screen volume
    - the worst wifi performance I've ever seen in a modern laptop (last 5 years) my phone gets double the performance on the same network
    - wouldn't wake from sleep or wouldn't remain asleep (hotbag) - somewhat fixed now but still happens to a few devices daily
    - terrible screen flex under nominal pen pressure, you can see the typical lcd screen waves/discoloration while using the pen
    - terrible pen lag, while tracing the pen across the screen in OneNote, lines lag a quarter inch behind the nib at nominal speeds
    - pen erase pressure needed to be significant to work, Faulty pen, replaced
    - atrocious battery life, half of what MS claims just browsing the web, There are countless workarounds including underclocking and feature disabling.

    Overall it took 6 months for MS to issue enough updates to make the device usable. This will be the last surface I or my company will purchase. When behaving its not the worst device in the world
    06-09-2016 05:36 PM
  7. decider's Avatar
    Since BB was selling them for $150 off this week, I purchased another last night. Needed something to play with this weekend while i am off work on Friday. None of my previous purchases had the fan issue as others have discussed, I have bene stuck on the light bleed issue, when I think I will have to ignore if I really want a surface pro 4.
    06-13-2016 07:37 AM
  8. Byrese's Avatar
    Swappa. No problems

    Posted via the Windows Central App for Android
    06-16-2016 09:46 PM
  9. decider's Avatar
    So far this 4th SP4 I received this week has worked without issue from out of the box to setup. All my others would bluescreen during setup and had more light bleed than I cared to pay for. But in regards to light bleed on this one I just received, I cannot complain as where on my previous SP4s, the light bleed was really obvious. I could on this current one I just got say light bleed is not there on this one. Microsoft told me that there are SP4s out there that don't have the light bleed issue, and maybe I found one.
    06-16-2016 11:05 PM
  10. decider's Avatar
    So far all is still good. I have not yet experienced one BSOD, though it won't alarm me if it does, eventually anyone using a windows computer is going to experience a BSOD on occasion. But as of today, June 18, have not experienced single issue, even connected standby is working, no power issues. For a test of sleep mode, I disconnected my Surface from charging, closed the lid and then checked when I got up next morning, and I was able to wake it up without issue, Battery showed 100% upon wakeup. So it looks like there are some good SP4s.
    06-18-2016 08:45 PM
  11. Zandur Khan's Avatar
    Bought my Surface Pro 4 when released in Denmark december 2015. I have had zero issues with the device. Bought a Surface Pro 3 in the US early after release and that is also running without any issues. My Surface Pro 4 is my only and primary work machine.
    06-22-2016 09:20 AM
  12. shawnthor's Avatar
    I purchased my SP4 on Amazon (seller "mojoacc") and it has been trouble-free. The first thing I did was a full reset, before setting everything else up and installing all Windows updates and app updates. I had read some threads here and in other forums about some issues, so I decided to be pro-active about it by doing the following:
    • Downloaded a clean ISO of Windows 10 from https://forums.windowscentral.com/e?...token=1rHqnDou (64-bit).
    • Mounted the ISO (right-click, select mount), then took note of the drive letter it was assigned to be used in the next step.
    • Opened PowerShell (run as admin) and ran this command: dism /online /cleanup-image /restorehealth /source:WIM:E:\sources\install.wim:1 (Note: it did find issues and it corrected them).
    • Still in PowerShell, I ran this command: sfc /scannow (Note: again, it did find issues and it corrected them).
    • Restarted.

    It has been running like a dream ever since.
    The link is not working anymore. Any ideas?
    08-03-2016 07:44 PM
  13. pwscott's Avatar
    The link is not working anymore. Any ideas?
    +! Link for ISO is not working.

    Purchased mine from Amazon, have had no issues.....loving mine.
    08-04-2016 08:12 AM
38 12

Similar Threads

  1. Lumia 950 heat and battery drain.
    By Dedpewl in forum Windows Phones
    Replies: 31
    Last Post: 09-18-2017, 11:57 AM
  2. Band 2 and Health App not matching steps
    By jmerrey in forum Connected Living
    Replies: 4
    Last Post: 05-23-2016, 02:55 AM
  3. [WP 8.1] How to access NAS?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 05-21-2016, 11:30 PM
  4. Where did you buy your Surface Pro 4 and how many issues have you had?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-21-2016, 09:42 PM
  5. How to reactivate a local connection that i made?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 05-21-2016, 08:17 PM
LINK TO POST COPIED TO CLIPBOARD