01-19-2017 08:52 PM
75 123
tools
  1. X0LARIUM's Avatar
    I am extremely angry and upset. I have recently bought a Surface Pro 4, the latest MS has to offer.
    But I am sorry to say, my 6 year old iPad Mini works far better than this piece of S word.

    I am on the Anniversary Update. And it has nothing but caused a lot of issues since the update.

    Issues in particular:

    SKYPE DOESN'T LOAD/WORK

    SOUND DOESNT WORK

    YouTube Videos don't play

    Multimedia Files Dont play from the hard disk

    This is NOT what I expected from a company that has all eyes on it.

    Honestly, this is the last chance I wanted to give Microsoft, before running as fast as I can to another camp. And guess what, time to bring those running shoes out.
    08-10-2016 01:21 AM
  2. rdubmu's Avatar
    If you download another browser like firefox, chrome or even use internet explorer does youtube work?

    What do you mean that sound doesn't work, sometimes the video that is playing has its own controls, you will have to unmute it there. Skype works just fine, but the messaging and skype app does not work and is being discontinued. Just download the most recent version of skype from the Windows Store.

    What type of multimedia files are not playing? You possibly might need to download the correct player based on the file type.

    I hope your running shoes are comfortable.
    08-10-2016 01:28 AM
  3. ttsoldier's Avatar
    Sucks.

    I love mine.
    saras112 and spoonxii like this.
    08-10-2016 03:13 AM
  4. borgeindergaard's Avatar
    It sounds like you either got a bad one, or that you need to do a refresh of the OS installation.
    I recently got a SP4 myself, and did a fresh installation of the Win10 AU update, and everything has been working perfectly.
    08-11-2016 05:46 AM
  5. kristalsoldier's Avatar
    It sounds like you either got a bad one, or that you need to do a refresh of the OS installation.
    I recently got a SP4 myself, and did a fresh installation of the Win10 AU update, and everything has been working perfectly.
    Been my experience too!!
    TLRtheory likes this.
    08-11-2016 06:10 AM
  6. X0LARIUM's Avatar
    It sounds like you either got a bad one, or that you need to do a refresh of the OS installation.
    I recently got a SP4 myself, and did a fresh installation of the Win10 AU update, and everything has been working perfectly.
    There are three kinds of refresh. Which one did you do? And which one should I? I don't mind doing it TBH. Also, the last couple of days its working fine. TOUCHWOOD!
    08-11-2016 06:53 AM
  7. ananve's Avatar
    Normally it would take some times to update/ settled down. There are a lot of things happening between its first launch and the currently more stable situation.

    If it works well after the first run-in days, that is normal.

    Posted from my Surface 3 running W10
    rdubmu and anon(8532178) like this.
    08-11-2016 07:56 AM
  8. Allen Rhodes's Avatar
    Complete wipe and start clean. Its the same with a phone. A corrupt install doesn't reflect an entire line of products. When you have that many issues, its either that and will be fixed with a TOTAL wipe, or its the hardware. That's why they come with warranties. If the issues you were having were wide spread, like the bios/driver issues when it was first released, the haters would have eaten that up. But its not typical, which is why they are selling so well, unlike the phones, because of advertising. Go figure!
    rdubmu, pwscott, 11B1P and 1 others like this.
    08-11-2016 08:09 PM
  9. pwscott's Avatar
    There are three kinds of refresh. Which one did you do? And which one should I? I don't mind doing it TBH. Also, the last couple of days its working fine. TOUCHWOOD!
    If it's working fine now, you might consider going back and changing the title of your somewhat DRAMATIC post with mostly caps in the title. It's the first thing visitors to the forum are seeing and it seems like it's not quite indicative of where things really stand for you. Just a respectful suggestion...take it or leave it.
    08-11-2016 09:22 PM
  10. borgeindergaard's Avatar
    There are three kinds of refresh. Which one did you do? And which one should I? I don't mind doing it TBH. Also, the last couple of days its working fine. TOUCHWOOD!
    I actually made a USB installation media of Win10 AU from the ISO, and completely reformatted and partitioned the SP4 harddrive and reinstalled completely from scratch... Then I installed the Surface update packages from here https://forums.windowscentral.com/e?...token=lFoy2oVP and did a full Windows Update after that.

    It might be oldfashioned, but it works.
    anon(601415) likes this.
    08-14-2016 07:23 AM
  11. X0LARIUM's Avatar
    Took the suggestion the member who advised renaming the post. I agree with him/her.
    08-14-2016 10:46 AM
  12. X0LARIUM's Avatar
    If it's working fine now, you might consider going back and changing the title of your somewhat DRAMATIC post with mostly caps in the title. It's the first thing visitors to the forum are seeing and it seems like it's not quite indicative of where things really stand for you. Just a respectful suggestion...take it or leave it.
    Er..how? I tried by clicking on 'Go Advanced' but don't see the option. Any help?
    08-14-2016 10:48 AM
  13. rdubmu's Avatar
    Er..how? I tried by clicking on 'Go Advanced' but don't see the option. Any help?
    Ask a Mod to do it.
    pwscott likes this.
    08-14-2016 02:29 PM
  14. anon(601415)'s Avatar
    I actually made a USB installation media of Win10 AU from the ISO, and completely reformatted and partitioned the SP4 harddrive and reinstalled completely from scratch... Then I installed the Surface update packages from here https://forums.windowscentral.com/e?...token=d4oN_LD3 and did a full Windows Update after that.

    It might be oldfashioned, but it works.
    That's what I did and everything is running well.
    08-14-2016 05:00 PM
  15. X0LARIUM's Avatar
    That's what I did and everything is running well.
    Alright, the issue is very recurring but there is no pattern. Can I just format it, without doing any USB installation?

    Alternatively, which package do I download? There are like 4...
    08-15-2016 09:44 AM
  16. X0LARIUM's Avatar
    Absolute trash. I should have bought a Mac. Horrible product. I reset the machine. Factory reset so all data gone. Guess what. The EXACT Same issue still persists. Never buying another MS product ever again.
    Thorgal Aegirsson likes this.
    08-17-2016 12:25 AM
  17. illpoetic's Avatar
    Too bad.. I love mine.
    08-17-2016 04:31 AM
  18. X0LARIUM's Avatar
    I spoke to Microsoft Support. They suggested I do a clean flash from a USB, hopefully eliminating the issue. Now what he said next, made me a little uncomfortable. He said we will replace it, BUT, the replaced device MAY NOT be a brand new device. I don't know why and I don't know how. Because it makes absolutely no sense in giving away my one month old device for a second-hand/refurbished piece, that too at the price of a BRAND NEW one.

    What do you guys think? Is it how it is?
    08-17-2016 06:51 AM
  19. excalibur1814's Avatar
    Just return the device and try to get a refund.

    You might want to check the Apple support forums as their devices also have issues. Good luck.
    08-17-2016 10:20 AM
  20. mike-berry's Avatar
    I honestly think you should go back to your iPad mini.

    My suggestions are:

    What browser are you using?

    Which Skype application are you using?

    What playback application are you using?

    Maybe using a full fledged OS is too complicated for you.

    I love my surface to death.
    08-17-2016 04:00 PM
  21. becosemsaida's Avatar
    I honestly think you should go back to your iPad mini.

    My suggestions are:

    What browser are you using?

    Which Skype application are you using?

    What playback application are you using?

    Maybe using a full fledged OS is too complicated for you.

    I love my surface to death.
    Are you stating that your Surface doesn't have problems?? Please help us all out ??? If i knew that a product from microsoft, leader in the OS and App bussiness, was such a piece of........ for sure i would have waited for something else, huawei matebook or even the Samsung Pro . IOS is a system that i NEVER buy or use again that's for sure.

    Beco
    X0LARIUM likes this.
    08-17-2016 05:13 PM
  22. mike-berry's Avatar
    Are you stating that your Surface doesn't have problems?? Please help us all out ??? If i knew that a product from microsoft, leader in the OS and App bussiness, was such a piece of........ for sure i would have waited for something else, huawei matebook or even the Samsung Pro . IOS is a system that i NEVER buy or use again that's for sure.

    Beco
    Actually my surface doesn't have any problems and I use it quite heavily for school. My gaming laptop and my gaming computer have problems on the other hand. I just try to fix things and research about it before I complain. There's nothing in this world that exists without problems.
    anon(8532178) likes this.
    08-17-2016 06:49 PM
  23. X0LARIUM's Avatar
    Ok guys, let's just calm down a bit. It is an electronic device and things are bound to go wrong. Something goes wrong for you, may not for me. In my case, it is a very peculiar issue.
    Now here is what I have done, as per the Microsoft Support:

    Flash WIN10 through a USB from the link they provided. I did just that.

    And what happened?

    The device is working absolutely fine. The driver issue is gone.

    BUT

    This is NOT the anniversary update but the version I had got with my Surface a month ago.

    Which I am fine to use. I am going to test this out, install apps and everything. And then update again to anniversary update next week to see if the issue still persists.

    MS has agreed to give me a replacement, just that the guy said, "It MIGHT NOT be a new device." Which to me is totally unacceptable. In that case, I will ask for a refund.

    Now coming to the Apple vs Microsoft part.

    Guys I am a member of this forum from the last 6 years. I LOVE MICROSOFT to DEATH too. But don't get me wrong. This product doesn't work. At least for me. And I expect you guys to accept it the way it is. I have no personal vengeance against MS. I love them a lot. But if you are going to take my money and give me something that doesn't deliver, I don't think you deserve my hard earned money.

    It is just that. Am I angry? Yes, very angry. Am I going to invest in Microsoft again. Yes I will. Why? Because this is a very peculiar SOFTWARE glitch. It needs to be rectified. That's all. And yes, while my uber cool Surface has been lying around without sound, I have been using my 6 year old iPad Mini that TILL DATE WORKS LIKE A CHARM. I have no shame in saying that here.

    Let Microsoft produce a product like that, we will debate it then. Until then it is:
    iPad Mini (6 year old) - 1
    Surface Pro 4 - 0.
    08-18-2016 02:57 AM
  24. excalibur1814's Avatar
    My beef is due to the thread title. It literally screams 'notice me'. We all come here for help, not to be special and loved. ALL devices can have issues and, these days, it's to be expected to a certain point.

    Also being ' extremely angry and upset' is a bit much. Blood pressure... be healthy :)



    Anyway, in the end, I do hope that you're happy as that's the main thing.
    08-18-2016 05:28 AM
  25. becosemsaida's Avatar
    For now i have my Surface working and the only problem is that it's freezing without notice or "overcharged" with apps. No clockspeed at fixed values, no overheating or other problems. Although i notice that my batt is not holding up as it should (4 hours) i think i am starting to get this solved. Unfortunatly this is the work for MS to discover what is wrong with this device and not ours !!! I have the Surface for about 3 months now and it hasn't been working as it should yet.

    Anyone knows how the batt is monitored and charged? Want to check how it is done.........

    Beco
    08-18-2016 07:54 AM
75 123

Similar Threads

  1. USB Fan for Surface
    By bulls96 in forum Microsoft Surface Pro
    Replies: 2
    Last Post: 10-06-2016, 11:33 AM
  2. Why cant I install the latest update on my lumia 730?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 09-29-2016, 09:18 AM
  3. The ASUS Zenbook UX303UA is only 400 on Amazon!
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 09-28-2016, 08:30 AM
  4. Microsoft finally reveals what was in the recent Lumia 550 and 650 firmware updates
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 09-28-2016, 08:30 AM
  5. How to take ownership of files and folders on Windows 10
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 09-28-2016, 07:11 AM
LINK TO POST COPIED TO CLIPBOARD