07-19-2020 03:06 PM
44 12
tools
  1. ccddd's Avatar
    Made an account just to say this worked! Rubber banded the power button down while it was plugged into power, plugged an Xbox controller into the USB port and it vibrated every 10 seconds for 15 minutes. When it stopped I removed the rubber bands and pressed the power button once again, and it turned on! Selected reset at the recovery option and it booted fine. This is probably witchcraft.
    pkcable likes this.
    03-20-2019 01:47 AM
  2. Jenzibah's Avatar
    OH MY GOD.
    Signing up to share my experience in case it's similar to a future reader, I certainly benefited from not only mikeychen's original post but also some of your replies to OP, THANK YOU!!

    Friday morning, I woke up to a blank Surface - wouldn't power on normally even though I hadn't done anything especially unusual. Possibly used it more than usual as I'm on an Easter break, and I might've hit Sleep rather than Shut Down the night before, which seems to be the case for other ppl in this thread! I think the charger was connected all night, but can't quite remember... anyway I had the charger in it soon enough, and it seemed to be charging fine seeing as the light was on continuously.

    Friday was spent trying various methods to wake it up (not including the freezer one, dayum that scares me). I tried hotkeys Win+Ctrl+Shift+B, tried Power button 30sec, tried Power button + Volume Up for 15sec, tried Volume Up + Volume Down rapidly together 3 times within 2s, tried various combinations of above methods with charger on/off and keyboard attached/detached....... no effect. The screen stayed black and no logo or anything flashed up on it, not once. The only response I got was when I held the Power button down: the charger light would flash every 8 secs or so. I timed that with a stopwatch over 2 days and it was consistent... more on that later.

    I was on the phone with a techo at one point, and he asked me to plug in a USB and press Volume Up for a few secs... nothing happened and he asked me to press Volume Down instead... still nothing happened. He seemed to be testing for whether the laptop was still "alive" - if so, it would apparently flash something up while pressing Volume Up/Down with a USB in. It didn't look good. But I still had a bit of hope because of that charger light being on! Also, the keyboard backlight flickered very briefly once or twice when I was trying things over the 2 days, though it was definitely dormant most of the time.

    Googling solutions, I thought my last shred of hope was a USB "image" boot which I'd leave to the PC doctors... until I came across this thread. With newfound energy around 10am on Saturday, I wrapped a rubber band around my surface (keyboard attached) using a chopstick to hold the Power button down, and left it with the charger connected. Checked after 20 mins, no change. Checked after 5 hours, also no change! Such disappointment! The charger light continued to blink every ~8s as the Power button was held down, and when I opened up the laptop nothing happened, nor when I pressed Power or re-attached the keyboard or tried the Power/Volume Up combo again. I was losing hope, but thought I'd try the same solution overnight.........

    Around 6pm Saturday, I left my surface in the same configuration as above (except using an eraser instead of a chopstick this time to ensure grip, though I'm 99% sure the chopstick did fine last time). I went out to a dinner then came back and went straight to bed because frankly I could barely stand the sight of my surface anymore!

    At about 4am I woke up, probably because I'd slept so early, and while dozing half-asleep I noticed some flashing at the corner of my eye. I sat up and looked over to see my surface, then realised it must just be that damn charger light. I was about to sink down again when the flashing suddenly stopped! A continuously light emanated from my quiet machine. Then I spied the *Power* button lighting up briefly beneath the eraser!! After jumping out of bed, I carefully removed the rubber band contraption and opened up the laptop, charger still connected. I pressed the Power button and... TA-DA!!!!! Logo appeared and Surface started up as normal!!

    Currently breathing a sigh of relief over my newly backed-up data, and reflecting that it is important to fight the despair and not lose hope unless you've really tried everything!
    HeyCori likes this.
    04-27-2019 09:56 PM
  3. bruckit's Avatar
    I want to add something to this discussion because this trick did not work for me. But what did was just as crazy. Credit goes to a person on youtube. Mine would not turn on entirely dead but light showed it would charge.

    I applied pressure to the center of the back of the surface and it was able to turn on. if i let go of the pressure it cut off right away. I flipped it over and pressed firmly on the back of the surface maybe ten to fifteen times. I flipped it over and its been perfect for going on a week now. There must be a connector that comes unseated that can be fixed with pressure in the right place.
    HeyCori likes this.
    05-01-2019 12:35 AM
  4. GerardSamija's Avatar
    Signed up to add my 2 cents. Bought a Surface Pro 3 256GB/8GBRAM device last month, slightly used. It had been upgraded from 8 to Windows 8 by the user, wiped clean before the transaction. It performed admirably for a few weeks, a night and day difference compared to my previous 2GB Surface which just crashed constantly due to inadequate memory. Media editing, browsing, movies, whatever I threw at it, however many apps I had open, zero problems. Which was impressive as tablets have always given me more trouble than this in the 10 years I've been using various models.

    Yesterday I left my office to hang out with my family for a couple of hours. The Surface had my email app and Firefox open, nothing heavy. When I went back and tried to wake it up the screen stayed black. The white LED on the charging connector blinked off momentarily about every 8 seconds. After a bunch of searching from my phone I found this discussion. Of course I'd tried the official Microsoft fix with timed button presses... and of course that did nothing, a couple of dozen times in a row. As I discovered by plugging in an external spinning drive, the thing was rebooting every 8 seconds. Not a screen driver problem. But after reading these two pages I put a wedge of wood on the power button (angled to compensate for the slant of the device edge) and used a woodworking clamp to hold that against the power button. Tried taking that off about 2 hours later but no difference, so I put it on for another couple of hours.

    Just before sleep I took a look and found that the LED had stopped blinking! So off came the clamp and wedge again, pressed the power button, nothing happened. Pressed it several times in rapid succession and 'SURFACE' appeared on the screen and the device booted successfully.

    So I set about copying out all my latest files to an external drive. About 2 minutes into that file dump the screen went black again and the drive stopped spinning suddenly. Pressing the power button started a normal boot. Tried again, crashed again... So this time I followed what someone here suggested; changed sleep behaviour in power settings such that on external power it never times out. After that I had no problem copying out 8GB or so of files. In the morning the screen was still on, no change.

    I haven't rebooted since. Bit afraid to. I've downloaded the official recovery package and put that on a USB stick, in case I have to do the desperate thing and wipe to factory spec, but I'd really prefer not to have to put in the days and days of work customizing this thing. Prior to this disturbing event yesterday I have to say this was the most stable and functional computer I've ever had in 20 years, though an ASUS EEE running Windows 7 Ultimate N came close. This my second Surface in 6 months, and I like the design, but if this kind of nonsense keeps up I'll have to look to a different brand. Seems Microsoft might not be ready for prime time.

    But complaints aside, by all means anyone with this issue should try somehow or other clamping something on to the power button for some hours, as long as it takes. Sure beats sending it in for an expensive repair or replacement. Sure beats losing a bunch of files relating to one's life and business. I'm left wondering if this is related to a Windows Update, or what... but it seems Microsoft isn't remotely interested in answering such questions. None of their official forums comes close to resolving this as you guys have done.
    HeyCori likes this.
    05-01-2019 11:50 AM
  5. Seagull Tan's Avatar
    Hi all,

    I have created my account a while a go just wanting to express my thanks to mikeychen and let everyone here knows that the rubberband tricks worked on my Surface Pro 3, too! To add, I have kept my power button pressed overnight but around 5 yesterday (evening time), my adapter light still wouldn't stop blinking. I then thought of the 'CPR' method I came across (couldn't remember much details about the steps) and I decided to just press my palms against the back of my Surface a few times like doing a massage on it. Next, I stopped to observe and surprisingly found the adapter indicator light stopped blinking! I thought this should be the sign of revival and so I removed my rubber band and the toothpick I used to hold the power button down. With much hope, I then pressed the power button to try turning my Surface on. To my delight, this has really brought back my Surface to life!!! Thank God! I was so happy and quickly did a back up on my important folders/files. This has lasted since last evening and I hope it will continue working.

    I was still so down with my Surface suddenly stopped working a few days ago, especially after having tried so many other solutions posted online until I came across this forum that gives me hope of revival:( Thank you so much, mikeychen, for sharing your solution that has helped to save my Surface Pro! You a Star!*
    HeyCori likes this.
    05-05-2019 09:34 PM
  6. 8bXIhymk's Avatar
    Signed up to +1 this solution. A huuuuuuge thank you to mikeychen, I wish this thread was a more prominent result in related Google searches.

    Long story follows:
    Following installation of a firmware (supposedly battery management improvements haha!) and some OS updates on my SP3 the surface failed to restart. It then wouldn't power on at all. As above tried all the Microsoft troubleshooting procedures to no avail. Called MS support and their solution was to buy a new device. The device is backed up so no data loss but the response from MS is pretty rich IMO, given they continue to fiddle with the firmware on a "discontinued" device, so if they brick it for you you're SOL.

    Anyway with nothing to lose and having stumbled on this thread I tried the rubber band solution. I left the bubber band installed over night with the power cord plugged in. No luck. I then unplugged the power cord and tried again with a travel power pack plugged into the USB port, as the charging indicator on the power pack provided a more visible indication of the cycling of boot attempts than the LED on the SP3 charging cable. I was also hoping to eventually drain the SP3 battery flat on the theory that might reset something that was stuck in an odd state.

    Eventually the surface stopped trying to restart (as evidenced by the charging indicator on the power pack staying blank). I unplugged the power pack, removed the rubber band, pressed the power button on the surface and Hey Presto! Back in business. First task: create a new backup!

    My theory is that the cause is some sort of error with the battery management system (BMS), either as a result of a firmware update (my case) or it reading/setting an e.g. out of spec value for some reason. On attempting to boot the BMS sees that things don't match up and refuses to allow the system to boot. While dead, on my system if I put my ear close to the side of surface near the USB port I could hear some coil/electronics whine on attempted startup as I guess the BMS checked the battery state, then it would power the system off after a few seconds. Continually trying to power on, or time eventually drains the battery to where it is "in spec" and the system is allowed to start. Then the BMS recalibrates itself. Or some thing like that! I wonder how many SP3s, or other models have been returned or thrown out that could have/have later been resurrected by this procedure?
    HeyCori likes this.
    06-19-2019 07:28 AM
  7. Nathanjjjj's Avatar
    Hi all,

    My surface just had the same problem, tried to start it up this morning with no success.

    Unfortunately I don't have the original charger and my new one doesn't show the led flashing as a few of you have mentioned above. I tried the rubber band method for a few hours whilst out, but came back to the same black screen staring at me.

    I wanted something to show me the tablet had some power inside and was not completely dead so I plugged my phone into the USB port, it would charge for a number of seconds then go off for the same amount and then charge again. After a few cycles of this (keeping the power button pressed) the surface logo appeared
    ½
    ¹Œ

    In my opinion the insertion of a usb with device attached forces the battery/ laptop out of the sleep function.
    HeyCori likes this.
    08-07-2019 12:38 PM
  8. Benj Medina's Avatar
    Had a similar problem wherein when I got back from work, my SP3 just won't turn on anymore. It was a scary moment to be honest, just bought this refurbished unit last Feb. 2019 so I was really close to possibly regretting that decision. I'm using a similar unit for work for much longer now but never had any issue like it before; that's why I opted to buy one for myself.

    Like most of us here, I tried to start it up using various button combinations but it just starts for about 5 seconds and it shuts down again. I had an idea to boot it up from a usb but of course that didn't work. I was close to giving up until I found this thread. The solution seems absurd but it worked!

    First try was just a few hours it didn't work, then I left it for pretty much a day while being plugged in and after removing the rubber bands (I used the flat and thick ones; four of those) it worked! It asked for an automatic repair procedure and I selected the default one. During it, it came back to the previous state at some point but I did notice seeing the normal login screen before it stopped failing to start again. I was kicking myself thinking that I should have selected one of the advanced options.

    At this point, the rubber band solution is a guarantee to work for me so before I went to bed, I had it wrapped again then the next morning, it's back up and running normally now.

    I have a hunch that during a windows update installation, the battery ran out i.e. interrupting the process that could have caused that malfunctioning. Also took the advice of not having the auto sleep mode enabled anymore; maybe it's really for the best.

    Thanks a lot for this!
    HeyCori likes this.
    08-23-2019 12:00 AM
  9. eek3M8's Avatar
    Same story as everyone else. SP3 sitting a closet for over two years. After 26 hours of having the the power cycle every 8.5 seconds, i got a solid light on the charger. I also had a xbox controller plugged in via USB that would vibrate every power cycle like another user suggested. It took almost an hour to get from the Surface logo to File Explorer populated with folders, but after subsequent reboots and updates it is back to normal speed.

    Thanks so much to the OP and all who contributed their stories of success after. No way I would have ever thought that it would need to be held down for over a day to trigger whatever caused it to come back to life!
    HeyCori likes this.
    09-05-2019 08:25 AM
  10. surfaceuser's Avatar
    I created an account just to say thank you for your crazy rubber band idea--- it worked!

    I used my surface pro 3 the other day, everything was normal and i hit the power button to put it to sleep. After that it would not turn on. No logo, no signs of life (except for the charger was lit up. I tried all of the power down/power up combinations multiple times. Found this forum, rubber banded the power button for over 5 hours, took off the rubber band and let it sit for a bit, hit the power button, and voila right back to life! I thought it was a gonner before trying this trick, so thank you from the bottom of my heart!
    Laura Knotek likes this.
    10-31-2019 09:27 PM
  11. asteroid7687's Avatar
    Same here - just created an account to say THANK YOU!

    My Surface Pro 3 was rendered useless for some months now, tried ALL the tricks with all thinkable button combinations, pressure from the back and so on, screen remained black...
    Then I discovered this thread and gave it a try. Before I would do the rubberband overnight trick I tried to hold the power button manually. The power light did the well-known little flash every 8 sec and after 12 minutes the Surface logo appeared and everything turned back to normal!
    So - thanks again! :)
    11-21-2019 04:03 PM
  12. Michael Gitkos's Avatar
    My sister-in-law bought a used Surface Pro 3 based on my recommendation a few months ago, and a few weeks ago, it started having the same problem. She tried everything she could find, and so did I. This was a last resort, and took WAY too much digging to find this thread. Put the rubber bands on, and after about 36 hours or so, the light was finally solid. I was afraid the rubber bands might've just stretched out / got loose (was pessimistic because this felt too good to be true).

    Remove the rubber bands, opened the cover, and 1 click of the power button and it booted up! This is the most bizarre fix I've ever seen. Thank you, OP! You're a life saver!
    01-09-2020 10:34 AM
  13. mkinoax's Avatar
    Confirmation with a slight variation
    [TL;DR (updated): had to repeat process at least 4 times, sometimes for more than 10 minutes. Once it seemed having phone plugged into charge would help, but this was not consistent.]

    Same symptoms. Same despair. Same luck that this thread now appears among the top Google results.

    I didn't even get to the rubber band stage. I was reading every post in the thread and decided to hold down the power button while having my phone plugged in (as Nathanjjjj suggested a few posts up). After about two minutes and no change, I figured this cycling wasn't great for my phone, so I plugged the USB. But I still had the power button down the whole time. Very shortly thereafter, the cycling of the charger light stopped and the Surface booted up.

    Coincidence? Perhaps. But I figured I'd throw it out there. Any serious experts have an idea of the root cause, especially if the ziploc-and-freezer solution also actually works? Thanks to all!

    UPDATE: Surface ran for 10 minutes before dying again. Further sessions holding down power button varied in length, but seemed to be getting longer. Once, holding it down for 5 minutes, "Surface" logo popped up and I let go. The screen froze and I had to start again. For these sessions, I didn't find plugging in or unplugging my phone made a consistent difference. I ultimately used rubber bands and left for 20 minutes, started it up after the charging light was no longer blinking. It's been running well now for over an hour. Fingers crossed it hangs on long enough for a thorough backup.
    Last edited by mkinoax; 01-11-2020 at 03:40 PM.
    greekbecky likes this.
    01-11-2020 10:57 AM
  14. greekbecky's Avatar
    I'm at my wits end, none of the fixes worked for me. This is my 2nd Surface Book 2 (the 1st only lasted 2 months with the same issue, before they replaced it with this one). Like others, I can't get the PC to start. When the power is attached, it shows a steady, solid connection, the light is on and not flashing intermittently every 8 seconds as others have reported. I've tried the power/volume hot fixes, put the tablet in the freezer, applied pressure to the back of the tablet as one guy did to get it to start, heated it with a blow dryer and yesterday, tried the rubber band over the power button trick (with keyboard, adapter and phone in USB attached)...no luck. All my data trapped in this worthless box that cost me $3K+ and Microsoft couldn't care less about it. In fact, when I went to the Microsoft store, I was cordial, but I knew they wouldn't do anything except offer me the $600 refurb replacement and lose your data offer. When there are pages of folks that have this same issue and the employees claim they never get people coming in with the problem, it saddens me to think how little they care about us as consumers. As I walked out, I hear the two employees laughing...what a feel good moment. Before I throw in the towel, I figured I'd ask if anyone had any other potential tricks to get this thing to start. They guys at the store told me there are folks out there that can save the data, but it will destroy the machine (which I'm good with at this point). Sorry for the long note, but I know you all felt this desperate at one time.
    03-12-2020 12:56 PM
  15. allen0411's Avatar
    Hi,
    I created this account purposely to reply :)

    Just wanna ask... if the LED didnt light up when i pressed the power button,, does the rubberband solution doesn't work for me T_T ?
    Mine is Surface Book 2..
    04-16-2020 04:58 AM
  16. allen0411's Avatar
    I faced the same problem!!
    Mine showed a flat battery icon mark when start up, and in a few seconds, black out.
    Now.. it's not even showing the icon...

    Everyone was asking, why such an expensive PC can spoilt so easily without any way to repair it?
    Desperate and frustrated.
    04-16-2020 05:00 AM
  17. JWKATL's Avatar
    Yet another person who created an account just to say that the rubber band trick worked, so thank you to mikeychen for posting and others for confirming!

    Backstory: my wife's SP3 worked 2 days ago. When she went to use it today it would not turn on. She plugged it in thinking that the battery might be dead, but that didn't help. She then tried all of the power button / volume button recommmendations, but those didn't work either.

    After finding this thread I had her try the rubber band. First step was moving from her replacement charger to her MicroSoft charger. The MS charger blinked as others described, but the replacement one did not. After about an hour with the rubber band on the power button the charger LED remained solid (without blinking). She removed the rubber band and the device turned on. She is now double-checking all of her backups to ensure they are good, but we are glad that we may not have to buy her a new laptop in the middle of COVID-19!!!

    Thank you again to everyone who posted their success. And for those for whom this trick has not been successful, I offer my condolences. I wish I knew other tricks to try.
    HeyCori likes this.
    05-04-2020 12:29 PM
  18. J S 2020's Avatar
    I also created an account in this forum just to share my experience and would like to thank everyone who shared their troubleshooting experiences and insights here to help me fix my issue. (Scroll down to the end for summary.)

    I came home from work and tried to turn on the SP3 and it just would not turn on. In the past, the soft-reset and/or force shutdown have worked to fix the issue.

    After reading on Microsoft support forums and LifeWire about what to do if the SP3 just won't turn on:
    1. I made sure that the SP3 was plugged in and charging with the white LED light lit on the cord. Then let it sit for 15 minutes or so. I was positive that the battery could not have just died completely while I was at work for 8 hours... but just in case.
    2. I tried the soft-reset method (hold down power button for 10 secs, release button, and press power button again). That didn't work.
    3. I tried the force shutdown method (hold down power button for 30 secs, release button, then press and hold both the power button and volume up button for 30 secs). That didn't work either.
    4. I don't have a connected keyboard and was unable to attempt to turn it on with the Windows+Ctrl+Shift+B keys. However, I tried the volume Up/Down numerous times. That didn't work.
    5. I disconnected accessories from SP3 and tried to turn it on normally. All I had was a microSD card. That didn't work.

    I tried all the steps above several times without any success.
    By this time, I did noticed that while I was doing the soft-reset or the force shutdown method, the white LED light on the power did turn on/off accordingly. I was worried that the screen hardware may have failed. After all, the tablet is 5 years old.

    Then I found this forum here and read about the rubberband resurrection method, the CPR method, and the USB wake method:
    6. I wasn't ready to try the rubberband method just yet since it would take hours to complete. I would do it as a last resort. I simply pushed on the the power button as hard as I could for maybe about 2-5 minutes hoping that it would clear a stuck button of some sort in there. That didn't work.
    7. I gently tried the CPR method, not knowing how hard to press on the screen and the back of the SP3. I only pressed hard enough to feel the bend on the screen or the back for a couple times. I even pressed around the corners and edges just in case. Tried to power it up and nothing.
    8. Then there was the USB wake method. I don't have an Xbox controller and couldn't follow this route. Then I remembered that I have a USB gamepad around and I figured that maybe I can use it as a substitute for a USB keyboard instead. At the very least, the buttons would simulate some keystrokes of a keyboard. I plugged it in. (I did remember that the white LED light on the power cord was lit while I was doing this.) I pushed all the buttons and arrow keys on the gamepad as if I was entering a secret code into some entertainment consoles like back in the day. Nothing, the screen remained black and dead silent. Then about 5-10 seconds later, the Surface Pro logo was displayed. There was a message saying not to turn off the system as it was trying to complete the Windows update. Once that was done, the login screen was displayed normally.

    I figured that while I was away, the system did an update and somehow the process got stuck. The USB wake method shared from this forum woke the tablet and allowed it to complete its update. It saved me $500-$600 from paying for a replacement. Even though it took me about 2.5 hours to get the SP3 back up, I now feel everyone's pain when their Surface tablets won't turn on. Hopefully, this tablet will last me a couple more years before I have to get a replacement.

    Summary: Try plugging in a USB cord connected device such as a gamepad, Xbox controller, mouse or even a cell phone to wake up the SP3.

    Update:
    The day after, the same thing happened again. I tried to use USB cord connected device and it still wouldn't work. This time I used the rubband resurrection method and it worked after about 4 hours. I was able to save all my data. I also updated the BIOS to allow for USB boot in case I needed to take this route in the future (it was disabled). I suspected that there is an issue with the wake from hibernation process. I disabled the hibernation function and so far it has worked well. That night right before powering down, it performed another Windows update. I was a little worried and wondered if a recent update caused this issue. The next day I turned on the SP3 and it powered up just fine. So far, no further issues.

    Summary: Use the rubberband resurrection method and disable the hibernation function on the SP3.
    Last edited by J S 2020; 05-28-2020 at 02:01 PM.
    HeyCori likes this.
    05-26-2020 04:57 AM
  19. Brant Stalzer's Avatar
    To echo many others: "I also created an account in this forum just to share my experience and would like to thank everyone who shared their troubleshooting experiences and insights here to help me fix my issue."

    The difference for me was I have a Surface 2 which had gone into "family use" and suddenly exhibited the behavior.

    After trying all the usual boots (30 seconds power, volume up + power), I had a backlight flicker one time. USB peripherals demonstrated power on boot attempt, then shutdown a few seconds later.

    LED on power connector would stay solid white. Press power, it would blink once about 8 seconds later - about when the USB peripherals would shut down. So something in boot process was bailing, returning to shutdown.

    Used a pencil + big rubber band to get the LED cycle going. Probably took 2-3 hours before I saw no more blink cycle.

    I tried to press power and got a decent backlight for multiple seconds (progress!), then it shut off and seemingly back to bad behavior.

    Before putting back on the rubber band, I tried a 30 second reset, nope.
    I tried a power + volume up for 15, nope.
    I tried a power + volume down for 15, ... maybe?

    Don't know, because I also then flipped it over and gave it a moderate, soft-hard "massage" as I had noted that mentioned.

    When I flipped it over, Surface with the dots going, so it was booting at that point.

    It could have been either of the volume methods, the massage feasibly? helped a connection.

    But I am highly confident the power state of not having the blink cycle helped get in line to get things working again.

    I'm copying anything important, and there was a waiting Windows Update that people had been "sleeping" on, so I'm monitoring it through that. (Win 10, 1903)

    Summary: Use the rubber band resurrection method and disable the hibernation function on the SP2.
    07-19-2020 03:06 PM
44 12

Similar Threads

  1. My 640 says my memory card is unavailable
    By Mikepoint in forum Ask a Question
    Replies: 2
    Last Post: 04-13-2017, 08:50 AM
  2. Windows 10m and Windows 10 on ARM
    By Eduard Vlad Ilie in forum Ask a Question
    Replies: 3
    Last Post: 04-12-2017, 02:45 AM
  3. there is no windows 1 mobile update for my lumia 730? its april 2017
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 04-09-2017, 06:56 PM
  4. New Surface design patent suggests Microsoft is considering USB Type-C for power
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 04-09-2017, 03:30 PM
  5. Additional Surface Dial features in Creators Update?
    By joe_s in forum Ask a Question
    Replies: 0
    Last Post: 04-09-2017, 11:57 AM
LINK TO POST COPIED TO CLIPBOARD