1. SymoClod's Avatar
    I took delivery of a brand new SP7 (i5/8gb/256gb) yesterday. I signed in and let in run numerous updates for windows and firmware and then the quick update to 1909. All seemed fine. I installed Office and all was fine for half an hour.

    Suddenly the screen went black. I initially thought that it had shutdown due to some thermal issue as the back of the device was quite hot. I left it alone for an hour to cool and came back to it.

    I tried to restart it but, on pressing the power button all I get is the Windows/Surface logo for a second and then it goes black again.

    I've tried forcing a full shut down by holding down the power button as recommended in Microsoft support but no difference. Tried to get it to boot into Safe Mode but nothing. It's effectively dead.

    Microsoft have been pretty good and are sending me a replacement by Express Delivery.

    I'm wondering if anyone else has had the same problem. I have seen a few reports online of something similar although those all seem to relate to the i7 model and those affected seem to be able to restart by pressing the power button twice (doesn't work for me) albeit that the problem seems to re-occur for others. They seem to think it's a graphics driver issue.

    Anyone had a similar experience? Hopefully the replacement will be ok.
    11-26-2019 06:35 AM
  2. Indistinguishable's Avatar
    And you've tried all of this while giving it a full charge, right?

    I'd say it's time to process a warranty exchange for a defective device.
    11-26-2019 11:23 PM
  3. HeyCori's Avatar
    I didn't have the screen go black but I did have a different issue. Granted I have the i3 with a different gpu, nonetheless, it appears to be driver related. After waking from sleep, the color profile was slow to load. I thought maybe it was because the device wasn't ready for 1909, but going back to 1903 didn't help. I tried reinstalling the drivers from Microsoft's website that matched my build (msi package 18362) but that didn't work. Then I installed package 17763, which is technically not the build I'm on, but it worked. I do have another bug where if I set the brightness to 0, it will shoot back up to 100 even though the bar still says 0. However, it's not like I ever set it to 0 unless I'm in an extremely dark room. And even then I can use like 5 instead of 0.
    Laura Knotek likes this.
    11-27-2019 08:48 AM
  4. SymoClod's Avatar
    Well I have had the replacement for a day and it seems fine. I did actually turn it off for a while after installing the initial Windows and firmware updates this time as it was damn hot again and I'm still suspicious that that might have been the original problem. I know this is a new intel chipset and architecture and the i5 is fanless so I hope it is not going to be a recurring problem. That said, now that everything is updated and installed, it is running perfectly cool in general use.

    Having had a chance to use it a little I'm quite impressed with it - the instant resume is really impressive and the wifi speeds, particularly when transferring files, are greatly superior to my old SP4. It's also noticeably speedier than my old SP4 which was an i7 model.
    @HeyCori - with regards to the brightness issues you mentioned, I did come across a few other people with the same problem whilst researching my own problem so it seems you are not the only one.
    11-28-2019 06:36 AM
  5. ski6's Avatar
    I have the same problem. Did you manager to recover stuff from your ssd?
    01-05-2020 10:30 AM

Similar Threads

  1. Tidal offering up Black Friday four-month subscription on the CHEAP
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 11-26-2019, 06:00 AM
  2. Samsung's ridiculously fast 1TB NVMe SSD is on sale right now!
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 11-26-2019, 06:00 AM
  3. My Samsung QLED Q60R TV is currently on sale for Black Friday
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 11-26-2019, 02:11 AM
  4. Windows Central for W10 and W10M not updating news, forums, etc.
    By Fandangarino in forum Site Feedback & Help
    Replies: 0
    Last Post: 11-25-2019, 10:34 PM
  5. Affinity Photo is the best damn Photoshop replacement, and it's on sale now
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 11-25-2019, 05:50 PM
LINK TO POST COPIED TO CLIPBOARD