1. victorba's Avatar
    I have two of the original Surface Pro tablets. I have had them both since new and they are configured identically software-wise (Windows 10 insider build 17093).

    I have had no problems with either one since new.

    I recently installed Build 17093 and any other updates that were provided, let them complete and rebooted. Both loaded and ran successfully. I then shut off the tablets.

    When I went to start up BOTH tablets, they are responding the same way, the Surface logo shows up as usual, goes away and then the Surface logo starts flashing on the screen at 3 second intervals.

    I have looked at the Microsoft solutions pages https://support.microsoft.com/en-us/...ry-wont-charge and https://support.microsoft.com/en-us/...art-on-surface.

    I also tried allowing them to run their batteries out, then retrying the solutions from Microsoft, again without success.

    I have tried all of their offered solutions without success. BOTH tablets remain unusuable, flashing the Surface logo at 3 second intervals.
    02-13-2018 08:17 AM

Similar Threads

  1. Touch Issue (Problem) with my Surface Pro 2 in Windows 10 Pro 1703
    By aliveli4950 in forum Microsoft Surface Pro 2
    Replies: 3
    Last Post: 10-18-2018, 09:30 AM
  2. Lumia 735 - Win 10 - New Battery not charging correctly
    By Andreas Pazureck in forum Nokia Lumia 730 & 735
    Replies: 2
    Last Post: 06-03-2018, 06:24 AM
  3. Microsoft Surface Tablet Pro 2 Vibration and associated humming
    By flash54 in forum Microsoft Surface Pro 2
    Replies: 4
    Last Post: 02-11-2018, 05:44 PM
  4. Changing the resolution of Windows 10 Mobile
    By kaktus1389 in forum Windows 10 Mobile
    Replies: 4
    Last Post: 02-08-2018, 04:11 PM
  5. Windows 10 build 17093 for PC: Everything you need to know
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-08-2018, 04:10 PM
LINK TO POST COPIED TO CLIPBOARD