1. pavlovscow's Avatar
    Hey everyone,

    i just upgraded to windows 8.1 for my surface rt, which I hadn't used in a while. When I go to Facebook.com in ie, it forces me to the mobile site. No one else is complaining about it. Is there a setting in ie to appear as a mobile device I can toggle? Am I missing something?
    10-04-2013 02:26 AM
  2. SlickShoesRUCrazy's Avatar
    Hey everyone,

    i just upgraded to windows 8.1 for my surface rt, which I hadn't used in a while. When I go to Facebook.com in ie, it forces me to the mobile site. No one else is complaining about it. Is there a setting in ie to appear as a mobile device I can toggle? Am I missing something?
    I've been running 8.1 on my RT since the preview was available and just a few hours ago my RT started doing the same thing. Facebook only loads mobile version for some reason in the browser. It was working just fine this morning and loading the desktop version.

    I had a weird message saying I need to activiate java script or something, and the next time I returned to facebook, mobile version only loads. Even more annoying I can't find a way so that it loads the desktop version.
    10-04-2013 04:05 AM
  3. anon(5334066)'s Avatar
    10-04-2013 07:18 AM
  4. Tas33's Avatar
    This just started happening on my Surface RT as well yesterday (10-3-13). I've been using my Surface since it was released, and installed the 8.1 update months ago, and never had this problem before. Nothing changed, I didn't even reboot the Surface, and this started occurring. If anyone knows how to fix this, I'd be appreciative! I really dislike the mobile facebook site, particularly when I'm not on a 3-inch screen!
    10-04-2013 07:37 AM
  5. martinmc78's Avatar
    Same here - only an issue with facebook though, every other website still loads properly. Even happens if you use IE in desktop mode.

    Its quite annoying especially as there is usually an option to change to full website somewhere but even that seems to be missing.
    10-04-2013 07:37 AM
  6. martinmc78's Avatar
    Found a possible solution

    Using desktop IE, go to http://www.facebook.com/home.php which should display the full site with a warning then display IE menus (press alt) and Tools, and into compatibility mode - facebook.com should be highlighted. Add it to the list for compatibility mode. It should then mostly work for both Metro and Desktop IE when you visit Facebook.
    mattcald, yaouank, HeyCori and 2 others like this.
    10-04-2013 07:46 AM
  7. Michael Alan Goff's Avatar
    I don't seem to run into this problem.
    10-04-2013 08:12 AM
  8. Vallos's Avatar
    Hey everyone,

    i just upgraded to windows 8.1 for my surface rt, which I hadn't used in a while. When I go to Facebook.com in ie, it forces me to the mobile site. No one else is complaining about it. Is there a setting in ie to appear as a mobile device I can toggle? Am I missing something?
    Thank you for starting this thread. I thought it was just me.

    Found a possible solution

    Using desktop IE, go to http://www.facebook.com/home.php which should display the full site with a warning then display IE menus (press alt) and Tools, and into compatibility mode - facebook.com should be highlighted. Add it to the list for compatibility mode. It should then mostly work for both Metro and Desktop IE when you visit Facebook.
    Thanks, but it did not work for me.
    10-04-2013 09:28 AM
  9. SlickShoesRUCrazy's Avatar
    Definitely seems to be facebook is the problem. now its telling me to upgrade from ie8 haha.
    10-04-2013 10:07 AM
  10. Vallos's Avatar
    I am able to get full browser on my phone and work computer, but not on my Surface
    10-04-2013 10:22 AM
  11. curseoftheninja's Avatar
    Same thing here. I sent a bug report to Facebook. It also seems like every site with flash is telling me my flash is not up to date.
    10-04-2013 11:43 AM
  12. Sean Steele's Avatar
    your suggestion worked perfectly, but I had to log out first, then manually type the address in. Compatibility view did the trick! thank you
    10-04-2013 12:36 PM
  13. Michael Alan Goff's Avatar
    Definitely seems to be facebook is the problem. now its telling me to upgrade from ie8 haha.
    Compatibility mode would make it look like IE 8, iirc.
    10-04-2013 03:49 PM
  14. HeyCori's Avatar
    Was coming here to ask about the same thing. Did the trick above but now I have a banner asking me to upgrade my browser. Not having a problem like this with any other sites or devices. Must be a Facebook thing.
    10-04-2013 05:40 PM
  15. Christian Kallevig's Avatar
    Yeah, this is happening to me as well. It's extremely frustrating and kinda pathetic that Facebook is now more usable on my phone than on my Surface.
    10-04-2013 10:47 PM
  16. Undead_Steve's Avatar
    Still happening for me as well on my Surface RT with 8.1 Preview - I assume it's something changed on Facebook's end, since it worked just s few days ago.
    I'm curios whether this is will happen once we get the 8.1 RTM on our Surfaces in 2 weeks.
    10-05-2013 06:04 PM
  17. prlundberg's Avatar
    Same thing happened to me. Working now in compatibility mode.
    10-05-2013 07:15 PM
  18. dhyna143's Avatar
    I'm using RT 8.1 as well, but the compatibility view didn't work for me neither. I tried these steps and it worked for me.

    1. Use CHARM to search for 'Turn windows features on or off' and SELECT it.
    2. Windows Features window will open with a list of folders. Uncheck folder 'Internet Explorer11' then OK. It will ask you to restart.
    3. RESTART your device.

    Once you logged back in, repeat the process but this time you'll put the check back for folder 'Internet Explorer11'. After you RESTART your device for the second time, open your IE and type the URL in the address bar such as facebook.com. You should not see the message anymore asking to 'switch browser' or something. I hope this helps.
    11-23-2013 03:55 PM
  19. dhyna143's Avatar
    Thank you for starting this thread. I thought it was just me.


    Thanks, but it did not work for me.

    I'm using RT 8.1 as well, but the compatibility view didn't work for me neither. I tried these steps and it worked for me.

    1. Use CHARM to search for 'Turn windows features on or off' and SELECT it.
    2. Windows Features window will open with a list of folders. Uncheck folder 'Internet Explorer11' then OK. It will ask you to restart.
    3. RESTART your device.

    Once you logged back in, repeat the process but this time you'll put the check back for folder 'Internet Explorer11'. After you RESTART your device for the second time, open your IE and type the URL in the address bar such as facebook.com. You should not see the message anymore asking to 'switch browser' or something. I hope this helps.
    11-23-2013 04:07 PM
  20. dhyna143's Avatar
    Was coming here to ask about the same thing. Did the trick above but now I have a banner asking me to upgrade my browser. Not having a problem like this with any other sites or devices. Must be a Facebook thing.
    I'm using RT 8.1 as well, but the compatibility view didn't work for me neither. I tried these steps and it worked for me.

    1. Use CHARM to search for 'Turn windows features on or off' and SELECT it.
    2. Windows Features window will open with a list of folders. Uncheck folder 'Internet Explorer11' then OK. It will ask you to restart.
    3. RESTART your device.

    Once you logged back in, repeat the process but this time you'll put the check back for folder 'Internet Explorer11'. After you RESTART your device for the second time, open your IE and type the URL in the address bar such as facebook.com. You should not see the message anymore asking to 'switch browser' or something. I hope this helps.
    11-23-2013 04:10 PM

Similar Threads

  1. Replies: 15
    Last Post: 11-26-2013, 02:28 PM
  2. Did T-Mobile stop charging voice minutes for calls over wifi?
    By HoosierDaddy in forum Nokia Lumia 521
    Replies: 17
    Last Post: 11-22-2013, 06:42 AM
  3. Facebook security error on wp8
    By dangerous_dave in forum Windows Phone 8
    Replies: 13
    Last Post: 10-10-2013, 08:03 AM
  4. Replies: 8
    Last Post: 10-05-2013, 03:01 AM
  5. Is Class 10 micro SD supported in lumia 820??
    By SaiKiran7474 in forum Nokia Lumia 820
    Replies: 4
    Last Post: 10-04-2013, 07:24 AM
LINK TO POST COPIED TO CLIPBOARD