1. haydenhew's Avatar
    I am having an issue when trying to boot a new Surface Rt off a Recovery Drive I had previously created. I follow the specified steps:

    1. Insert USB
    2. Hold down Volume down button
    3. Tap power button and release both buttons

    Everything looks normal, Blue recovery screen comes up, I choose keyboard layout, go through and tell it to "use a USB device". At this point the surface RT reboots and then just loops back through to the Blue recovery menu!

    Have tried different USBs with new Recovery data, multiple Surfaces, all with the same result! Am i missing something? Has anyone else seen this behaviour?
    11-04-2013 05:45 PM
  2. omgitsnick's Avatar
    After you choose a keyboard layout you need to tap on Troubleshoot instead of Use a device because it's already booting off from the USB. From there you can Reset your PC, which will also give you the option to repartition your drive.
    11-04-2013 07:07 PM

Similar Threads

  1. cannot save to skydrive
    By Ram Ben-Tuvia in forum Samsung ATIV S
    Replies: 4
    Last Post: 06-23-2014, 10:30 PM
  2. How does Games With Gold work on Xbox One?
    By coip in forum The Xbox Lounge
    Replies: 24
    Last Post: 11-14-2013, 09:42 PM
  3. Coming back to Windows
    By Pinchscape in forum New to the Forums? Introduce Yourself Here!
    Replies: 6
    Last Post: 11-06-2013, 12:35 PM
  4. Brand new nokia lumia camera issue
    By Newphoneissue in forum Nokia Lumia 620
    Replies: 5
    Last Post: 11-06-2013, 10:19 AM
  5. I've HAD IT WITH NOKIA HEADPHONES!!!!
    By carlosrdd in forum Cases & Accessories
    Replies: 6
    Last Post: 11-06-2013, 08:53 AM
LINK TO POST COPIED TO CLIPBOARD